Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

karlrais

Lumbridge CowHideKiller and Banker [ABCL10]

550 posts in this topic

why the (ef) won't any of these scripts (effing) run; it's been 2 hours. i've extracted moved, not extracted move, deleted zip files, incorperated zip files, done all these again after closing and restarting the client. Seriously.

Okay dude, I had the same problem as you but I figured it out. 

 

Make sure you download the CLASS files, not the source files. Don't extract or anything, just open up your .tribot > bin > scripts folder and when you download the CLASS files in winRAR just open it there and drag and drop all the class files into the script folder. Then when you click start script it will work. To have tribot log you in when you disconnect you just have to click View > Account Manager > Add and add the username/password to the account. Tribot is trusted and I haven't heard of people being hacked by tribot but if you're nervous only use bot for a new account like I am. 

 

On topic, I've only run the bot for 5 minutes so far but it's working perfectly, I will babysit the bot for the most part because cows are a high-ban rate area but it will make afking quite a bit easier lol. Thanks dude!

 

Will post progress reports after an hour of running, if Tribot itself doesn't freeze up. I've learned the biggest reason my bot will fail is that the actual client freezes for whatever reason, but that's no big deal. Just have to force close it and reopen it and we're back on our way. Not too worried about efficiency, though the script itself seems very efficient indeed.

Share this post


Link to post
Share on other sites

Updated the script!

 

Removed all hashmaps. This should fix some errors for some people.

Script will now ignore all hides and cows outside the fence.

SHOULD now run away from Evil chicken and Swarm (didn't get the change to test it).

Some other minor stuff.

Edited by karlrais

Share this post


Link to post
Share on other sites

Major-minor hotfix. Download links all work now.

 

EDIT: Hotfix to hotfix gg

Edited by karlrais

Share this post


Link to post
Share on other sites
[23:53:10] TRiBot (5.53_1) loaded. (1.6.0_45:/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home)

[23:55:09] Exception in thread "AWT-EventQueue-0" 

[23:55:09] java.lang.UnsupportedClassVersionError: scripts/CameraPitch : Unsupported major.minor version 51.0

[23:55:09] at java.lang.ClassLoader.defineClass1(Native Method)

[23:55:09] at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)

[23:55:09] at java.lang.ClassLoader.defineClass(ClassLoader.java:615)

[23:55:09] at java.lang.ClassLoader.defineClass(ClassLoader.java:465)

[23:55:09] at obf.yc.ALLATORI_DEMO(te:165)

[23:55:09] at obf.yc.ALLATORI_DEMO(te:142)

[23:55:09] at obf.lD.ALLATORI_DEMO(of:148)

[23:55:09] at obf.lD.ALLATORI_DEMO(of:23)

[23:55:09] at obf.ib.<init>(wn:177)

[23:55:09] at obf.NF.A(jp:195)

[23:55:09] at obf.tC.actionPerformed(vf:1465)

[23:55:09] at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2028)

[23:55:09] at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2351)

[23:55:09] at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)

[23:55:09] at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)

[23:55:09] at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:236)

[23:55:09] at java.awt.Component.processMouseEvent(Component.java:6382)

[23:55:09] at javax.swing.JComponent.processMouseEvent(JComponent.java:3275)

[23:55:09] at java.awt.Component.processEvent(Component.java:6147)

[23:55:09] at java.awt.Container.processEvent(Container.java:2083)

[23:55:09] at java.awt.Component.dispatchEventImpl(Component.java:4744)

[23:55:09] at java.awt.Container.dispatchEventImpl(Container.java:2141)

[23:55:09] at java.awt.Component.dispatchEvent(Component.java:4572)

[23:55:09] at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4619)

[23:55:09] at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4280)

[23:55:09] at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4210)

[23:55:09] at java.awt.Container.dispatchEventImpl(Container.java:2127)

[23:55:09] at java.awt.Window.dispatchEventImpl(Window.java:2489)

[23:55:09] at java.awt.Component.dispatchEvent(Component.java:4572)

[23:55:09] at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:710)

[23:55:09] at java.awt.EventQueue.access$400(EventQueue.java:82)

[23:55:09] at java.awt.EventQueue$2.run(EventQueue.java:669)

[23:55:09] at java.awt.EventQueue$2.run(EventQueue.java:667)

[23:55:09] at java.security.AccessController.doPrivileged(Native Method)

[23:55:09] at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)

[23:55:09] at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:98)

[23:55:09] at java.awt.EventQueue$3.run(EventQueue.java:683)

[23:55:09] at java.awt.EventQueue$3.run(EventQueue.java:681)

[23:55:09] at java.security.AccessController.doPrivileged(Native Method)

[23:55:09] at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:87)

[23:55:09] at java.awt.EventQueue.dispatchEvent(EventQueue.java:680)

[23:55:09] at obf.WB.dispatchEvent(sk:49)

[23:55:09] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)

[23:55:09] at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)

[23:55:09] at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)

[23:55:09] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)

[23:55:09] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)

[23:55:09] at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)

 

definitely the new files, not sure why this happens :/

Share this post


Link to post
Share on other sites

 

[23:53:10] TRiBot (5.53_1) loaded. (1.6.0_45:/System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home)
 
definitely the new files, not sure why this happens :/

 

It's because you are using java 1.6 while you need Java 1.7 32-bit version.

 

How to update?

Easiest way is to uninstall everything Java via control panel. Then go to http://java.com/en/download/manual.jsp and download the 32-bit installer. Then just double click and install and you should be good to go.

 

Or if you already have Java 7 installed or you don't want to uninstall anything check out this thread:

https://tribot.org/forums/index.php?/topic/471-ensuring-tribot-uses-the-right-java/

Share this post


Link to post
Share on other sites

high banrate area at the moment, i got a bot busting ban only for 2 days so all good :) just a heads up

Share this post


Link to post
Share on other sites

high banrate area at the moment, i got a bot busting ban only for 2 days so all good :) just a heads up

 

Sorry to hear that. You are the second person to report a ban. I really thought it's enough human like this time...

Share this post


Link to post
Share on other sites

Haven't gotten banned yet botting the past few days. Obtained nearly 8k cow hides. Thank you for the script!

 

I'm probably going to take a break from botting though because bot watch seems really brutal now.

Share this post


Link to post
Share on other sites

Alright guys I have updated the script!

 

Everything should work now, also added GUI so run in LITE mode until I get it working normally.

 

EDIT: Now works in lite mode

Edited by karlrais

Share this post


Link to post
Share on other sites

The bot doesn't move after you get an inventory full of cowhides =( Can you please fix it?

 

:s It sure does for me... I need more details. Can you post paint screenshot?

EDIT: Since you joined a week ago you are probably doing something wrong :P

Edited by karlrais

Share this post


Link to post
Share on other sites

:s It sure does for me... I need more details. Can you post paint screenshot?

EDIT: Since you joined a week ago you are probably doing something wrong :P

Seems that I downloaded the old version by mistake. Sorry about that. Works great!

Share this post


Link to post
Share on other sites

hmm i cant seem to get the script to work at all followed the instructions but it doesnt do anything after pressing start

 

nevermind i figured it out i didint actually have lite mode running that was why

 

i cant get it to run past like 10mins it just stops

Edited by CHIEFCHARLIE

Share this post


Link to post
Share on other sites

i cant get it to run past like 10mins it just stops

 

I just did 7h proggy with this.

 

To help you I need more information than "It just stops".

Edited by karlrais

Share this post


Link to post
Share on other sites

range support???

 

It does work, but it was designed for melee. Meaning it walks to target when it could just shoot with ranged. It sometimes spam click cows when it shouldn't with ranged.

Despite all that, it does get you to level 40 in few hours and you should never get banned in that time frame.

 

Ranged support coming if I find the time.

Edited by karlrais

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.