Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Usa

USA's Abyss Runecrafter [650K/HR+][ALL RUNES! 1-99][ABCL 10]

Recommended Posts

Either invest heavily in glory's (dont recommend this), or get (40?) magic so you can teleport with runes to your house and use the mounted glory (definitely get one of these).

 

1-44, elemental rifts will work fine.

hmm, maybe I"ll just do fire runes like that guy said until 44

 

edit: and this is my first purchased script in a long time - for $20 I have quite the expectations =p

Edited by Luke L

Share this post


Link to post
Share on other sites
Array

Sorry if this is a stupid question but how do I know the food ID's? My guy keeps getting stuck in the bank and just keeps moving teh camera angle up and down but I am assuming it is because he cannot find the right food. Thanks!

 

EDIT: Nvm I googled the ID and so far its working great! thanks!

Edited by BoremoreBirds

Share this post


Link to post
Share on other sites

Sorry if this is a stupid question but how do I know the food ID's? My guy keeps getting stuck in the bank and just keeps moving teh camera angle up and down but I am assuming it is because he cannot find the right food. Thanks!

 

EDIT: Nvm I googled the ID and so far its working great! thanks!

Hey just for future reference, you go up to the debug tab and then click "inventory". That will display the id of all the items in your inventory:)

  • Like 1

Share this post


Link to post
Share on other sites

Ok so I have a pretty big gripe this morning. This is mostly my fault, but my account will more than likely be banned after the first day of using this script.

 

Worked great yesterday, before I went to bed I stopped the bot and manually world hopped. started it back up and went to bed. Forgot that the GUI reset, so it went back to nature runes (dumb on my part).

 

The ridiclous part is that it went to the nature altar, and clicked on it (of course it said "You need to have 44 runecrafting to make those") FOR 6 HOURS. Chat log had many people saying "Report the bot, he's been doing this for 2 hours" etc.

 

are you kidding me? A $20 script doesn't even have a killswitch? Really? I'm no coder but I'd assume that it would take less than 5 minutes to code a killswitch if a bot is stuck in an infinite loop for more than 5 minutes.... really? $20 dollar?

 

Pretty disappointed..

Share this post


Link to post
Share on other sites

i allways use ring of life. Eventhough i allways have to reclaim my puches atleast 2 times a day.

How can you die 2x a day? Got like 10hp or something? <.<

 

@USA

You should do so instead of bringing the super energys with you and waste an invent space. The bot just heals to full energy @ bank, or do you lose more time/cash on that?

Yes

Share this post


Link to post
Share on other sites

Ok so I have a pretty big gripe this morning. This is mostly my fault, but my account will more than likely be banned after the first day of using this script.

 

Worked great yesterday, before I went to bed I stopped the bot and manually world hopped. started it back up and went to bed. Forgot that the GUI reset, so it went back to nature runes (dumb on my part).

 

The ridiclous part is that it went to the nature altar, and clicked on it (of course it said "You need to have 44 runecrafting to make those") FOR 6 HOURS. Chat log had many people saying "Report the bot, he's been doing this for 2 hours" etc.

 

are you kidding me? A $20 script doesn't even have a killswitch? Really? I'm no coder but I'd assume that it would take less than 5 minutes to code a killswitch if a bot is stuck in an infinite loop for more than 5 minutes.... really? $20 dollar?

 

Pretty disappointed..

You only have yourself to blame. Dont expect the Coder to put failsafes in for failure to follow simple instructions/setup, take your time next time.

 

anyone else getting stuck when bot arrives at nature alter? "Australian ping bad" - http://puu.sh/6KPrt.jpg

Next time you are sitting there, hit the "Print Script Stack Trace" under "Script" at the top of the client. Add any information you can find in the Bot Debug/Client Debug, I'll see if I can find anything otherwise yes it might be ping/hardware related as I have not been able to reproduce anything like this.

Share this post


Link to post
Share on other sites

^ I was thinking of buying this script till i saw your response usa I think your script should have a failsafe if it gets stuck and can't get out of a spot for more then 5 minutes weather it's the scripts fault or the person setting it up because there new to it... you just lost $20 customer by the way you treated luke l and the simple fact you didn't offer to put in a failsafe...

Share this post


Link to post
Share on other sites

You only have yourself to blame. Dont expect the Coder to put failsafes in for failure to follow simple instructions/setup, take your time next time.

I think it would be good with a failsafe because sometimes you get tele'd away by a random (very rare) and the script gets stuck and once I got stuck in the middle of the abyss just standing there with the status navigating path or something similar. 

 

It's very rare that something actually happen but if it's possible with a failsafe it would be nice. :)

 

 

Also noticed a couple of times that the script doesn't actually click the home/house teleport and it won't retry if it failed (when doing an emergency tele in abyss/being pked). Would be nice if it clicked a couple of times or something till it teleported away.

 

 

Edit: The bot didn't even recognize that it got pked and ended up in lumby. Just standing there doing nothing. 

Edited by Zumzod

Share this post


Link to post
Share on other sites

I am writing because I don't know what else to do. Very dissatisfied with this script. It keeps randomly stopping, and leaving my character logged in, sitting in the same place without doing anything. Here are two examples when I have caught it sitting. 

 

Example one: The mouse kept moving slight over the chaos rift, moving slightly back and fourth. Watched it for 5 minutes, stuck in an infinite loop before I killed the script as many of the same people kept running by me as I stood still. Not a problem on my end, as it clearly ran correctly for over 2 hours before running into this bug. Could be fixed with a failsafe that teleports after the character doesn't move for maybe 2-3 minutes time, as previously stated:

 

9vf7g5.png

 

Example two: Second bug is the bot runs fine for nearly half an hour, then randomly stops at altar. It read's "sleeping for altar", not sure what this means, maybe an intentional anti ban or something? All I know is, as you can see by the computer time and the time in the debug, it sat again for 5 minutes, unmoving. Please let me know if something is wrong or if this is intended:

 

v7waow.png

 

Last example: Not sure what exactly happened. Clearly the bot died - I have no gripe with that, that is what is expected with a bot that goes to the wildneress, could lag out, etc. Again what I have a problem with, is that bot let's my character sit there, logged in, for what appears to be 2 hours in lumbridge (if I'm reading the logs correctly) because it last said: "Trip: 64" at 16:40, and has it loggin in and out until 18:31. Script is still "running" instead of a "log out and kill" type thing. Let me know if I can post any debug or something some how that will let you know what happened or if I'm doing something wrong:

 

2efjhua.png

 

Now, I apologize if I'm being the one to really mess up - I don't usually ever blame a scripter, and obviously this script works with some of the legit awesome proggies, but something isn't working here. I am usually the person who reads every detail the scripter mentions (I have my bank set up exactly as you showed, my house set up in the exact orientation of yours, etc. etc.), so I have never had these kind of problems with a bot... and especially a $20 one.

 

If these mess ups are my fault, by all means please point it out and lead me in the right direction, but if something is going haywire in the script I'd like my money back, or at least maybe a "I'll work on it and have it fixed shortly" type deal.

 

Thanks so much, sorry for my hostility... just so odd for me - I'm never "that guy"!

 

edit: new bug. Completely redownloaded tribot and everything to make sure everything was up to date. Ran bot, and it ran pretty good for like half an hour.. then it randomly decided, in the middle of withdrawing ess, that I was out of ess. As you can see, I clearly was not... LOL...buggy, buggy, buggy :(. On the plus side, at least it ended the script, lol...

2lig8xt.png

Edited by Luke L

Share this post


Link to post
Share on other sites

I think it would be good with a failsafe because sometimes you get tele'd away by a random (very rare) and the script gets stuck and once I got stuck in the middle of the abyss just standing there with the status navigating path or something similar. 

 

It's very rare that something actually happen but if it's possible with a failsafe it would be nice. :)

 

 

Also noticed a couple of times that the script doesn't actually click the home/house teleport and it won't retry if it failed (when doing an emergency tele in abyss/being pked). Would be nice if it clicked a couple of times or something till it teleported away.

 

 

Edit: The bot didn't even recognize that it got pked and ended up in lumby. Just standing there doing nothing. 

 

 

Seriously such a waste of money, my longest run time on this bot is 10 mins, i have been restarting it for days so bs

 

 

 

It just keeps saying enabled all randoms and just stands there

 

 

 

 

It seems recent users are having the same problem as me, as noted with the standing in lumbridge, and also the user states the "enabled all randoms", as that happens in those three pics I posted as well. 

 

Please let us know what is going on, if maybe it's a client issue at the moment?

Share this post


Link to post
Share on other sites

To all the people having issues, please read the entire first post and attempt to fix your problems like a human being or just be completely rude and insult the script/scripter when I have it running no problem. Clearly you are doing something wrong.

*Face palm*, as for myself, please read my whole post. Which includes that I "read the entire first post", and also mentions that you "Have it running no problem"

 

I'll copy and paste for your convenience, as well as bold the parts i'm referring to. Maybe you're not talking about me, but heres my experience:

 

"Now, I apologize if I'm being the one to really mess up - I don't usually ever blame a scripter, and obviously this script works with some of the legit awesome proggies, but something isn't working here. I am usually the person who reads every detail the scripter mentions (I have my bank set up exactly as you showed, my house set up in the exact orientation of yours, etc. etc.), so I have never had these kind of problems with a bot... and especially a $20 one."

Share this post


Link to post
Share on other sites

Hey guys,

 

Been part of this nature bot a long time and have had my share of queries. A lot of people repost VERY similar complaints as before. Mainly getting stuck in Abyss (Sleeping at altar), stuck at bank (out of pure essence) etc.

 

Now as this has probably been mentioned at least once every two pages the main problem that you are having is lag. This script requires a decent amount of processor speed, for example: it has these problems when I try to run in on my old computer. The laptop I run it on now isn't fantastic but I set its priority to 'high' in task manager and it runs well. 

 

Please read the first page carefully, the bot will struggle on VPS I think, so either upgrade your computer or figure out how to make it faster because any issue where the bot freezes, aside from the occasional client error is generally LAG BASED.

 

Rant Over

 

TL;DR : Most problems are lag based and not USA's fault.

Share this post


Link to post
Share on other sites

 

 

TL;DR : Most problems are lag based and not USA's fault.

 

I'm not struggling with these lag related issues but imo there is a few tweaks that could be made which would improve the script and might help those who are struggling. (example sleeping at the altar, for me it has happened once in the 1000's of hours I have ran the script so it's not an issue (except for my old comp) but I think (don't know how it's coded though) it's not that hard to add some kind of check.

 

Then that the script doesn't notice when it has been teleported away(rarely happens) to example white wolf mountain. 

Sometimes when it dies and goes to lumby it doesn't terminate the script and it stands there logging in/out which is not lag related and should have some kind of failsafe.

 

TL;DR: Most issues are lag based related but there could still be some fairly simple checks if certain things happen.

Share this post


Link to post
Share on other sites

I'm not struggling with these lag related issues but imo there is a few tweaks that could be made which would improve the script and might help those who are struggling. (example sleeping at the altar, for me it has happened once in the 1000's of hours I have ran the script so it's not an issue (except for my old comp) but I think (don't know how it's coded though) it's not that hard to add some kind of check.

 

Then that the script doesn't notice when it has been teleported away(rarely happens) to example white wolf mountain. 

Sometimes when it dies and goes to lumby it doesn't terminate the script and it stands there logging in/out which is not lag related and should have some kind of failsafe.

 

TL;DR: Most issues are lag based related but there could still be some fairly simple checks if certain things happen.

Yes that seems fair. I haven't died in a while but does it still stay logged in when you do? If so that would be good

Share this post


Link to post
Share on other sites

Yes that seems fair. I haven't died in a while but does it still stay logged in when you do? If so that would be good

 

Yeah, sometimes it logs out and sometimes it wont (even though it spotted the pker) and if you die in the abyss (somehow) I've never seen it log out. Though I've only died like once or twice there.

 

 

My account just hopped to a F2P world and stood there for 30mins searching for the mage :/

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • [CONTEST ANNOUNCEMENT] 2019 Botter's Choice Awards
      2019 Botter’s Choice Awards

      To celebrate the launch of our TRiBot Official RuneScape Bot Blog,

      we’re doing a giveaway! 

      The TRiBot Official RuneScape Bot Blog: 

      Teaching you how to do more advanced botting, faster.
      Contest Details

      Prize: 3 winners will be selected to win 25 TRiBot credits.

      How to enter:

      Respond to this forum post by November 12th tagging the thread for: 

      Your favorite script

      Provide a brief explanation (1-2 sentences) why you think that script should be put in the top 5. 

      Who can enter?

      Botter’s who are not currently scripters. Sorry scripters, the people are going to vote. Your contest is here.

      The top 5 in each category will be showcased on our TRiBot Official RuneScape Bot Blog in a “People’s Choice” section and promoted across the TRiBot website. 

      -- Credits will be awarded based on thoughtfulness and humor -- 

      Bonus points

      Use a meme in your explanation. Because we all love memes.

      *no purchase necessary. Winners will be announced on Friday, November 15, 2019 at 4:00 p.m. on our News and Announcements forum. 

      -- Vote Below -- 
        • Like
      • 28 replies
    • [READ TO THE END FOR A TEASER]

      I've noticed some new TRiBotters have had some troubles finding out sources of how to do certain things, such as using advanced scripts and often get lost in the forums.

      We are still getting posts asking where to start, what to do, recommended scripts, etc. 

      As many of you know, I am new to the team, and had troubles myself learning how to bot, let alone script. 

      So, what our team decided to do was make it easier to learn how to bot, how to script, and just become an overall better botter and scripter faster. 

      As some of you might have seen, I've posted 3 new blogs, you can check it out by clicking on the following picture or here.


      These first 3 blogs are the first of many blogs that will be TRiBot official. They are encouraged to be challenged, improved upon and act as A Best Practices Guide for Botters.

      What information would you like to see in the blogs?

      👇 [TEASER] 👇

      .

      .

      .

      We are going to be hosting a  CONTEST  this  OCTOBER.

      Its scary to think how soon you'll find out.👻

      Stay tuned.


      - RileyZ
      • 8 replies
    • Today marks a big day for TRiBot! To make it easier for users to use TRiBot, we've created installers available for every platform! These installers are all bundled with the latest version of OpenJDK 1.8 (Java 😎, which is LG compatible.

      Using TRiBot is now easy. Simply download the installer for your platform, install TRiBot, and run it. The TRiBot Loader will correctly identify the bundled JDK so there's no need to change the Java selection.

      Windows

      EXE installer: TRiBot-windows-x64-4.0.3.exe


      MSI installer: TRiBot-windows-x64-4.0.3.msi


      Portable version: TRiBot-windows-x64-4.0.3.zip


      Mac OS

      Installer: TRiBot-macos-4.0.3.dmg


      Portable version: TRiBot-macos-4.0.3.tgz


      Unix/Linux

      Installer: TRiBot-unix-4.0.3.sh


      RPM installer (CentOS/Fedora): TRiBot-linux-4.0.3.rpm


      DEB installer (Debian): TRiBot-linux-4.0.3.deb


      Portable version: TRiBot-unix-4.0.3.tar.gz


      Platform Independent

      JAR file: tribot-loader-4.0.3.jar


      Note that this jar file does not include the bundled JDK.



      Windows and Mac OS users may notice a warning message stating that the installer/application is un-recognized or un-trusted. Please ignore this message and proceed with running the installer/application. We need to acquire a code signing certificate so that we can sign the installers letting the operating system know that these files can be trusted. It will take a week or more to acquire one, so please hold tight.

      Other notable changes to the TRiBot Loader:

      Support getting the version from OpenJDK distributions


      Add check for bundled JDK


      Copy OpenJDK tools.jar to the bundled JDK if not present


      Set the current java as the first available list entry


      Ignore Java versions which are symbolic links


      Make the bundled JDK the preferred Java version


      Update icon images


      Reduce the number of HTTP calls
        • Thanks
        • Like
      • 32 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 18 replies
    • Hello TRiBot,

      Today we have a significant release that has been in the works for the last month addressing several key issues, features and bugs in the backlog.

      With these changes, we are also including a new TRiBot Loader which will allow you to select any version that is released. This adds the flexibility of allowing you to revert to a previous version should an issue arise, run development only builds, view an accurate change log between versions etc. we are very proud to offer this feature and think it will add a lot more functionality down the road as we continue to release new versions.

      These changes include 80+ commits by our development team, a list of them is summarized below and also available for your viewing pleasure in the new TRiBot Loader.

      In addition, we have taken additional steps to improve as a development team by adding continuous integration and deployment into our workflow to assist in delivering timely releases such as bug fixes as well as new features on a weekly basis depending on our development cycle.
        • Thanks
        • Like
      • 39 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...