Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Sign in to follow this  
rajche

Looking glass problem.

Recommended Posts

Hello guys. I've tried every possible setup with java jdk 1.8.0_202 and java jdk 1.8.0_252. Osbuddy, openosrs, every guide found on forum so far, and yet i my looking glass can't seem to find osbuddy or openosrs or any client for that matter. I've deleted hooks, followed natan script that deletes cache/hooks/everything, but so far i'm stuck not being able to load it, also tried updating java policy for full permissions. . Can someone suggest something that i might be overlooking?
(I've tried this with windows 7 32 bit, windows 10 64bit(reinstalled both 2x)), same problem. I have it running with no problems with the same steps i did on a computer just next to me. I do not understand at this point what am I doing wrong? Can someone please guide me?

Share this post


Link to post
Share on other sites

For anyone else struggling to get Looking Glass to Work. Try Fluffee's Fix that worked immmediately for me. Uninstall all your other java JDKs and regular java installs. Download Java JDK 8u102. Install. Delete your Hooks again. Run Tribot. Choose the new JDK. Open Osbuddy, wait til it loads up to the login screen. Then Click Looking Glass. 

This worked after all the struggle.

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By lau1992
      Hi!
      I was playing around with a VM as it is easier to manage multiple instances for me personally on my local machine (I do not use proxies, but use a vpn). But I can't get LG to work... On my local machine everything runs smooth, but on the VM it always says "looking for OSRS client" (you know the message). I have the same configuration as on my local machine.
      Is there a configuration property to be set on VM level or something? 
      All suggestions are welcome!
      --------Specs of the VM:
      - Clean install with VMware Workstation 15 Player running Windows 7 Ultimate (also tested with Windows 10 with VirtualBox)
      - Java JDK 8u251
      - OSBuddy.jar
      - Tribot loader 4.0.4

    • By ah12ims1
      as the title suggests, it works, but my issue is that for me it only works with OSbuddy. 
      this is what i have installed for java  
       
      however when i try and open the runelite (or open osrs) jar file i get this error 
      so, i inquired about what i should do to get RL or OPRS working, i installed JDK 11 (also 13 after to check if there was any diff, but none).
      this lead to RL working, but then my Tribot loader AND my OSB wouldnt load.
      my tribot loader didnt even give an error, it just didnt open, and my OSB gave this error 
       
      can someone please help me out, i just want to use tribot looking glass witrh runelite instead of OSB
    • By briareos2285
      Just got a new Windows 10 Home x64 Laptop. Going through my usual install method and finding that I cant get looking glass to work. I have followed a few "old" guides, because I cant find any that are more recent. I am installing Java SE Development Kit 8u251, I am choosing the x86 version since the only OSbuddy cross platform .jar  file is 32bit. Its worked fine in the past. I then open Osbuddy, and then Open Tribot. I leave it on the default Tribot Version of 10.24.1. I select the java version for Tribot to use to be the JDK and not the jre. I changed the Heap Size to 1024 MB and login. I minimize Osbuddy, then I click New Client(Looking Glass). The Screen goes to black and says " Waiting for a Runescape client.... currently waiting for a valid client. List of detected java applications below." and there is nothing Below. I also tried a backup method that used to work as well, which was to instead click New Client (Osbuddy) and then manually select the Osbuddy .jar file which would open up Osbuddy and Create a Looking Glass Tab that mirrored Osbuddy. This no longer happens either. Ive also deleted the Hooks and Caches using Naton's Java Executable. I have also defined the correct Paths in my Computers Environment Variables.
      Im at a loss for what to do. Any help greatly appreciated
    • By joewhite1997
      whenever i load the bot client, (just spent ages with jar fix and reinstalling all java to my pc several times as client stoppped working for me. The looking glass window just loads a blank black screen? any help would be greatly appreciated, first time back on rs and botting for a long time.
    • Guest
    • By witn6ss
      Hey guys, I'm currently a VIP member and LG is not showing up for me. It has always shown up and worked before but it isnt now and i just renewed my vip today. i've tried closing and re-opening tribot as well as re-installing it. please help if you can, thanks.
    • By TheIronPride
      Hey everyone i been using looking glass for a few months now, and just today i no longer see it as an option, i only see "new Client" and "New Client (advanced)" where there is normally a "new Client (looking Glass)" option, any suggestions?
    • By acezeps
      Used tribot for about a year now, running lg only the entire time. ive always been able to fix errors that would come up but since the update my Lookingglass has been broken. Tried everything I know how to do ie. Uninstall everything and download proper osbuddy,tribot, and java jdk downloads. 
      running into the same error over and over again, and my debug log at the bottom spams errors non-stop, took a while to even be able to see some words cause it was spamming so fast.
      Heres mostly what its saying in the debug, any help would be wonderful. Love everything about tribot, hope someone could help a brother out.
       
      Debug:
       
      debug log.txt
  • Our picks

    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 10 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
      • 26 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...