Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Ark

[PREMIUM] ARKSlayer Pro - Automatic Slayer Training [Cannon][Restocking][Prayer][Superiors][ABC2]

Recommended Posts

Posted (edited)

Hello, just got back to the bot to find out it had died at the same place @ trolls again. I know it went well on run prior to that, but that was in the middle of the task. Apparantly teleporting out isn't working as intented when the task has finished.
Also, isn't it supposed to loot the grave once it has died? Luckily I was just in time to loot it myself :)

Are we still supposed to use the 10.24.2 version btw?

Edited by karelpeter

Share this post


Link to post
Share on other sites
Posted (edited)
50 minutes ago, karelpeter said:

Hello, just got back to the bot to find out it had died at the same place @ trolls again. I know it went well on run prior to that, but that was in the middle of the task. Apparantly teleporting out isn't working as intented when the task has finished.
Also, isn't it supposed to loot the grave once it has died? Luckily I was just in time to loot it myself :)

Are we still supposed to use the 10.24.2 version btw?

10.24.2 doesn't work for worldhopping and lost some clicking hooks, which is probably why you died. I've checked and teleporting after tasks is definitely working as intended. There currently isn't any client working 100%, so it is probably worth just just using the latest client.

Do you have the Fremennik Isles quest completed? It shouldn't be doing that task without a Neitiznot shield, which should deflect a lot of the damage you take.

Deathwalking also works, I killed my accounts a lot to test it - can you send me the debug from your bot? I'll work out what's going on for you.

For what it's worth, Tribot 11 is about to become the core client - worth trying it out, this script works perfectly on Tribot 11 to my knowledge.

Edited by Marcusihno

Share this post


Link to post
Share on other sites
Posted (edited)
15 minutes ago, Skids said:

Working pretty well after I blocked Black Demons (gets stuck at the lift). 

UvNGBAU.png

Fixed that task bug today, should work now :) 

Thanks for the progress report, very nice!

Edited by Marcusihno

Share this post


Link to post
Share on other sites

Patch 2.15 has been pushed, my Tribot 11 (the beta that is about to go live) support patch:

Following this patch, I recommend using Tribot 11 for running ARKSlayer (and all of your scripts) - it will soon be the default client.

- Checked and made any relevant fixes necessary for ARKSlayer to run using Tribot 11
- Fixed a bug caused by the Tribot break handler that made the script not teleport back home properly after tasks after a break

Please note: Please use fixed client size mode, as I have noticed some minor bugs with resizeable mode so far that are client-related.

Share this post


Link to post
Share on other sites
Posted (edited)
15 hours ago, Ark said:

10.24.2 doesn't work for worldhopping and lost some clicking hooks, which is probably why you died. I've checked and teleporting after tasks is definitely working as intended. There currently isn't any client working 100%, so it is probably worth just just using the latest client.

Do you have the Fremennik Isles quest completed? It shouldn't be doing that task without a Neitiznot shield, which should deflect a lot of the damage you take.

Deathwalking also works, I killed my accounts a lot to test it - can you send me the debug from your bot? I'll work out what's going on for you.

For what it's worth, Tribot 11 is about to become the core client - worth trying it out, this script works perfectly on Tribot 11 to my knowledge.

Perhaps that was the cause for my problems then, as I was using 10.24.2 nor fixed screen mode. I did have the quest completed and it brought a neitiznot shield as well. After dieing, it was just standing there.

What I also just noticed is that, in the Brimhaven dungeon, it tried to click the opposite crevice of where the character was standing (the Iron/Steel dragon area). 

Edited by karelpeter

Share this post


Link to post
Share on other sites
Just now, karelpeter said:

Perhaps that was the cause for my problems then, as I was using 10.24.2 nor fixed screen mode. I did have the quest completed and it brought a neitiznot shield as well. After dieing, it was just standing there.

What I also just noticed is that, in the Brimhaven dungeon, it tried to click the opposite crevice of where the character was standing (the Iron/Steel dragon area). 

I'm genuinely surprised it worked at all on 10.24.2 without fixed mode, walking is completely unfunctional on that client version. 

I suggest using Tribot 11, fixed screen mode and clearing your hooks - that should resolve most of your issues :) 

Share this post


Link to post
Share on other sites
3 minutes ago, Engzy said:

Hi, mine also keeps dying after finishing every task. It just stands in lumbridge doing nothing. I was using the latest tribot version 10.25.11 on fixed mode. 

I need a lot more information, this seems to be something specific to some users. Debug for a start, then a description of what's happening exactly.

Share this post


Link to post
Share on other sites
1 minute ago, Ark said:

I need a lot more information, this seems to be something specific to some users. Debug for a start, then a description of what's happening exactly.

I closed it already but I can remember it said finished task going to the bank and tried to teleport, eventually dying at dagganoths. I'll let it run again a few times and see if it dies again, ill let you know everything :)

Share this post


Link to post
Share on other sites
Just now, Engzy said:

I closed it already but I can remember it said finished task going to the bank and tried to teleport, eventually dying at dagganoths. I'll let it run again a few times and see if it dies again, ill let you know everything :)

Okay - just as a matter of interest, what banking location are you using? Did it equip the teleport item?

Share this post


Link to post
Share on other sites
1 minute ago, Ark said:

Okay - just as a matter of interest, what banking location are you using? Did it equip the teleport item?

I use ring of dueling for banking + restore and row for GE restocking. Im not sure if it equipped the teleport item, im pretty sure it usually does not equip it. 

Share this post


Link to post
Share on other sites
Posted (edited)
13 minutes ago, Engzy said:

I use ring of dueling for banking + restore and row for GE restocking. Im not sure if it equipped the teleport item, im pretty sure it usually does not equip it. 

I'll take a look and push a potential fix

Edit: Pushed V2.16, which should fix any issues you're having (hopefully)

Edited by Ark
  • Like 1

Share this post


Link to post
Share on other sites
9 minutes ago, Ark said:

I'll take a look and push a potential fix

Edit: Pushed V2.16, which should fix any issues you're having (hopefully)

Thanks for the quick response! The bot is still running, I'll let you know if it happens again. 

Share this post


Link to post
Share on other sites

Pushed V2.18, an extensive performance upgrade and clean-up:

- Grand Exchange purchasing is now faster and more fluid, with an emphasis on preventing detection
- Considerable base performance upgrade from a code-efficiency point of view
- Fixed Deathwalking

- Re-added some low-level antiban functions
- Fixed a bug with the conversation interaction for new accounts getting their first task
- Fixed a handful of NPE possibilities

Share this post


Link to post
Share on other sites
1 hour ago, lilchanny123 said:

Any plans for Kraken boss?

Once this script is flawless, I may look to release some separate (Slayer-related) bossing scripts - no plans to add any bosses to this script though, it does a hell of a lot already :) 

Share this post


Link to post
Share on other sites
Posted (edited)
18 minutes ago, keko1337 said:

Any chance of adding herb sack for most herb tasks/ seed box for seed tasks etc?

Herb sack will be coming at some point in the future :) 

16 minutes ago, keko1337 said:

And if possible in the future add a button to not pick other peoples items dropped from mobs, cause my ironman keeps bugging on tasks alot durning this on crowded areas. it just sits there and spams to pick an item up.

The script does not officially support Ironman accounts. I'll be working on some Ironman-friendly features soon, but flawless running for normal accounts is my priority atm.

 

 

Pushed V2.19:

- Increased the timeout slightly on the no XP failsafe
- Fixed a bug causing certain accounts to die due to not equipping Rings of Wealth correctly at the end of tasks

Edited by Ark

Share this post


Link to post
Share on other sites
Posted (edited)

Just purchased this script. Wondering how must people use it effectively? Recommended to use with or without looking glass? If with looking glass, what clients are supported. 

Edit: Works well when it works. Seems to be getting stuck at a few points. Like when it needs to rebank for supplies or when it finishes a task. Was killing Black Demons in Chasm of Fire. Killed 130 before it needed to bank.  In my instance, it picks up the cannon and then just stands there.  The client logger just stops as well. Manually pausing and resuming the script does nothing. clicking inside the client window doesnt have any affect. Was running on fixed mode with the newest Tribot Loader.

 

arkslayer.jpg

Edited by briareos2285

Share this post


Link to post
Share on other sites
Posted (edited)
On 6/30/2020 at 10:21 PM, Ark said:

 

Bot getting more and more stable, great.

However, I do have a thing or two that I'm running in to after a few days of running this intensively.

For higher level players, it doesn't seem to be very practical for certain tasks. This is also due to the looting mechanism. For example Aberrant spectres; it will bring a full inventory of sharks but eat them in order to pick kind of worthless herbs. 
I tried fixing this by selecting the "Max XP mode - only loot high value items". However, it stops looting entirely for me with this option, same as when I select "Loot over X amount". What happens is my character goes to bank literally every few minutes because after a few kills it's inventory is already full. I heard you are working on implementing herb sack, that's awesome. For now, I'm stuck with the default looting setting, which isn't too practical for higher levels that can't be bothered with 1-3k drops. But it's better than not picking up an imbued heart 😛

Lastly, I had to save my character from dieing at trolls again, was just continueing fighting them at 20 hp and no food/prayer. I am using the latest version, is fixed mode still a necessity? (Using Duel ring + RoW).

Looking forward to your insight :)

Edited by karelpeter

Share this post


Link to post
Share on other sites
7 hours ago, briareos2285 said:

Just purchased this script. Wondering how must people use it effectively? Recommended to use with or without looking glass? If with looking glass, what clients are supported. 

Edit: Works well when it works. Seems to be getting stuck at a few points. Like when it needs to rebank for supplies or when it finishes a task. Was killing Black Demons in Chasm of Fire. Killed 130 before it needed to bank.  In my instance, it picks up the cannon and then just stands there.  The client logger just stops as well. Manually pausing and resuming the script does nothing. clicking inside the client window doesnt have any affect. Was running on fixed mode with the newest Tribot Loader.

 

arkslayer.jpg

DaxWalker went down last night, which caused this. I'm pushing a patch today which should improve performance and prevent any issues like this :) 

48 minutes ago, karelpeter said:

Bot getting more and more stable, great.

However, I do have a thing or two that I'm running in to after a few days of running this intensively.

For higher level players, it doesn't seem to be very practical for certain tasks. This is also due to the looting mechanism. For example Aberrant spectres; it will bring a full inventory of sharks but eat them in order to pick kind of worthless herbs. 
I tried fixing this by selecting the "Max XP mode - only loot high value items". However, it stops looting entirely for me with this option, same as when I select "Loot over X amount". What happens is my character goes to bank literally every few minutes because after a few kills it's inventory is already full. I heard you are working on implementing herb sack, that's awesome. For now, I'm stuck with the default looting setting, which isn't too practical for higher levels that can't be bothered with 1-3k drops. But it's better than not picking up an imbued heart 😛

Lastly, I had to save my character from dieing at trolls again, was just continueing fighting them at 20 hp and no food/prayer. I am using the latest version, is fixed mode still a necessity? (Using Duel ring + RoW).

Looking forward to your insight :)

I'll take a look at making it only loot items worth more than your food value, that way it can improve task length. You have to appreciate that for an AIO Slayer script, it's borderline impossible to create a 100% flawless decision algorithm for food and prayer potion quantities that applies for all levels - and hardcoding stuff isn't a solution :P Loot above X value does work; there's a chance RSBuddy's price system was down though. I'll check it out :) 

I'm pushing a big update today which should hopefully address the death issues^^

Share this post


Link to post
Share on other sites
Posted (edited)

Pushed V2.20, a hotfix patch to deal with Tribot 11 issues:

- Removed multiple interface methods that are now broken on Tribot 11 (client bugs, awaiting dev fixes)

- Hotfixed a lot of things that are client-related

- Fixed a bug with returning home that was caused by the interfaces issue on Tribot 11

 

Other stuff:

- Added a fix for Stronghold of Security management
- Now uses Escape key to close the GE interface if you have Esc closing selected in your options

 

Please note: You must restart your client to get this update.

Edited by Ark

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, Ark said:

DaxWalker went down last night, which caused this. I'm pushing a patch today which should improve performance and prevent any issues like this :) 

I'll take a look at making it only loot items worth more than your food value, that way it can improve task length. You have to appreciate that for an AIO Slayer script, it's borderline impossible to create a 100% flawless decision algorithm for food and prayer potion quantities that applies for all levels - and hardcoding stuff isn't a solution :P Loot above X value does work; there's a chance RSBuddy's price system was down though. I'll check it out :) 

I'm pushing a big update today which should hopefully address the death issues^^

Hey, even with the latest update and using tribots' latest version, it doesn't pick up various valuable drops. On my current Aberrant spectres task for example; my settings are "Loot over 5000", it picks up ranarr weeds and rune full helmets but it did not loot a mystic robe bottom. I have seen things happen like this multiple times:(.

Edited by karelpeter

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 64 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
  • Recently Browsing   1 member

×
×
  • Create New...