Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Netami

Netami's Runecrafter [Abyss] [ZMI] [Pouch gathering] [Death walking] [Restocking] [Muling]

Recommended Posts

Posted (edited)

Welcome to the thread for Netami's Runecrafter!

Support/discussion discord link: https://discord.gg/aacD5Th

GET IT HERE: https://tribot.org/repository/script/id/3493

 

Over the past few months I've been working on my own Runecrafting script, which I'm now happy to release

for public use! Below is the list of features currently implemented in the script:

- Regular (walking) runecrafting

- Abyss runecrafting

- ZMI altar

- Pouch repair (abyss or NPC Contact)

- Progression queue

- Custom jewelry/teleport/bank selection for jobs

- Lava/mud combination runes

- Integrated GE Selling/Restocking

- Stamina potion support

- Customization mouse speed

- Integrated muling (for use with Netami's Muler)

- Pouch gathering from abyss

- Pouch organization in inventory

- Script ending conditions (time, runes made, level)

- Profile saving/loading

- Profile loading via script arguments

- Dynamic signatures/hiscores

 

Below is the list of runes/methods supported:

Red = Regular (non-abyss) only, Yellow = Abyss only, Green= Abyss and regular OR custom method

- Air runes

- Mind runes

- Water runes

- Earth runes

- Mud runes (magic imbue OR talismans)

- Fire runes

- Body runes

- Lava runes (magic imbue OR talismans)

- Cosmic runes

- Chaos runes

- Astral runes (Moonclan teleport)

- Nature runes

- Law runes

- Death runes

- Blood runes

- Soul runes

- ZMI Altar (Ourania teleport)

 

GUI Screenshots:

https://imgur.com/a/vsSG4RU

 

Hiscores page:

https://netamiscripts.com/rc/

 

Dynamic signatures (replace Netami with your own TRiBot username):

https://netamiscripts.com/rc/users/Netami.png

 

ZTvoicf.png

MD52B5X.png

Edited by Netami
  • Like 5

Share this post


Link to post
Share on other sites

After babysitting the bot for a couple of hours I noticed it occasionally got stuck right when it entered the abyss. It won't do anything and will stand around as the monsters attack. Will add more information if I figure out a possible reason as why this is happening.

Share this post


Link to post
Share on other sites
3 hours ago, kiberlt said:

After babysitting the bot for a couple of hours I noticed it occasionally got stuck right when it entered the abyss. It won't do anything and will stand around as the monsters attack. Will add more information if I figure out a possible reason as why this is happening.

Yeah if you can let me know what it does when this happens that'll help me debug; for instance if it's trying to click an obstacle it can't or navigate to something

Share this post


Link to post
Share on other sites
1 hour ago, Netami said:

Yeah if you can let me know what it does when this happens that'll help me debug; for instance if it's trying to click an obstacle it can't or navigate to something

After entering the abyss from the western side, the cursor stopped moving and the bot "gave up". Debugger was filled with the messages I've attached below, tens of them every second. After manually clicking on the rock to mine, the bot "woke up" and kept running.

java_xmjF49Pub7.png

Share this post


Link to post
Share on other sites
Posted (edited)
33 minutes ago, kiberlt said:

After entering the abyss from the western side, the cursor stopped moving and the bot "gave up". Debugger was filled with the messages I've attached below, tens of them every second. After manually clicking on the rock to mine, the bot "woke up" and kept running.

java_xmjF49Pub7.png

I'll check this out today, thanks

Edit: which rune are you crafting, and what is the status in script paint?

Edited by Netami

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, Netami said:

I'll check this out today, thanks

Edit: which rune are you crafting, and what is the status in script paint?

Death runes, while using a pickaxe. Status was Enter Altar but I will doublecheck once it gets stuck again.

EDIT: Doublechecked, it does say Status: Enter Altar.

Edited by kiberlt

Share this post


Link to post
Share on other sites
1 hour ago, kiberlt said:

Death runes, while using a pickaxe. Status was Enter Altar but I will doublecheck once it gets stuck again.

EDIT: Doublechecked, it does say Status: Enter Altar.

Thanks keep me posted

49 minutes ago, takotakotako said:

Any runepouch support for zmi?

Yes there is

Share this post


Link to post
Share on other sites
1 hour ago, vho835 said:

Any plans on adding zeah runecrafting?

 

41 minutes ago, ph0ne said:

This

I need an account that has access to zeah RC, I would definitely like to add it though

49 minutes ago, takotakotako said:

it keeps withdrawing the runes for paying bank at zmi even tho runes are already inside runepouch. 

I'll double check the rune pouch is also checked for these, thanks. 

Share this post


Link to post
Share on other sites

Tried Ourania and it also got stuck on the ZMI bank for me, tried depositing the Rune Pouch, then gave up. Status: Withdrawing, debugger claiming my Giant Pouch isn't full (don't have 75 RC so can't even use one).

Also, are more combination runes planned? I'd love to make Steam runes for example.

Share this post


Link to post
Share on other sites
7 hours ago, kiberlt said:

Tried Ourania and it also got stuck on the ZMI bank for me, tried depositing the Rune Pouch, then gave up. Status: Withdrawing, debugger claiming my Giant Pouch isn't full (don't have 75 RC so can't even use one).

Also, are more combination runes planned? I'd love to make Steam runes for example.

Hey, version 1.22 I released about 10 hours ago should have patched this rune pouch thing at ZMI, not sure if you were running that version or not, but make sure your bank is filled in a way so it can't deposit needed items when it uses the Deposit All button as well.

I can definitely add the other combination runes soon, shouldn't take too long!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 1 reply
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 71 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Haha
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...