Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Sign in to follow this  
sgt p0wned

Having Java Issues

Recommended Posts

Posted (edited)

Hey guys, 

So fresh install so I go ahead and download the normal java and then the jdk.. 

I keep getting some popup,

Java Virtual Machine Launcher  

Error: a jni error has occurred, please check install and try again. 

I get that when I try and run any normal .jar client like runelite or openosrs. 

 

Anyone know whats going on here?

Thanks guys

Edit: Running win 10 

Edited by sgt p0wned
forgot a detail

Share this post


Link to post
Share on other sites
Posted (edited)

yeah I had the normal java 8 update 241 from java.com or whatever then downloaded the jdk and still had the problem.

I'm just uninstalling both and trying to just install the jdk, maybe that will help? 

Same jni error with just jdk but after that popup comes one that says A JAVA EXCEPTION HAS OCCURED

I don't get it lol I already paid for vip for Lookingglass to so this is all just straight down time. 

Edited by sgt p0wned

Share this post


Link to post
Share on other sites

Uninstall all Java. (Can search for tools online to do even more thorough Java installs)
Install just the latest JDK8 from the Java website.
On the TRiBot loader, make sure JDK 8 is selected in the Java version box.
Trick 'Console Mode.

Post screenshot/text of exact error you get.

Share this post


Link to post
Share on other sites

I got openosrs and runelite to work with jdk 11 but when I have jdk 11 installed tribot wont work.. then when I have jdk 8 installed openosrs and runelite wont work. is there a way to specify what java to use with each program ? 

This java stuff could drive someone mad I swear lol mad respect for all scripters

Share this post


Link to post
Share on other sites

I've tried to run Runelite with Tribots LG and it didn't work. Runelite only works with the latest JDK version of Java while Tribot only works with JDK 1.8.0_102. I tried installing both JDK 14 (to run Runelite) and JDK 1.8.0_102 (to run Tribot) but that didn't work either. Any help?

Share this post


Link to post
Share on other sites

I'm having this issue as well, I CANNOT use looking glass.


Steps to reproduce:
Install JDK8u251
At this point you can open Tribot successfully.

Then install JDK11.0.7
You will be unable to open Tribot any longer, but you will now be able to open the openOSRS.jar


This is a problem because Tribot uses JDK8, while openOSRS uses JDK11, but both cannot be installed if you want any chance of starting up Tribot.

If anyone has a hotfix for this I'm all ears.
I imagine it has something with directing tribot to use the JDK8 javaw.exe but I tried that and still nothing..

Share this post


Link to post
Share on other sites
11 minutes ago, ikeig said:

I'm having this issue as well, I CANNOT use looking glass.


Steps to reproduce:
Install JDK8u251
At this point you can open Tribot successfully.

Then install JDK11.0.7
You will be unable to open Tribot any longer, but you will now be able to open the openOSRS.jar


This is a problem because Tribot uses JDK8, while openOSRS uses JDK11, but both cannot be installed if you want any chance of starting up Tribot.

If anyone has a hotfix for this I'm all ears.
I imagine it has something with directing tribot to use the JDK8 javaw.exe but I tried that and still nothing..

https://bitbucket.org/openosrsjava8/launcher/downloads/

Built using Java 8 so it doesn't require 11.

Share this post


Link to post
Share on other sites
1 minute ago, Netami said:

Since it's the loader it doesn't need as frequent updates; it's built by @Fluffee for LG use specifically

Do you know if it's compatible with Tribot 11? I can't seem to get it working but I'm definitely willing to chalk it up to user error.

Share this post


Link to post
Share on other sites
Just now, ikeig said:

Do you know if it's compatible with Tribot 11? I can't seem to get it working but I'm definitely willing to chalk it up to user error.

Should be, it'll likely require some cache/temp file clearing, mainly the .jar files in your %temp% directory in Windows.

Share this post


Link to post
Share on other sites

Just starting the OSRSshaded.jar by itself, it attempts to connect to the update server for runescape but then just sits at a black screen with no prompts or anything. You ever seen this before? It does the same thing when I launch it from looking glass.. 

image.png

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Our picks

    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 62 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...