Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
dodgedave

Issues loading client

Recommended Posts

Can anyone shed some light on the recent issue i'm experiencing

On client startup, either manually or using arguments, I get a black screen that states "Downloading jar: null null" with this debug:-

 

Quote
  • [20:27:07] TRiBot Beta loaded. (1.8.0_231:C:\Program Files (x86)\Java\jre1.8.0_231)
  • [20:27:07] Launching Client from Boot File
  • [20:27:07] Loading human mouse movement data.
  • [20:27:08] Successfully loaded human mouse data.
  • [20:27:22] java.net.MalformedURLException: no protocol: nullnull
  • [20:27:22] at java.net.URL.(Unknown Source)
  • [20:27:22] at java.net.URL.(Unknown Source)
  • [20:27:22] at java.net.URL.(Unknown Source)
  • [20:27:22] at obf.WD.nI(jm:64)
  • [20:27:22] at obf.uH.ca(hi:53)
  • [20:27:22] at obf.bi.b(ol:159)
  • [20:27:22] at obf.bi.(ol:48)
  • [20:27:22] at obf.kh.(ym:81)
  • [20:27:22] at obf.uH.(hi:141)
  • [20:27:22] at obf.Xh.(id:36)
  • [20:27:22] at obf.Re.run(vm:275)
  • [20:27:22] at java.lang.Thread.run(Unknown Source)
  • [20:27:22] java.net.MalformedURLException: no protocol: nullnull
  • [20:27:22] at java.net.URL.(Unknown Source)
  • [20:27:22] at java.net.URL.(Unknown Source)
  • [20:27:22] at java.net.URL.(Unknown Source)
  • [20:27:22] at obf.uH.ca(hi:168)
  • [20:27:22] at obf.bi.b(ol:159)
  • [20:27:22] at obf.bi.(ol:48)
  • [20:27:22] at obf.kh.(ym:81)
  • [20:27:22] at obf.uH.(hi:141)
  • [20:27:22] at obf.Xh.(id:36)
  • [20:27:22] at obf.Re.run(vm:275)
  • [20:27:22] at java.lang.Thread.run(Unknown Source)
  • [20:27:22] java.lang.reflect.InvocationTargetException
  • [20:27:22] at java.awt.EventQueue.invokeAndWait(Unknown Source)
  • [20:27:22] at java.awt.EventQueue.invokeAndWait(Unknown Source)
  • [20:27:22] at obf.Xh.(id:57)
  • [20:27:22] at obf.Re.run(vm:275)
  • [20:27:22] at java.lang.Thread.run(Unknown Source)
  • [20:27:22] Caused by: java.lang.NullPointerException
  • [20:27:22] at java.awt.Container.addImpl(Unknown Source)
  • [20:27:22] at java.awt.Container.add(Unknown Source)
  • [20:27:22] at obf.oG.(ad:32)
  • [20:27:22] at obf.Xh.Pa(id:57)
  • [20:27:22] at java.awt.event.InvocationEvent.dispatch(Unknown Source)
  • [20:27:22] at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
  • [20:27:22] at java.awt.EventQueue.access$500(Unknown Source)
  • [20:27:22] at java.awt.EventQueue$3.run(Unknown Source)
  • [20:27:22] at java.awt.EventQueue$3.run(Unknown Source)
  • [20:27:22] at java.security.AccessController.doPrivileged(Native Method)
  • [20:27:22] at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
  • [20:27:22] at java.awt.EventQueue.dispatchEvent(Unknown Source)
  • [20:27:22] at obf.hf.dispatchEvent(wi:177)
  • [20:27:22] at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
  • [20:27:22] at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
  • [20:27:22] at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
  • [20:27:22] at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
  • [20:27:22] at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
  • [20:27:22] at java.awt.EventDispatchThread.run(Unknown Source)
  • [20:27:22] Exception in thread "383"
  • [20:27:22] java.lang.NullPointerException
  • [20:27:22] at java.awt.Container.addImpl(Unknown Source)
  • [20:27:22] at java.awt.Container.add(Unknown Source)
  • [20:27:22] at obf.Re.run(vm:249)
  • [20:27:22] at java.lang.Thread.run(Unknown Source)

I also seem to be having issues with the scripts randomly ending and the repository going down

Edited by dodgedave
Wrote the wrong thing

Share this post


Link to post
Share on other sites
Array
10 hours ago, dfewsloc said:

Looks like ur proxies are bad

No proxies are being used, but thank you for your reply

 

10 hours ago, Fluffee said:

Are you trying to use a proxy? If not, have you tried deleting your .tribot folder? That may help 🙂

Yes, tried deleting the .tribot folder, and also removing any cache traces

Sometimes the client loads up fine, seems to be an intermittent issue.

It leaves me unable to use the client starter to start more than one bot unfortunately.

Share this post


Link to post
Share on other sites
14 hours ago, dodgedave said:

No proxies are being used, but thank you for your reply

 

Yes, tried deleting the .tribot folder, and also removing any cache traces

Sometimes the client loads up fine, seems to be an intermittent issue.

It leaves me unable to use the client starter to start more than one bot unfortunately.

 

14 hours ago, bagszn1 said:

Having same issue anyone know a fix? And also im not using a proxy.

It's possible that both of these issues are caused by the issues the RS servers are facing. At least even earlier today trying to get a vanilla client to load was quite difficult, which might be why the issue is inconsistent 😦

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 25 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...