Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold

Recommended Posts

Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

Why?

  • Increased reliability - less server errors
  • Increased availability - less downtime
  • Increased security - keeping us and you secure
  • Increased capacity - ability to serve you better
  • Increased speed - less waiting for things to load
  • Faster development - server and service updates will come faster

What are the changes?

  • Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)
  • Distributed computing
  • Load balancing
  • Git management of server files and filesystem
  • Redis caching

How?

  • AWS ECS (with 10 EC2 instances)
  • AWS ElastiCache (Redis)
  • AWS Load Balancing
  • AWS EFS (Elastic file system)

Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

Please post on this thread if you experience any issues other than slow loading times.

  • Like 5

Share this post


Link to post
Share on other sites
3 hours ago, TRiLeZ said:

The fix has been successfully applied to the new server, and it has gone live again!

There seems to be an auth issue i believe?  tried adding worthys zulrah trial it didnt work, so i purchased it, the script comes on and off in repo and giving an unable to load error

Edited by kushad

Share this post


Link to post
Share on other sites
1 hour ago, TRiLeZ said:

The latest update (now live) should fix all reported issues.

I'm still experiencing the same issues, 

Scripts that I bought during the "downtime" and scripts that I'm adding right now are still not appearing in the Script Manager.

While refreshing my user panel, half the time it's displaying accurate active subscriptions and the other half it's not.

Share this post


Link to post
Share on other sites
8 minutes ago, tariqll said:

I'm still experiencing the same issues, 

Scripts that I bought during the "downtime" and scripts that I'm adding right now are still not appearing in the Script Manager.

While refreshing my user panel, half the time it's displaying accurate active subscriptions and the other half it's not.

Exact same issue here, scripts that were there before downtime seem to work fine. Others added during are not appearing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By bluefirecorp
      I've been a member of a small community known as Darkscience for ages.
      The small community of just over 100 are primarily are sysadmins, developers, and security experts. The community offers decades of experience in sysadmin, programming, and security. There's plenty of random knowledge out there, such investing/financial experts and even amateur radio hobbyist. 
      Anyway, the community is looking for more members, intelligent people to join be a part of it.
      I've created #tribot and will hand the chan over to any admin. Mods will get OP after verification. Feel free to stop by and visit #darkscience if you just wanna talk with a few random internet people.
      Git service: https://git.drk.sc/
      Mibbit IRC Link: https://client02.chat.mibbit.com/?channel=%23tribot&server=irc.darchoods.net%3A%2B6697
      IRC connection info:
      http://www.darkscience.net/servers/
      https://www.darchoods.net/
       
      And finally other communities:
      https://libsecure.so/
  • Our picks

    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 68 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...