Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
FALSkills

DISCONTINUED - EzQuester v1

Recommended Posts

3 hours ago, FALSkills said:

Added arguments for Dragon Slayer, please babysit :) 

Sorry for the delay in releasing it, designing/implementing some of the things I wanted to turned out to be a fairly big task that I wasn't super thrilled to be working on (so I took it slowly...)

script must've uploaded wrong?

  • [16:22:21] java.lang.NoClassDefFoundError: org/tribot/api2007/types/RSGroundIte

Share this post


Link to post
Share on other sites
2 minutes ago, dayzsa said:

script must've uploaded wrong?

  • [16:22:21] java.lang.NoClassDefFoundError: org/tribot/api2007/types/RSGroundIte

Try deleting TRiBot jars in your .tribot/dependencies folder, as well as the jars in your %TEMP% folder (t1_agent*.jar and os*.jar). That issue is not related to the script but to the TRiBot client.

Edited by FALSkills

Share this post


Link to post
Share on other sites

Bug Report Format:
Argument used: purchase;stamina;useglory;disableidler;dragonslayer;dragonslayermelee;
Screenshot/gif (including paint): didn't take
Bot debug (txt file or pastebin link): didn't take
Client debug (txt file or pastebin link): https://pastebin.com/VGWJUYPT
Any additional info to provide: can't get melee option to work for dragon slayer account has 60/50/41 and 43 prayer

 

Share this post


Link to post
Share on other sites
4 hours ago, kryptonite93 said:

Bug Report Format:
Argument used: purchase;stamina;useglory;disableidler;dragonslayer;dragonslayermelee;
Screenshot/gif (including paint): didn't take
Bot debug (txt file or pastebin link): didn't take
Client debug (txt file or pastebin link): https://pastebin.com/VGWJUYPT
Any additional info to provide: can't get melee option to work for dragon slayer account has 60/50/41 and 43 prayer

 

Try using just "dragonslayermelee" and let me know if you still have problems. I will try to clarify on the pastebin.

Share this post


Link to post
Share on other sites
14 hours ago, kryptonite93 said:

I did try with dragonslayermelee in the bug report I posted

No, you tried it with:
purchase;stamina;useglory;disableidler;dragonslayer;dragonslayermelee;

which has dragonslayer;dragonslayermelee in it

Try it with just dragonslayermelee

Share this post


Link to post
Share on other sites

Not sure if F2P is supported, but i'm trying to do vampire slayer and it gets stuck trying to buy a varrock teleport instead of just walking (or using runes if that's possible?).

purchase;vampireslayer;mousespeed:150;minsleep:250;maxsleep:500;disableidler

  • [16:55:30] EzGrandExchange: Successfully withdrew coins
  • [16:55:39] EzGrandExchange: Using offer slot: 1
  • [16:55:39] EzGrandExchange: Opened buying offer menu.
  • [16:55:42] EzGrandExchange: We do not have enough of: Varrock teleport
  • [16:55:44] EzGrandExchange: Using offer slot: -1
  • [16:55:44] EzGrandExchange: Opened buying offer menu.
  • [16:55:55] EzGrandExchange: We do not have enough of: Varrock teleport
  • [16:55:55] ABCTracker: Picking up mouse.
  • [16:55:56] EzGrandExchange: Using offer slot: -1
  • [16:55:56] EzGrandExchange: Opened buying offer menu.
  • [16:56:04] Script Ended: EzQuester v1.

 

If I try running it wihtout "purchase"

  • [17:51:20] java.lang.NullPointerException
  • [17:51:20] at scripts.ezquests.vampireslayer.o.g(VampireSlayer.java:115)
  • [17:51:20] at scripts.ezquests.vampireslayer.o.g(VampireSlayer.java:431)
  • [17:51:20] at scripts.ezquests.vampireslayer.o.g(VampireSlayer.java:24)
  • [17:51:20] at scripts.ezquests.o.g(EzQuest.java:246)
  • [17:51:20] at scripts.ezquesters.ezquester.tasks.QuestTask.g(QuestTask.java:85)
  • [17:51:20] at scripts.ezquesters.ezquester.EzQuester.run(EzQuester.java:243)
  • [17:51:20] at java.lang.Thread.run(Unknown Source)
  • [17:51:20] Script Ended: EzQuester v1.
Edited by cass2186

Share this post


Link to post
Share on other sites

TreeGnomeVillage failing - was working previously have used the below numerous times on several accounts. It gets hung withdrawing items from bank and then re-deposits them to repeat step two.

purchase;priestinperil;knightssword;hazeelcult;vampireslayer;naturespirit;digsite;biohazard;fightarena;knightssword;vampireslayer;naturespirit;recruitmentdrive;biohazard;treegnomevillage;grandtree;animalmagnetism;dwarfcannon;fishingcontest;lostcity;losttribe;mtd;tearsofguthix;dragonslayerrange;xmarksthespot;xskill:agility;mousespeed:200;minsleep:250;maxsleep:500;usedueling;useglory;stamina;endatge

Bot Debug: https://pastebin.com/SuigVzKK

Client Debug: https://pastebin.com/jAuRTGAR

Share this post


Link to post
Share on other sites
4 hours ago, osrsgf001 said:

TreeGnomeVillage failing - was working previously have used the below numerous times on several accounts. It gets hung withdrawing items from bank and then re-deposits them to repeat step two.

purchase;priestinperil;knightssword;hazeelcult;vampireslayer;naturespirit;digsite;biohazard;fightarena;knightssword;vampireslayer;naturespirit;recruitmentdrive;biohazard;treegnomevillage;grandtree;animalmagnetism;dwarfcannon;fishingcontest;lostcity;losttribe;mtd;tearsofguthix;dragonslayerrange;xmarksthespot;xskill:agility;mousespeed:200;minsleep:250;maxsleep:500;usedueling;useglory;stamina;endatge

Bot Debug: https://pastebin.com/SuigVzKK

Client Debug: https://pastebin.com/jAuRTGAR

Just uploaded potential fix, let me know if the issue persists. If so, please include a screenshot with the script running. Thanks

Share this post


Link to post
Share on other sites
5 minutes ago, osrsgf001 said:

Testing now be in touch soon.

Nope - still an issue but different from previous. Previously it would deposit all items into bank, now its stuck on withdrawing staff, it clearly does withdraw the airstaff (x2 which is what was in my bank) as you can see in my invent. Link to screenshot below.

 

https://gyazo.com/6554b8575a5fb6c7745f1cecf81a4909

Share this post


Link to post
Share on other sites
21 hours ago, osrsgf001 said:

Nope - still an issue but different from previous. Previously it would deposit all items into bank, now its stuck on withdrawing staff, it clearly does withdraw the airstaff (x2 which is what was in my bank) as you can see in my invent. Link to screenshot below.

 

https://gyazo.com/6554b8575a5fb6c7745f1cecf81a4909

Apologies for the delay, I have uploaded another potential fix.  If it is still not working, please contact me via pm or discord.

Share this post


Link to post
Share on other sites

I cant get dragon slayer to work

 Bot uses bank and does nothing until termination

arguement used: "dragonslayer"

same with "dragonslayermelee" , etc

Account has 40+ attack 43+ prayer

Edited by Anarch

Share this post


Link to post
Share on other sites
8 hours ago, Anarch said:

I cant get dragon slayer to work

 Bot uses bank and does nothing until termination

arguement used: "dragonslayer"

same with "dragonslayermelee" , etc

Account has 40+ attack 43+ prayer

Please use the requested bug report format. It thinks you are missing an item but I can't figure out which item without checking the report format.  Try also using the "purchase" argument to get it to purchase whatever is missing. I would still like to know what is missing so that I can teach the script to fix itself. 

6 hours ago, YoHoJo said:

Suggestion:

  • For quests like Cooks Assistant & Imp Catcher, have option to get the items organically vs buying them from the GE.
  • Change argument from 'cooksassistant' to 'cooksass' 🍑

I have an alternative version that does that for Cooks Assistant, but i'm not going to do that for Imp Catcher.  I will look into adding that option for Cooks Assistant soon.

  • Like 1

Share this post


Link to post
Share on other sites

 

Argument used:  dragonslayer;purchase


Screenshot/gif (including paint):


Bot debug (txt file or pastebin link): [17:06:56] C:\Users\Jaren\AppData\Roaming\.tribot


Client debug (txt file or pastebin link): [17:06:56] Script Ended: EzQuester v1.
[17:07:07] Downloading script 'EzQuester v1'.
[17:07:11] Arguments: dragonslayer;purchase
[17:07:11] Script Started: EzQuester v1.
[17:07:11] Setting up global walk condition.
[17:07:11] Received argument: dragonslayer
[17:07:11] Received argument: purchase
[17:07:11] Task number 1: SetupTask
[17:07:11] Task number 2: DragonSlayer
[17:07:13] We already have all quest items!
[17:07:19] PlayerExaminer: Inspecting player: BuckinThanos using method: Right click
[17:07:19] Out of item: [email protected]
[17:07:19] Out of item: [email protected]
[17:07:19] Out of item: [email protected]
[17:07:19] We have failed the previous task: DragonSlayer
[17:07:25] Out of item: [email protected]
[17:07:25] Out of item: [email protected]
[17:07:25] Out of item: [email protected]
[17:07:25] Out of item: [email protected]
[17:07:25] We have failed the previous task: DragonSlayer
[17:07:29] Out of item: [email protected]
[17:07:29] Out of item: [email protected]
[17:07:29] Out of item: [email protected]
[17:07:29] Out of item: [email protected]
[17:07:29] We have failed the previous task: DragonSlayer
[17:07:33] Out of item: [email protected]
[17:07:33] Out of item: [email protected]
[17:07:33] Out of item: [email protected]
[17:07:33] Out of item: [email protected]
[17:07:33] We have failed the previous task: DragonSlayer
[17:07:37] Out of item: [email protected]
[17:07:37] Out of item: [email protected]
[17:07:37] Out of item: [email protected]
[17:07:37] Out of item: [email protected]
[17:07:37] We have failed the previous task: DragonSlayer
[17:07:42] We have failed 5+ tasks. Ending script.
[17:07:42] Script Ended: EzQuester v1.

 

Share this post


Link to post
Share on other sites
1 hour ago, SnaDouble C said:

i cant run the script, it starts GUI pops up and then immediately shuts down says java.lang something (unknown source)

 

help?

Please read the first post. There is no GUI.

If you can report the error using the bug report form on the first post I can help figure out why it may not be working.

Share this post


Link to post
Share on other sites
15 hours ago, Anarch said:


 

Spoiler

 

Argument used:  dragonslayer;purchase


Screenshot/gif (including paint):


Bot debug (txt file or pastebin link): [17:06:56] C:\Users\Jaren\AppData\Roaming\.tribot


Client debug (txt file or pastebin link): [17:06:56] Script Ended: EzQuester v1.
[17:07:07] Downloading script 'EzQuester v1'.
[17:07:11] Arguments: dragonslayer;purchase
[17:07:11] Script Started: EzQuester v1.
[17:07:11] Setting up global walk condition.
[17:07:11] Received argument: dragonslayer
[17:07:11] Received argument: purchase
[17:07:11] Task number 1: SetupTask
[17:07:11] Task number 2: DragonSlayer
[17:07:13] We already have all quest items!
[17:07:19] PlayerExaminer: Inspecting player: BuckinThanos using method: Right click
[17:07:19] Out of item: [email protected]
[17:07:19] Out of item: [email protected]
[17:07:19] Out of item: [email protected]
[17:07:19] We have failed the previous task: DragonSlayer
[17:07:25] Out of item: [email protected]
[17:07:25] Out of item: [email protected]
[17:07:25] Out of item: [email protected]
[17:07:25] Out of item: [email protected]
[17:07:25] We have failed the previous task: DragonSlayer
[17:07:29] Out of item: [email protected]
[17:07:29] Out of item: [email protected]
[17:07:29] Out of item: [email protected]
[17:07:29] Out of item: [email protected]
[17:07:29] We have failed the previous task: DragonSlayer
[17:07:33] Out of item: [email protected]
[17:07:33] Out of item: [email protected]
[17:07:33] Out of item: [email protected]
[17:07:33] Out of item: [email protected]
[17:07:33] We have failed the previous task: DragonSlayer
[17:07:37] Out of item: [email protected]
[17:07:37] Out of item: [email protected]
[17:07:37] Out of item: [email protected]
[17:07:37] Out of item: [email protected]
[17:07:37] We have failed the previous task: DragonSlayer
[17:07:42] We have failed 5+ tasks. Ending script.
[17:07:42] Script Ended: EzQuester v1.

 


 

I can't help if you don't provide all of the requested content. In 100% of bug report cases I will need a screenshot including the paint to know which step in which quest you are on, and importantly what the current STATE of the script is.  If you have any extra information to provide, like "I am trying this on a f2p account", then that would also be beneficial. Help me help you!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 65 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...