Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
FALSkills

DISCONTINUED - EzQuester v1

Recommended Posts

1 hour ago, wristband43 said:

Just used the trial and checked in after roughly 8:30 minutes in it was just stuck at the bank on digsite.

 

edit: still gets stuck without stamina argument and trying to remove null items from bank and often gets stuck trying to click something in the bank its not scrolled to.

Please report issues using the bug report format on the first post of the thread.  I cannot do anything with the information you've provided.  First, I would try clearing your cache as it sounds like your client is not behaving properly. Here is a link to a file that does it for you: 

 

Edited by FALSkills

Share this post


Link to post
Share on other sites
Array
8 hours ago, FALSkills said:

I recently update the core framework of all quests which is unfortunately going to break several of the withdrawing tasks for different quests.  I am not home to push the fix right now, but I will get it updated as soon as possible.  

 

edit: if you encounter an issue like this and would like to force the script to proceed for now, usually (but not always) removing the "stamina" argument will resolve the issue. Please also let me know which quest though.

I tried to remove the stam argument but that also didnt work for lost city. Everything else has worked great for me, thanks. I just manually did lost city though now. 

Edited by Engzy

Share this post


Link to post
Share on other sites
3 hours ago, FALSkills said:

Please report issues using the bug report format on the first post of the thread.  I cannot do anything with the information you've provided.  First, I would try clearing your cache as it sounds like your client is not behaving properly. Here is a link to a file that does it for you: 

 

Merlin's crystal is broken for withdrawing items, could you have it fixed when you get the chance?  Not sure about what else may not work, but for merlins crystal it just stops the script.

Share this post


Link to post
Share on other sites
54 minutes ago, Androbolic said:

Merlin's crystal is broken for withdrawing items, could you have it fixed when you get the chance?  Not sure about what else may not work, but for merlins crystal it just stops the script.

I just updated it, let me know if it's working now.

Share this post


Link to post
Share on other sites

bot seems to be breaking at the ge occasionally.  started up 4 accs with witch's potion as well, all bought the stuff at ge and script ended after 5 failed attempts trying to get lobsters or something from the ge.  had cash and everything lost the bot debug though if i get it ill send on here

 

Edit: was monitoring the bot more, its buying combat bracelet (6) and for some reason the ge selling price is going way above the normal for like 60-100k even though it advertises as 13k at the ge.  Could the bot switch to buying combat bracelet (4)'s instead people are selling them regular price.  The bot was crashing when it was unable to buy the combat bracelets and waiting a long time

bring more lobsters to duel arena, bot died while there.  also could not select monkfish, shark or other foods in the arguments setting as it broke the bot when starting and glitched the GE

edit 2: while banking at edgeville, bot mouse just kept moving left and right in the bank and was not doing anything.  debug said no safespot that was it.  reran script and fixed it.  does the bot use ring of wealths for ge and teleports?  maybe add that feature if its not in

Edited by Androbolic

Share this post


Link to post
Share on other sites
6 hours ago, Androbolic said:

bot seems to be breaking at the ge occasionally.  started up 4 accs with witch's potion as well, all bought the stuff at ge and script ended after 5 failed attempts trying to get lobsters or something from the ge.  had cash and everything lost the bot debug though if i get it ill send on here

 

Edit: was monitoring the bot more, its buying combat bracelet (6) and for some reason the ge selling price is going way above the normal for like 60-100k even though it advertises as 13k at the ge.  Could the bot switch to buying combat bracelet (4)'s instead people are selling them regular price.  The bot was crashing when it was unable to buy the combat bracelets and waiting a long time

bring more lobsters to duel arena, bot died while there.  also could not select monkfish, shark or other foods in the arguments setting as it broke the bot when starting and glitched the GE

edit 2: while banking at edgeville, bot mouse just kept moving left and right in the bank and was not doing anything.  debug said no safespot that was it.  reran script and fixed it.  does the bot use ring of wealths for ge and teleports?  maybe add that feature if its not in

As I have already asked you, please submit bug reports using the bug report format.  
Bug Report Format:
Argument used: 
Screenshot/gif (including paint):
Bot debug (txt file or pastebin link):
Client debug (txt file or pastebin link):
Any additional info to provide:

Any other form of report is likely to contain only partial information that will make it much harder to find out how to fix whatever issues you are experiencing.

  • Fixed several instances of quests that were not using the food name that can be configured via arg. This should fix the Witch's Potion issue.

Anything else I don't really have a solution in mind.  I don't plan on changing prices due to market fluctuations - the script has functionality for you to specify custom pricing already:
"custompricing" -  checks file prices.txt in .tribot/ezquester/ for items, edits prices to desired price. ITEM_NAME:PRICE (Redberry pie:10000) one per line

I don't know why your bot would be at the duel arena or how it would die there.

I have no idea what your bot was doing banking at edgeville without more information.

Share this post


Link to post
Share on other sites
3 hours ago, FALSkills said:

As I have already asked you, please submit bug reports using the bug report format.  
Bug Report Format:
Argument used: 
Screenshot/gif (including paint):
Bot debug (txt file or pastebin link):
Client debug (txt file or pastebin link):
Any additional info to provide:

Any other form of report is likely to contain only partial information that will make it much harder to find out how to fix whatever issues you are experiencing.

  • Fixed several instances of quests that were not using the food name that can be configured via arg. This should fix the Witch's Potion issue.

Anything else I don't really have a solution in mind.  I don't plan on changing prices due to market fluctuations - the script has functionality for you to specify custom pricing already:
"custompricing" -  checks file prices.txt in .tribot/ezquester/ for items, edits prices to desired price. ITEM_NAME:PRICE (Redberry pie:10000) one per line

I don't know why your bot would be at the duel arena or how it would die there.

I have no idea what your bot was doing banking at edgeville without more information.

meant to say fight arena quest instead of duel arena.  Can the bot just bring more food for the fight arena quest i believe it ran out and died.  I'll be supervising some more bots tonight, I'll get you all the bug report formats for what needs to be fixed when I can find it.

Share this post


Link to post
Share on other sites
4 minutes ago, Androbolic said:

meant to say fight arena quest instead of duel arena.  Can the bot just bring more food for the fight arena quest i believe it ran out and died.  I'll be supervising some more bots tonight, I'll get you all the bug report formats for what needs to be fixed when I can find it.

It should be safespotting for the fight arena quest.  Please provide a gif of what is happening if it is not safe spotting.

Share this post


Link to post
Share on other sites
43 minutes ago, FALSkills said:

It should be safespotting for the fight arena quest.  Please provide a gif of what is happening if it is not safe spotting.

it safe spots but gets damaged a bit in the process while getting to the safe spot, could just be that my computers lagging possibly?  Can ring of wealth feature be added for teleproting to ge and other places for quests?  

Share this post


Link to post
Share on other sites
3 minutes ago, Androbolic said:

it safe spots but gets damaged a bit in the process while getting to the safe spot, could just be that my computers lagging possibly?  Can ring of wealth feature be added for teleproting to ge and other places for quests?  

It automatically withdraws a Ring of wealth OR varrock teleport, if found, during the PurchaseTask.

Share this post


Link to post
Share on other sites
5 hours ago, FALSkills said:

It automatically withdraws a Ring of wealth OR varrock teleport, if found, during the PurchaseTask.

oh just noticed that.  i ran the bots and it has an error at witch's potion still with withdrawing quest items.  here is the client debug, for some reason says rats tail false and same with burnt meat.  Will then say failed previous task, and repeat 5 times before stopping script.  However the bot seems to have taken a break here

 

for black knights fortress, script keeps ending when starting the quest getting the items and does not work until its manually restarted.  same arguments below, anything wrong?  here is the debug

  • [16:28:39] Setting food name to: Lobster
  • [16:28:40] ABCTracker: Moving mouse.
  • [16:28:47] We have failed the previous task: BlackKnightsFortress
  • [16:28:47] Since this task has a purchase list, we will see if purchasing items allows us to complete the task.
  • [16:28:51] Setting food name to: Lobster
  • [16:28:52] Setting food name to: Lobster
  • [16:28:52] We have failed 5+ tasks. Ending script.

 

Arguments: Purchase;usedueling;useglory;usecombatbrace;foodname:Monkfish;staminacount:2;staminapurchasecount:10;stamina;witchspotion;impcatcher;witchshouse;waterfall;vampireslayer;treegnomevillage;fightarena;doricsquest;cooksassistant;druidicritual;blackknightsfortress;recruitmentdrive;plaguecity;biohazard;hazeelcult;xmarksthespot;xskill:agility;breakafterquests:4;minbreaklength:5;maxbreaklength:15;endatge;mousespeed:190;minsleep:120;maxsleep:240

 

Pic of the bot graphics: 7636562ffb9e5d9528c0349498f580e3.png
https://gyazo.com/7636562ffb9e5d9528c0349498f580e3

 

Bot Debug: None

  • [13:27:40] Login bot started.
  • [13:27:40] Login Bot: Login...
  • [13:27:42] Login bot succeeded.
  • [13:27:44] Rat's tail: false
  • [13:27:45] InteractionHelper: Rotating camera to make target visible. Current attempts: 2
  • [13:27:48] Rat's tail: false
  • [13:27:49] Rat's tail: false
  • [13:27:49] Withdrawing item: Stamina potion
  • [13:27:54] PlayerExaminer: Inspecting player: JettaTDi using method: Look at only
  • [13:27:54] Withdrawing item: Other meat
  • [13:27:56] Missing item: Burnt meat
  • [13:27:56] We have failed the previous task: WitchsPotion
  • [13:27:56] Since this task has a purchase list, we will see if purchasing items allows us to complete the task.
  • [13:28:00] Breaking for: 00:07:01
Edited by Androbolic

Share this post


Link to post
Share on other sites

Priest in peril very buggy!!

during dog fight, brings absolutely no food when the script is told to in the arguments.  Then it kills zamorak magesafand does not pick up the gold key.  Sits there saying "eating" when it has 0 food to eat.  Please run it yourself

Edited by Androbolic

Share this post


Link to post
Share on other sites
3 hours ago, Androbolic said:

Priest in peril very buggy!!

during dog fight, brings absolutely no food when the script is told to in the arguments.  Then it kills zamorak magesafand does not pick up the gold key.  Sits there saying "eating" when it has 0 food to eat.  Please run it yourself

I can't help you if you don't provide bug reports using the requested format.  There are specific configurations that you may be using which I might not be testing myself.  Provide the full bug report and I don't need to run it myself, because the info is present in what you've given me.

I will investigate the quests you have mentioned.  Please try clearing your client cache to see if that helps. 

 

Edited by FALSkills

Share this post


Link to post
Share on other sites
2 hours ago, FALSkills said:

I can't help you if you don't provide bug reports using the requested format.  There are specific configurations that you may be using which I might not be testing myself.  Provide the full bug report and I don't need to run it myself, because the info is present in what you've given me.

I will investigate the quests you have mentioned.  Please try clearing your client cache to see if that helps. 

 

I tried clearing cache, same issue. 

 

Bug Report Format:
Argument used: Purchase;usedueling;useglory;usecombatbrace;foodname:Monkfish;staminacount:2;staminapurchasecount:10;stamina;witchspotion;impcatcher;witchshouse;waterfall;vampireslayer;treegnomevillage;fightarena;doricsquest;cooksassistant;druidicritual;blackknightsfortress;recruitmentdrive;plaguecity;biohazard;hazeelcult;xmarksthespot;xskill:agility;breakafterquests:4;minbreaklength:5;maxbreaklength:15;endatge;mousespeed:190;minsleep:120;maxsleep:240
Screenshot/gif (including paint): 7636562ffb9e5d9528c0349498f580e3.png
Bot debug (txt file or pastebin link): 

  • [] Setting food name to: Lobster
  • [] ABCTracker: Moving mouse.
  • [] We have failed the previous task: Witch's Potion
  • [] Since this task has a purchase list, we will see if purchasing items allows us to complete the task.
  • [] Setting food name to: Lobster
  • [] Setting food name to: Lobster
  • [] We have failed 5+ tasks. Ending script

Client debug (txt file or pastebin link): 

nothing is showing up for client debug

Share this post


Link to post
Share on other sites

Seems that a past update prevented custom food args from working, so that is probably why it has been quitting out on you.  Please be sure to post the entire bug report, excluding parts of the debug is not a full bug report.  I want to see everything from when EzQuester started running.

Share this post


Link to post
Share on other sites

Argument used: Purchase;grandtree;foodname:Lobster;mousespeed:200;minsleep:250;maxsleep:500
Screenshot/gif (including paint): https://gyazo.com/c4f490261bcab402215906c0e40e3359

Bot debug (txt file or pastebin link): 
[15:04:48] java.lang.NullPointerException
[15:04:48]     at scripts.ezquesters.ezquester.EzQuester.passArguments(EzQuester.java:64)
[15:04:48]     at obf.lD.SA(zd:336)
[15:04:48]     at java.lang.Thread.run(Unknown Source)


Client debug (txt file or pastebin link):

[15:05:48] Arguments: Purchase;grandtree;foodname:Lobster;mousespeed:200;minsleep:250;maxsleep:500
[15:05:48] Script Started: EzQuester v1.
[15:05:49] Setting up global walk condition.
[15:05:49] Received argument: Purchase
[15:05:49] Received argument: grandtree
[15:05:49] Received argument: foodname:Lobster
[15:05:49] Received argument: mousespeed:200
[15:05:49] Received argument: minsleep:250
[15:05:49] Received argument: maxsleep:500
[15:05:49] Task number 1: SetupTask
[15:05:49] Task number 2: GrandTree
[15:05:50] We already have all quest items!

 

Any additional info to provide:

The paint says "managing_combat", has not started the quest and has all requirements, just equips staff and sits in the bank stuck for hours, I have deleted hooks, cache etc.

  • Like 1

Share this post


Link to post
Share on other sites
59 minutes ago, dodgedave said:

Argument used: Purchase;grandtree;foodname:Lobster;mousespeed:200;minsleep:250;maxsleep:500
Screenshot/gif (including paint): https://gyazo.com/c4f490261bcab402215906c0e40e3359

Bot debug (txt file or pastebin link): 
[15:04:48] java.lang.NullPointerException
[15:04:48]     at scripts.ezquesters.ezquester.EzQuester.passArguments(EzQuester.java:64)
[15:04:48]     at obf.lD.SA(zd:336)
[15:04:48]     at java.lang.Thread.run(Unknown Source)


Client debug (txt file or pastebin link):

[15:05:48] Arguments: Purchase;grandtree;foodname:Lobster;mousespeed:200;minsleep:250;maxsleep:500
[15:05:48] Script Started: EzQuester v1.
[15:05:49] Setting up global walk condition.
[15:05:49] Received argument: Purchase
[15:05:49] Received argument: grandtree
[15:05:49] Received argument: foodname:Lobster
[15:05:49] Received argument: mousespeed:200
[15:05:49] Received argument: minsleep:250
[15:05:49] Received argument: maxsleep:500
[15:05:49] Task number 1: SetupTask
[15:05:49] Task number 2: GrandTree
[15:05:50] We already have all quest items!

 

Any additional info to provide:

The paint says "managing_combat", has not started the quest and has all requirements, just equips staff and sits in the bank stuck for hours, I have deleted hooks, cache etc.

Seems to be happening to any quest with combat.

Share this post


Link to post
Share on other sites
3 hours ago, dodgedave said:

Seems to be happening to any quest with combat.

never seen that before, been running lots of quests on my bots.  I'm doing a rerun of almost half the quests going to do bug reports of what I find.  In your arguments, remove the line "foodname:lobster", its already lobster by default and I found that adding different food besides the default makes the bot a bit glitchy still after the fix but I'm managing with just lobsters

 

edit: started witch's potion on a few accounts, ran smoothly this time instead of crashing starting the quest at the ge.  Will update further on, got about 15 quests total on my list. 

Edited by Androbolic

Share this post


Link to post
Share on other sites

never mind, found a bug in witch's potion. 

arguments: Purchase;usedueling;useglory;usecombatbrace;staminacount:2;staminapurchasecount:8;stamina;witchspotion;doricsquest;impcatcher;witchshouse;waterfall;vampireslayer;treegnomevillage;fightarena;cooksassistant;druidicritual;blackknightsfortress;recruitmentdrive;plaguecity;biohazard;hazeelcult;xmarksthespot;xskill:agility;endatge;mousespeed:150

Screenshot: https://gyazo.com/1c8d3931cfaaaf74501071d34bca5513

bot debug:  attatched file, very long

client debug: attatched file also long

addtional info:  bot starts quest and talks to hetty.  however keeps repeating the step and continues to talk to hetty had to stop the script. also does this at the ge infinetly until manually stopped (gif #2 down below)

https://gyazo.com/38d0f5fff5ad26b9686d196d5436c511

bot debug.txt client debug.txt

Edited by Androbolic

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 49 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 25 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...