Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
FALSkills

EzQuester [Beta]

Recommended Posts

1 hour ago, gavin101 said:

demon slayer my character got stuck trying to attack the demon because he was under attack by the wizards already. turned auto retaliate on and intervened to fix it

Added a state to enable auto retaliate if not enabled.
It will retaliate against wizards and killed them if attacked. Not very easy to handle losing aggro.

1 hour ago, IamToxic said:

By any chance can you add an argument to use spells that scale up to magic level?

I will work on something for the time being, but in the future it will be fully customizable for things like this.

Share this post


Link to post
Share on other sites

script isnt recognizing that it's in combat with a black unicorn while talking to Svidi during MTD quest. Keep trying to talk to him while we're being attacked. (character eventually killed it with auto retaliate but the script also kept trying to talk to the npc during combat.)

Share this post


Link to post
Share on other sites

Argument used: purchase;vampireslayer;treegnomevillage;demonslayer;mousespeed:200;minsleep:150;maxsleep:500
Screenshot/gif (including paint): N/A
Bot debug (pastebin link): https://pastebin.com/TDdYBGQp
Client debug (pastebin link): https://pastebin.com/FzErTcFY
Any additional info to provide: The bot was at the GE trying to buy the required items. It didn't try to buy the hammer which is why the script broke in the end. It did go into a cycle of rapidly opening and closing both the bank and the ge interfaces.

Share this post


Link to post
Share on other sites
12 hours ago, gavin101 said:

script isnt recognizing that it's in combat with a black unicorn while talking to Svidi during MTD quest. Keep trying to talk to him while we're being attacked. (character eventually killed it with auto retaliate but the script also kept trying to talk to the npc during combat.)

I had combat checks in there, but they must not have been working for whatever reason. I made the combat checks more lenient.

4 hours ago, flamekiller999 said:

Argument used: purchase;vampireslayer;treegnomevillage;demonslayer;mousespeed:200;minsleep:150;maxsleep:500
Screenshot/gif (including paint): N/A
Bot debug (pastebin link): https://pastebin.com/TDdYBGQp
Client debug (pastebin link): https://pastebin.com/FzErTcFY
Any additional info to provide: The bot was at the GE trying to buy the required items. It didn't try to buy the hammer which is why the script broke in the end. It did go into a cycle of rapidly opening and closing both the bank and the ge interfaces.

Added hammer to Vampire Slayer purchase list

Share this post


Link to post
Share on other sites

Needed to intervene for fishing contest:

It got the garlic from the house and then camelot tabbed and ran back to the fishing content(pathing logic error?)

Then it ran to the fishing contest, put the garlic in and went into a [waiting for contest to end] state and did that whole thing without going to the gated woods and getting the bait to fish with

 

Share this post


Link to post
Share on other sites

Seems to be stuck going through doors and ladders, with some of the notable ones being during druidic ritual while exiting the dungeon after dipping the meats, knights sword when it tries to go back to talk to thurgo and restless ghost after finding the skeleton in the wizards tower.

Share this post


Link to post
Share on other sites
2 hours ago, gavin101 said:

Needed to intervene for fishing contest:

It got the garlic from the house and then camelot tabbed and ran back to the fishing content(pathing logic error?)

Then it ran to the fishing contest, put the garlic in and went into a [waiting for contest to end] state and did that whole thing without going to the gated woods and getting the bait to fish with

 

Please use the bug report format. Otherwise I have to guess at what is happening.  If you submit using the bug report format, I can see exactly what is happening.  I am guessing that your account already had the quest in progress. I am testing an updated version locally to see if it obtains the items properly when missing.

Share this post


Link to post
Share on other sites
1 hour ago, cheeko said:

Seems to be stuck going through doors and ladders, with some of the notable ones being during druidic ritual while exiting the dungeon after dipping the meats, knights sword when it tries to go back to talk to thurgo and restless ghost after finding the skeleton in the wizards tower.

Please try reloading your client.  There should be no issues with navigation like you are describing, it is likely an issue with your client.  If the issue persists, please submit proper bug reports so that I can see what and why things aren't working.

Share this post


Link to post
Share on other sites

Argument used: purchase;knightssword;knightssword;vampireslayer;mousespeed:200;minsleep:250;maxsleep:500

Screenshot/gif (including paint): N/A
Bot debug (pastebin link): https://pastebin.com/a7hpArs4
Client debug (pastebin link): https://pastebin.com/4ScPzCBk
Any additional info to provide: The bot withdraws all the required items, then rebanks them all, then withdraws them again. This occurs for the Vampire Slayer quest, have had other issues with the quest as well in previous posts. Not sure if it may be one to look further in to. Also for the Knight's Sword quest, there was an issue at the stage "Walking to blurite" it stayed at the Dwarfs house (can't remember his name) and the webwalker had some issues I believe, should be seen in the debug. (Also I know, derp on putting knights sword twice into the args ;) )

 

Share this post


Link to post
Share on other sites

Also on another quest when walking to Trufitus from Ardy north bank for the Jungle Potion quest. Have an issue, on the state: "WALKING_TO_TRUFITUS"

 

Argument used: purchase;knightssword;knightssword;vampireslayer;mousespeed:200;minsleep:250;maxsleep:500

Bot Debug: https://pastebin.com/cpHxjUiG

Client Debug: https://pastebin.com/2VbS9PA3

The bot just stands at the bank because the WebWalker cannot determine a route

Edited by flamekiller999

Share this post


Link to post
Share on other sites
2 hours ago, flamekiller999 said:

Argument used: purchase;knightssword;knightssword;vampireslayer;mousespeed:200;minsleep:250;maxsleep:500

Screenshot/gif (including paint): N/A
Bot debug (pastebin link): https://pastebin.com/a7hpArs4
Client debug (pastebin link): https://pastebin.com/4ScPzCBk
Any additional info to provide: The bot withdraws all the required items, then rebanks them all, then withdraws them again. This occurs for the Vampire Slayer quest, have had other issues with the quest as well in previous posts. Not sure if it may be one to look further in to. Also for the Knight's Sword quest, there was an issue at the stage "Walking to blurite" it stayed at the Dwarfs house (can't remember his name) and the webwalker had some issues I believe, should be seen in the debug. (Also I know, derp on putting knights sword twice into the args ;) )

 

Please submit a screenshot including paint with reports. It is applicable every time as it tells me where exactly to look in the code.  It also would show me your inventory so I can determine which item(s) are causing hangups.  I have no real clue right now otherwise.

There are no issues in the debug in relation to walking from the imcando dwarve. Please submit a separate report if you encounter another issue.  If you check the recent messages in the Client Debug, it often will say things such as idling which means it's currently taking a short break between actions.

2 hours ago, flamekiller999 said:

Also on another quest when walking to Trufitus from Ardy north bank for the Jungle Potion quest. Have an issue, on the state: "WALKING_TO_TRUFITUS"

 

Argument used: purchase;knightssword;knightssword;vampireslayer;mousespeed:200;minsleep:250;maxsleep:500

Bot Debug: https://pastebin.com/cpHxjUiG

Client Debug: https://pastebin.com/2VbS9PA3

The bot just stands at the bank because the WebWalker cannot determine a route

I will add coins to item list if account does not have a glory equipped. I would suggest using the arguments which maintain a charged glory/dueling/combat bracelet between tasks (not all are necessary, but each one is useful)

Share this post


Link to post
Share on other sites
14 hours ago, FALSkills said:

Please use the bug report format. Otherwise I have to guess at what is happening.  If you submit using the bug report format, I can see exactly what is happening.  I am guessing that your account already had the quest in progress. I am testing an updated version locally to see if it obtains the items properly when missing.

Sorry, if I end up using the script for another quest ill make sure to use the proper format. I will let you know that the quest wasn't started before using the script though.

Share this post


Link to post
Share on other sites

Argument used: purchase;doricsquest;knightssword;stamina;staminacount4
Screenshot/gif (including paint): didn't get.
Bot debug (pastebin link): https://pastebin.com/9cg7yBNK
Client debug (pastebin link): https://pastebin.com/dbf9wisfAny additional info to provide: Fally tabs were over 1k therefore not instabuying and the script would close the ge interface > go to withdraw items for quest > withdraw the other items for quest > realize it didn't have fally tabs and would abort the offer and repeat instead of just leaving in or increasing price. 

Going to run a few more accounts will update to include a gif if I come across this again. 

 

Found another issue while walking back to Thurgo after mining the blurite. Just gets stuck here handling the ladder. 

Updated bot debug: https://pastebin.com/d83DvKyr

Updated Client debug : https://pastebin.com/4FvQa142

1370338341_questerissue.gif.758aec0a392da19e64a61e83de6a8f9b.gif

Edited by FieryWaterWS

Share this post


Link to post
Share on other sites
40 minutes ago, FieryWaterWS said:

Argument used: purchase;doricsquest;knightssword;stamina;staminacount4
Screenshot/gif (including paint): didn't get.
Bot debug (pastebin link): https://pastebin.com/9cg7yBNK
Client debug (pastebin link): https://pastebin.com/dbf9wisfAny additional info to provide: Fally tabs were over 1k therefore not instabuying and the script would close the ge interface > go to withdraw items for quest > withdraw the other items for quest > realize it didn't have fally tabs and would abort the offer and repeat instead of just leaving in or increasing price. 

Going to run a few more accounts will update to include a gif if I come across this again. 

 

Found another issue while walking back to Thurgo after mining the blurite. Just gets stuck here handling the ladder. 

Updated bot debug: https://pastebin.com/d83DvKyr

Updated Client debug : https://pastebin.com/4FvQa142

1370338341_questerissue.gif.758aec0a392da19e64a61e83de6a8f9b.gif

Few things:

  1. Updated Knight's Sword purchase list to use better pricing algorithm
  2. argument "staminacount4" is incorrect, should be using "staminacount:4"
  3. I checked the navigation issue you showed and was not experiencing it on my end. Please try reloading your client; your client was not detecting the ladder.

Share this post


Link to post
Share on other sites
On 8/9/2019 at 4:13 PM, FALSkills said:

Few things:

  1. Updated Knight's Sword purchase list to use better pricing algorithm
  2. argument "staminacount4" is incorrect, should be using "staminacount:4"
  3. I checked the navigation issue you showed and was not experiencing it on my end. Please try reloading your client; your client was not detecting the ladder.

I had this same problem I just clicked the ladder and he went up.

Share this post


Link to post
Share on other sites

Used a on fresh account on brand new IP, had no issues other than working out arguments. Some said argument not recognized, unsure if it meant food or the one after (foodname:Lobster;useglory) but it used the glory so im not 100% sure what its referring too. Other than that it works perfectly.

 

P.S for the new argument people just pretype what you want in a notepad or w.e and copy and paste it and fix errors if you have any.

Share this post


Link to post
Share on other sites
9 hours ago, zickzucker said:

Used a on fresh account on brand new IP, had no issues other than working out arguments. Some said argument not recognized, unsure if it meant food or the one after (foodname:Lobster;useglory) but it used the glory so im not 100% sure what its referring too. Other than that it works perfectly.

 

P.S for the new argument people just pretype what you want in a notepad or w.e and copy and paste it and fix errors if you have any.

Looks like I forgot to add the argument for food name, should be fixed now.

I highly recommend using something like notepad, google sheets, excel, etc. to manage arguments.  Google sheets / excel can make life very easy if done properly.

Share this post


Link to post
Share on other sites
18 hours ago, Dabs710 said:

Tested on maybe 15 quests black knights fortress is broke jungle potion is buggy other than that it's been incredible would've taken me 3 weeks to do the quests I've done today

Black Knight's Fortress is working perfectly fine for me.  Please submit a bug report using the format in the first post if you experience issues.
I will do a run-through of Jungle Potion and see what may have been "buggy"

 

 

16 hours ago, dfewsloc said:

got stuck buying lobsters would only withdraw 1k coins and try buy 10 lobsters @ 100+ ea then would bank coins withdraw 1k again and do it again, besides that beast script so far :D

Please submit a bug report using the format in the first post so that I can find out why you were experiencing that issue.  The prices should dynamically update based off of the RSBuddy GE price.  There is also an argument for custom item pricing.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 25 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 70 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 23 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...