Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Xevii

[SOLVED] TriBot unable to send mouse clicks (?)

Recommended Posts

Posted (edited)

- - - - - -

Hello,

I am having an issue with TriBot if anyone could help. I am using LG with OSbuddy, JDK 102, Windows 10. Worked fine 3 or so days ago when i last used it.

Today (after update) my TriBot client seems unable to left/right click anything. With user input enabled and no script loaded, i can't left/right click anywhere, only move the mouse. Note that a regular client i.e. not via LG can click fine, this issue seems to just be with LG.

When I load a script, i don't seem to get any errors but the script eventually afk's out - it seems like it can't send left/right clicks either. interestingly, i have no keyboard input on the OSBuddy client while it is hooked, but i can left/right click within it - just not the TriBot LG client.

I am a new TriBot user so forgive me if this is a trivial issue. I have attempted to search the forums high and wide but to no avail (the wait time between searches is infuriating but I understand). I have read many FAQs that I found but none seem to describe my issue.

I see a lot of people having black screen LG issues after the recent update but that's not quite the issue i'm having but maybe related. I have tried many generic solutions such as deleting hooks.dat file, jagex_cl_oldschool_LIVE.dat file and jagex cache directory etc. with no luck.

Any help with this matter would be greatly appreciated.

Thanks

Edited by Xevii

Share this post


Link to post
Share on other sites
2 hours ago, Fluffee said:

I've just heard about this recently, but try navigating to the %temp% directory and deleting any LG or TRiBot .jar files that are there. That may help. If not, send me a message and I'll see if I can assist 🙂

I'm having the same issue. I tried deleting any LG or tribot.jar files but still no input detected from tribot

Share this post


Link to post
Share on other sites
7 hours ago, Fluffee said:

I've just heard about this recently, but try navigating to the %temp% directory and deleting any LG or TRiBot .jar files that are there. That may help. If not, send me a message and I'll see if I can assist 🙂

Thank you for the reply. I cleared my temp folder entirely, unfortunately the issue still persists :c

Share this post


Link to post
Share on other sites

Is anyone able to shine some light on this issue? I have been unable to get a hold of Fluffee, I think he's a busy guy.

I have been unable to use TriBot for the past 6 days because of this issue and I can see my subscription/activation time for all my purchases just ticking away... (no way to pause that is there?).

Share this post


Link to post
Share on other sites
Posted (edited)

Hello,

I am finally no longer experiencing this issue ^^ 

I initially nuked any trace of OSBuddy/Tribot/any rs client I had and re-downloaded the .jar's and tried again. I also tried reinstalling JDK 102 and 112 (the recommended versions for LG) but with no luck. I am currently using JDK8 update 221 (64-bit) - not sure if this is a factor.

I eventually found the problem to be a setting in OSBuddy. "Use system titlebar and borders" under Client settings. I guess I had turned this on at some point when I started getting this issue. When on, TriBot hooks into OSBuddy but is unable to click.

When toggled off, TriBot can hook into OSBuddy and the clicking issue is no longer present. Sometimes need to restart OSBuddy when enabling/disabling this setting but otherwise I can consistently click when setting is off and can't click with setting on.

0uVmRE.png

Seems safe to say that this was the problem, at least for me. I hope this helps anyone else who also experiences this issue ^^

tagging people that I've read have the same issue I think: @jnvl2 @IDontActuallyLift @cass2186 @Louis @SlarkenTV @carrynoob123

Cheers

 

 

 

Edited by Xevii
  • Like 1

Share this post


Link to post
Share on other sites
On 7/26/2019 at 11:09 AM, Xevii said:

Hello,

I am finally no longer experiencing this issue ^^ 

I initially nuked any trace of OSBuddy/Tribot/any rs client I had and re-downloaded the .jar's and tried again. I also tried reinstalling JDK 102 and 112 (the recommended versions for LG) but with no luck. I am currently using JDK8 update 221 (64-bit) - not sure if this is a factor.

I eventually found the problem to be a setting in OSBuddy. "Use system titlebar and borders" under Client settings. I guess I had turned this on at some point when I started getting this issue. When on, TriBot hooks into OSBuddy but is unable to click.

When toggled off, TriBot can hook into OSBuddy and the clicking issue is no longer present. Sometimes need to restart OSBuddy when enabling/disabling this setting but otherwise I can consistently click when setting is off and can't click with setting on.

0uVmRE.png

Seems safe to say that this was the problem, at least for me. I hope this helps anyone else who also experiences this issue ^^

tagging people that I've read have the same issue I think: @jnvl2 @IDontActuallyLift @cass2186 @Louis @SlarkenTV @carrynoob123

Cheers

 

 

 

still not working for me

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • This update features:

      Fixed broken hooks from today's update


      Fix wilderness level with RuneLite (Thanks @Todd)


      Add support for Kotlin .class files in scripts (Thanks @wastedbro)


      Overhaul Inventory API (Thanks @wastedbro)


      Add List support for common methods


      Change method grouping to make more sense (by functionality)


      Refactor methods to utilize Java 8 streams instead of cumbersome loops




      Recognize chatbox minimization (Thanks @JoeDezzy1)


      Fix Screen#isInViewport when NPC chat is open (Thanks @JoeDezzy1)


      Fix login bot bugs (Thanks @erickho123)


      Fix hint arrow return values (Thanks @Encoded)


      Fix depositAllExcept functionality (Thanks @wastedbro)


      Change containing box interface bound and adjust for Y values (Thanks @erickho123)
        • Like
      • 151 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
    • This release will:

      Add new internal framework for capturing exceptions


      Fix issue with not selecting the last column in world hopper (Thanks @Todd)


      Add a message about pin usage in Banking#openBank (Thanks @Todd)


      Disable the firewall by default (Thanks @Todd)


      Fix handling of the welcome screen after login (Thanks @Encoded)


      Fix wrong amount bank withdrawal (Thanks @Encoded)


      Fix Screen#isInViewport


      Fix Game#isInViewport (Thanks @Encoded)


      Call onBreakEnd for ListenerManager Breaking Listeners (Thanks @Encoded)


      Fix Prayer#getPrayerPoints NumberFormatException (Thanks @JoeDezzy1)



      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Thanks
        • Like
      • 28 replies
    • This release will:

      Fix LG for both OSBuddy and RuneLite


      Fix issue where the resizable client isn't able to be made smaller (Thanks @JoeDezzy1)


      Fix detection of the logout game tab when resizable mode and side panels are enabled (Thanks @JoeDezzy1)


      Add initial support for Sentry to allow us to identify and easily debug exceptions happening with all TRiBot users


      Add methods to determine if the bank is actually loaded, and not just the overarching interface (Thanks @wastedbro)



      Upcoming updates:

      Improved CLI support


      Full Sentry support


      Much more
        • Like
      • 64 replies
    • This release will:

      Fix NPE in Camera API (Thanks @wastedbro)


      Update deposit box interface ids (Thanks @Encoded)


      Add various bank methods (Thanks @wastedbro)


      Banking#getWithdrawXQuantity


      Banking#getDefaultWithdrawQuantity


      Banking#arePlaceholdersOn




      Fix resizeable minimap bug (Thanks @wastedbro)


      Remove Java 8 requirement


      Please note: TRiBot is not yet fully compatible with Java 10+




      Fix the break handler issues by ensuring the break handler thread never gets paused


      Fix broken settings hooks



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 68 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...