Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
TRiLeZ

TRiBot Release 10.14_0

Recommended Posts

This release will:

  • Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)
  • Improve banking API (Thanks @Encoded)
    • Adds methods for returning and using Java Lists, rather than arrays
    • Slightly randomizes some hardcoded behaviour
    • Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable
    • Other back-end improvements

Note: If you are using LG, please restart both the RS client and TRiBot.

  • Like 3
  • Thanks 1
  • Haha 1
  • Sad 1

Share this post


Link to post
Share on other sites
12 minutes ago, TRiLeZ said:

This release will:

  • Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)
  • Improve banking API (Thanks @Encoded)
    • Adds methods for returning and using Java Lists, rather than arrays
    • Slightly randomizes some hardcoded behaviour
    • Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable
    • Other back-end improvements

Note: If you are using LG, please restart both the RS client and TRiBot.

Banking.depositAllExcept does not seem to be working, it's depositing the only item I'm trying to keep in my inventory (coins)

Edit: It's working when I switch for ID's but using names is broken.

Edited by Zully

Share this post


Link to post
Share on other sites
6 minutes ago, Zully said:

Banking.depositAllExcept does not seem to be working, it's depositing the only item I'm trying to keep in my inventory (coins)

This is working, I just tested it. Delete hooks and restart 2x.

Banking.depositAllExcept(995);

It deposited everything except coins

Share this post


Link to post
Share on other sites
Just now, godspower33 said:

This is working, I just tested it. Delete hooks and restart 2x.

Banking.depositAllExcept(995);

It deposited everything except coins

I just edited my post, it's only broken for using names, ID's work for me too. Sorry.

Share this post


Link to post
Share on other sites
45 minutes ago, wastedbro said:

A fix is pending and should be included in the next client update, which will likely be a quick hotfix soon.

Great! I was worried I'd be stuck using ID's for the next little while. I assume you guys already know but people are saying the world hopping is still broken as well.

Share this post


Link to post
Share on other sites
Guest

This update broke Optimus Pest Control and Master Fletcher for me (and possibly more scripts).

The client (not invidual scripts) form a noticeable pattern of clicking two exact spots each time.

In the Pest Control script this happens every minigame match, in fletching script this happens every time it closes the bank.

Also the mouse is completely broken.

Please fix your bullshit, thanks. 

Share this post


Link to post
Share on other sites

Worldhopping is still broken. Every time a client is freshly started, first worldhopping attempt will fail. Bot prints this in Debug:

[13:18:35] Switching to world -1

The only way around this is to force bot to attempt a worldhop (it will fail), stop script, run same script again. From that point worldhopping works, until client needs to be restarted again.

It seems valid worldlist isn't loading properly until after first hop attempt on freshly started client. I'm not sure if this is a caching issue, but this needs to be looked at and fixed.

@TRiLeZ @Wastedbro2 @Encoded @erickho123

Edited by contemporary

Share this post


Link to post
Share on other sites
1 hour ago, gccltu said:

This update broke Optimus Pest Control and Master Fletcher for me (and possibly more scripts).

The client (not invidual scripts) form a noticeable pattern of clicking two exact spots each time.

In the Pest Control script this happens every minigame match, in fletching script this happens every time it closes the bank.

Also the mouse is completely broken.

Please fix your bullshit, thanks. 

This is a script issue, look at what was even changed. Also if you have an issue, post in the script forum, not in updates. 

Great Update :D

Share this post


Link to post
Share on other sites
Guest
24 minutes ago, boe123 said:

This is a script issue, look at what was even changed. Also if you have an issue, post in the script forum, not in updates. 

Great Update :D

This happens to multiple scripts, not just one.

Even if its somehow their issue, how Tribot fails to communicate with the developers? What kind of incompetence is this, or is it too much to ask for to have a functioning client? 

  • Like 2

Share this post


Link to post
Share on other sites
Guest
16 hours ago, godspower33 said:

This is working, I just tested it. Delete hooks and restart 2x.

Banking.depositAllExcept(995);

It deposited everything except coins

new to this. seen that people mentioned delete hooks. how exactly do i delete hooks? thanks

Share this post


Link to post
Share on other sites
3 hours ago, CincoSiete said:

new to this. seen that people mentioned delete hooks. how exactly do i delete hooks? thanks

C:\Users\Your_Username\AppData\Roaming\.tribot\settings\

It's in there^ I believe usually deleting hooks is only for RS updates but if you haven't done it before and stuffs broken for you it would be a good thing to try.

 

Share this post


Link to post
Share on other sites
Guest
2 hours ago, Zully said:

C:\Users\Your_Username\AppData\Roaming\.tribot\settings\

It's in there^ I believe usually deleting hooks is only for RS updates but if you haven't done it before and stuffs broken for you it would be a good thing to try.

 

strange i cant seem to find that. im going to try re downloading the client.

i found it but what exactly do i delete? 

Edited by CincoSiete

Share this post


Link to post
Share on other sites
11 hours ago, gccltu said:

This happens to multiple scripts, not just one.

Even if its somehow their issue, how Tribot fails to communicate with the developers? What kind of incompetence is this, or is it too much to ask for to have a functioning client? 

pretty much this - I see more and more ppl talking on discord groups how tribot fails at updates and having a working client and how loooong it takes for updates to roll.

Some of updates takes like what..6 months to get fixed.. ridiculous

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 10 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 26 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...