Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Jamie

[ABC2/ABCL10] JAIOPrayer : JavaFX GUI | Wilderness Altar | Gilded Altar | Bone Burying | Automated Host Finding

Recommended Posts

59 minutes ago, Core743 said:

Sorry can't do that. I would suggest reviewing that part of the script for specific zones of summoning, as some areas can't accomodate summoning. If the character summons a few beasts and ends up moving out of the restricted area, he can just move back in the area.

Without access to an account I cannot update the script. If another user can confirm its broken (I haven’t made an update to necromancy since release, and it was working), I’ll remove it from the script.

Share this post


Link to post
Share on other sites

As far as I know I'm doing it right, but it's been a while, just getting back into this a couple days ago... anyways, Dagganoth @ wilderness altar isn't loading anything for me.. I just press start script and the GUI stays and the on screen gui says loading for method, status, and state. Same if i try other bones for wilderness altar, havent tried any others... not really what i'm looking to do

Share this post


Link to post
Share on other sites
13 hours ago, Core743 said:

I suppose I'll have to wait for someone else to reports on this while doing dragon necromancy. Or if they've found a way to prevent the bot from being stuck when there's no space to summon. Not buying the script beforehand.

Necromancy won't be being fixed unless I can gain access to an account, so I'd agree with your decision not to purchase if you need that feature. I may remove it entirely.

Share this post


Link to post
Share on other sites
18 hours ago, High Order said:

As far as I know I'm doing it right, but it's been a while, just getting back into this a couple days ago... anyways, Dagganoth @ wilderness altar isn't loading anything for me.. I just press start script and the GUI stays and the on screen gui says loading for method, status, and state. Same if i try other bones for wilderness altar, havent tried any others... not really what i'm looking to do

Can you post a debug and your GUI setup for me please.

Share this post


Link to post
Share on other sites
On 11/2/2019 at 3:14 PM, HeyImJamie said:

Can you post a debug and your GUI setup for me please.

Nothing in bot debug and client debug. 

Simply put, if you start the necromancy mode without being near the altar, it just won't start/walk there. Getting to the actual location, it tries to summon the dragon/monster, even while in combat it might try to do it. And it will repeatedly try to summon in even if there isn't space. Ideally this should require the player to walk a few steps back or to a spot where there is space to summon the creature.

Screenshot_1368.png

Share this post


Link to post
Share on other sites
1 minute ago, Core743 said:

Nothing in bot debug and client debug. 

Simply put, if you start the necromancy mode without being near the altar, it just won't start/walk there. Getting to the actual location, it tries to summon the dragon/monster, even while in combat it might try to do it. And it will repeatedly try to summon in even if there isn't space. Ideally this should require the player to walk a few steps back or to a spot where there is space to summon the creature.

Screenshot_1368.png

If you can add my Discord I can try and resolve the issues with you, if not I'll remove necromancy within the next 24 hours as I have no accounts to update it with.

Share this post


Link to post
Share on other sites
Posted (edited)

Hello there,

 

I confirm that something is clearly wrong with the bot. However, my issue is a bit different from the guy above me.. my bot didn't even get to the point of using the burning amulet.

I set it to use wildy altar - dragon bones.

It went to the bank, took out *superior dragon bones* (not the dragon bones I set it to use) and then the script stopped.

This is the client debug received:

  • [21:02:18] Script Started: [Premium] JAIOPrayer.
  • [21:02:30] [GUI Handler] Mode Selected: Wilderness Altar.
  • [21:02:30] [GUI Handler] We'll be using: Dragon bones
  • [21:02:31] [Task Handler] Tasks added for method: Wilderness Altar. If this is wrong, restart the script and make sure you've clicked start on the correct method.
  • [21:02:31] [PK Observer] PKer Detection Thread Started.
  • [21:02:31] Required Items Set: {Burning amulet(=1, Dragon bones=27}
  • [21:02:34] [Bank Handler] Withdrawing Items. Fail Count: 0
  • [21:02:34] [Bank Handler] Attempting to Withdraw: Superior dragon bones
  • [21:02:40] java.lang.NullPointerException
  • [21:02:40] at scripts.JAIOPrayer.tasks.general.k.A(HandleBanking.java:264)
  • [21:02:40] at scripts.JAIOPrayer.tasks.general.k.K(HandleBanking.java:302)
  • [21:02:40] at scripts.JAIOPrayer.tasks.general.k.f(HandleBanking.java:173)
  • [21:02:40] at scripts.JAIOPrayer.JAIOPrayer.i(JAIOPrayer.java:185)
  • [21:02:40] at scripts.JAIOPrayer.JAIOPrayer.run(JAIOPrayer.java:93)
  • [21:02:40] at java.lang.Thread.run(Unknown Source)

(note: "We'll be using: Dragon bones" and then "Attempting to Withdraw: Superior dragon bones")

 

And this is the debug if I run the bot with no superior bones in the bank ( it just opens the bank and stops)

  • [21:05:05] java.lang.NullPointerException
  • [21:05:05] at scripts.JAIOPrayer.tasks.general.k.A(HandleBanking.java:264)
  • [21:05:05] at scripts.JAIOPrayer.tasks.general.k.f(HandleBanking.java:228)
  • [21:05:05] at scripts.JAIOPrayer.tasks.general.k.f(HandleBanking.java:34)
  • [21:05:05] at scripts.JAIOPrayer.JAIOPrayer.i(JAIOPrayer.java:184)
  • [21:05:05] at scripts.JAIOPrayer.JAIOPrayer.run(JAIOPrayer.java:93)
  • [21:05:05] at java.lang.Thread.run(Unknown Source)

Just bought it today, expected to get some prayer gains, guess it'll have to wait a bit ^^. 

Thanks in advance, if there is anything else I can do I will help.

Edited by andreim1994

Share this post


Link to post
Share on other sites
22 hours ago, andreim1994 said:

Hello there,

 

I confirm that something is clearly wrong with the bot. However, my issue is a bit different from the guy above me.. my bot didn't even get to the point of using the burning amulet.

I set it to use wildy altar - dragon bones.

It went to the bank, took out *superior dragon bones* (not the dragon bones I set it to use) and then the script stopped.

This is the client debug received:

  • [21:02:18] Script Started: [Premium] JAIOPrayer.
  • [21:02:30] [GUI Handler] Mode Selected: Wilderness Altar.
  • [21:02:30] [GUI Handler] We'll be using: Dragon bones
  • [21:02:31] [Task Handler] Tasks added for method: Wilderness Altar. If this is wrong, restart the script and make sure you've clicked start on the correct method.
  • [21:02:31] [PK Observer] PKer Detection Thread Started.
  • [21:02:31] Required Items Set: {Burning amulet(=1, Dragon bones=27}
  • [21:02:34] [Bank Handler] Withdrawing Items. Fail Count: 0
  • [21:02:34] [Bank Handler] Attempting to Withdraw: Superior dragon bones
  • [21:02:40] java.lang.NullPointerException
  • [21:02:40] at scripts.JAIOPrayer.tasks.general.k.A(HandleBanking.java:264)
  • [21:02:40] at scripts.JAIOPrayer.tasks.general.k.K(HandleBanking.java:302)
  • [21:02:40] at scripts.JAIOPrayer.tasks.general.k.f(HandleBanking.java:173)
  • [21:02:40] at scripts.JAIOPrayer.JAIOPrayer.i(JAIOPrayer.java:185)
  • [21:02:40] at scripts.JAIOPrayer.JAIOPrayer.run(JAIOPrayer.java:93)
  • [21:02:40] at java.lang.Thread.run(Unknown Source)

(note: "We'll be using: Dragon bones" and then "Attempting to Withdraw: Superior dragon bones")

 

And this is the debug if I run the bot with no superior bones in the bank ( it just opens the bank and stops)

  • [21:05:05] java.lang.NullPointerException
  • [21:05:05] at scripts.JAIOPrayer.tasks.general.k.A(HandleBanking.java:264)
  • [21:05:05] at scripts.JAIOPrayer.tasks.general.k.f(HandleBanking.java:228)
  • [21:05:05] at scripts.JAIOPrayer.tasks.general.k.f(HandleBanking.java:34)
  • [21:05:05] at scripts.JAIOPrayer.JAIOPrayer.i(JAIOPrayer.java:184)
  • [21:05:05] at scripts.JAIOPrayer.JAIOPrayer.run(JAIOPrayer.java:93)
  • [21:05:05] at java.lang.Thread.run(Unknown Source)

Just bought it today, expected to get some prayer gains, guess it'll have to wait a bit ^^. 

Thanks in advance, if there is anything else I can do I will help.

yeah bro. same here. i hope fix soon! :)

Share this post


Link to post
Share on other sites
On 1/5/2020 at 12:43 PM, pidars2 said:

Wilderness altar doesnt work.. 10x click burning amulet nonstop. fix it! @HeyImJamie

I'll try and take a look. Was it not clicking the dialogue?

22 hours ago, andreim1994 said:

Hello there,

 

I confirm that something is clearly wrong with the bot. However, my issue is a bit different from the guy above me.. my bot didn't even get to the point of using the burning amulet.

I set it to use wildy altar - dragon bones.

It went to the bank, took out *superior dragon bones* (not the dragon bones I set it to use) and then the script stopped.

This is the client debug received:

  • [21:02:18] Script Started: [Premium] JAIOPrayer.
  • [21:02:30] [GUI Handler] Mode Selected: Wilderness Altar.
  • [21:02:30] [GUI Handler] We'll be using: Dragon bones
  • [21:02:31] [Task Handler] Tasks added for method: Wilderness Altar. If this is wrong, restart the script and make sure you've clicked start on the correct method.
  • [21:02:31] [PK Observer] PKer Detection Thread Started.
  • [21:02:31] Required Items Set: {Burning amulet(=1, Dragon bones=27}
  • [21:02:34] [Bank Handler] Withdrawing Items. Fail Count: 0
  • [21:02:34] [Bank Handler] Attempting to Withdraw: Superior dragon bones
  • [21:02:40] java.lang.NullPointerException
  • [21:02:40] at scripts.JAIOPrayer.tasks.general.k.A(HandleBanking.java:264)
  • [21:02:40] at scripts.JAIOPrayer.tasks.general.k.K(HandleBanking.java:302)
  • [21:02:40] at scripts.JAIOPrayer.tasks.general.k.f(HandleBanking.java:173)
  • [21:02:40] at scripts.JAIOPrayer.JAIOPrayer.i(JAIOPrayer.java:185)
  • [21:02:40] at scripts.JAIOPrayer.JAIOPrayer.run(JAIOPrayer.java:93)
  • [21:02:40] at java.lang.Thread.run(Unknown Source)

(note: "We'll be using: Dragon bones" and then "Attempting to Withdraw: Superior dragon bones")

 

And this is the debug if I run the bot with no superior bones in the bank ( it just opens the bank and stops)

  • [21:05:05] java.lang.NullPointerException
  • [21:05:05] at scripts.JAIOPrayer.tasks.general.k.A(HandleBanking.java:264)
  • [21:05:05] at scripts.JAIOPrayer.tasks.general.k.f(HandleBanking.java:228)
  • [21:05:05] at scripts.JAIOPrayer.tasks.general.k.f(HandleBanking.java:34)
  • [21:05:05] at scripts.JAIOPrayer.JAIOPrayer.i(JAIOPrayer.java:184)
  • [21:05:05] at scripts.JAIOPrayer.JAIOPrayer.run(JAIOPrayer.java:93)
  • [21:05:05] at java.lang.Thread.run(Unknown Source)

Just bought it today, expected to get some prayer gains, guess it'll have to wait a bit ^^. 

Thanks in advance, if there is anything else I can do I will help.

Seems as if it's setting the wrong bones as you've mentioned. I'll take a look today. :)

Apologies in the delay, I've been at a training course for work for a few days that's taken my free time.

Share this post


Link to post
Share on other sites
21 hours ago, HeyImJamie said:

I'll try and take a look. Was it not clicking the dialogue?

Seems as if it's setting the wrong bones as you've mentioned. I'll take a look today. :)

Apologies in the delay, I've been at a training course for work for a few days that's taken my free time.

You can fix it now? 

Share this post


Link to post
Share on other sites
10 minutes ago, Androbolic said:

when will the prayer bot get back support for auto finding a host?  and howcome it is not withdrawing noted bones and coins from the bank for the rimmington method?  did i set it up wrong

You should start it with noted bones and coins already in the inventory. It never had support for auto finding a host, although I'll be looking to add using the HostViewer into V2.

Share this post


Link to post
Share on other sites
1 hour ago, HeyImJamie said:

You should start it with noted bones and coins already in the inventory. It never had support for auto finding a host, although I'll be looking to add using the HostViewer into V2.

ohh ok i thought it withdrew from the bank automatically haha.  when is v2 supposed to come out approximately the script will be sick once it can auto find a host and maybe make it switch to w330 automatically to search for the host

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 10 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
      • 26 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...