Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
acezeps

After update,looking glass broke

Recommended Posts

Used tribot for about a year now, running lg only the entire time. ive always been able to fix errors that would come up but since the update my Lookingglass has been broken. Tried everything I know how to do ie. Uninstall everything and download proper osbuddy,tribot, and java jdk downloads. 

running into the same error over and over again, and my debug log at the bottom spams errors non-stop, took a while to even be able to see some words cause it was spamming so fast.

Heres mostly what its saying in the debug, any help would be wonderful. Love everything about tribot, hope someone could help a brother out.

 

Debug:

 

debug log.txt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ToxicDeadlyMP
      Have you been banned yet?
      I'm not a newbie, I really want to purchase the extended for the looking glass feature. My plan is to run it for about 2-3hrs with a few hours in between as breaks. Never exceeding 3 hours of continuous boting. I want to use it on my main account so I'm wondering if using looking glass with these boting habits will keep me being detected extremely low. I'm also not just going to leave it running and turn off the screen, I'll be watching it for errors and such as I play other games. Also with the added looking glass feature and the human like mouse movements and the breaks, how could they even detect the boting? 
    • By Worthy
      OSBuddy may altar things in the Runescape client and will mess up some actions in game if using Looking Glass.
      For example, if you have the Jewelry Overlay  enabled, then clicking on some charged items (like a Ring of Dueling) may mess up.
       
      Ensure your OSBuddy settings are on default to guarantee Looking Glass running as smoothly as possible
       
       
      How to default your OSBuddy Settings
      Locate your OSBuddy folder ON WINDOWS: C:/Users/username/OSBuddy If you can't find it, just locate the folder of where you launch the OSBuddy jar, and navigate one or two levels up.
        Delete the settings folder  
       
      Now when using OSBuddy all of the custom overlay settings should be turned off.
      Double check if the Jewelry Overlay is disabled; and if not, disable it manually.
       
       
       
      Happy Botting!
      Worthy
    • By grammatoncleric
      Pretty sure I already know the answer, but I am just trying to be lazy and not write the code myself (since i dont write java, but python)(automation), was wondering if there is a cli starter that someone knows of that uses LG, im aware of the one with tribot, and ericks public one, but i think neither support LG (assuming osbuddy is already running for LG to hook into)
      Thanks,
      grammatoncleric
    • By OliverandFelix
      When using looking glass do I still connect to Runescape using the proxy selected through Tribot, or will the mirrored client run through my main ip adress as osbuddy has no option to use a proxy?
    • By zemp0
      Hey, been trying the whole day solving this issue ive read probably every single thread on the issue and still cant get it to work....
      Here is log:
      [02:08:01] TRiBot Release 9.312_5 loaded. (1.8.0_172:C:\Program Files (x86)\Java\jdk1.8.0_172\jre)
      [02:08:01] Loading human mouse movement data.
      [02:08:02] Successfully loaded human mouse data.
      [02:08:03] AGENT PATH: C:\Users\hmyhr\AppData\Local\Temp\t1_agent_1093120500.jar
      [02:08:03] java.rmi.ConnectIOException: error during JRMP connection establishment; nested exception is:
          java.io.EOFException
      [02:08:03]     at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:307)
      [02:08:03]     at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:202)
      [02:08:03]     at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:129)
      [02:08:03]     at java.rmi.server.RemoteObjectInvocationHandler.invokeRemoteMethod(RemoteObjectInvocationHandler.java:227)
      [02:08:03]     at java.rmi.server.RemoteObjectInvocationHandler.invoke(RemoteObjectInvocationHandler.java:179)
      [02:08:03]     at com.sun.proxy.$Proxy0.newClient(Unknown Source)
      [02:08:03]     at javax.management.remote.rmi.RMIConnector.getConnection(RMIConnector.java:2430)
      [02:08:03]     at javax.management.remote.rmi.RMIConnector.connect(RMIConnector.java:308)
      [02:08:03]     at obf.GO.iV(ffa:504)
      [02:08:03]     at obf.MJ.run(re:18)
      [02:08:03]     at java.lang.Thread.run(Thread.java:748)
      [02:08:03] Caused by: java.io.EOFException
      [02:08:03]     at java.io.DataInputStream.readByte(DataInputStream.java:267)
      [02:08:03]     at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:246)
      [02:08:03]     ... 10 more
      [02:08:03] No RuneScape client was found.
      I've tried alot of different versions of JDK 102, 112 etc etc both 64bit and 32bit using osbuddy at same bit ofc. Disabled firewall aswell and antivirus, ran jarfix, made new account on pc legit tried everything i read pls someone help
      EDIT: Resolved by Fluffeee thanks alot! If anyone has same issue just follow his link below worked
    • By MilkyWay
      iv never been able to get looking glass working since I joined, but I recently had a bit success and got it to hook on to osbuddy,
      but when I click start scripts nothing happens for me.
    • By herfolj
      Hello, been bitting for a couple of days on the looking glass service here. Yesterday the option didn't show up. Anyone know how to fix this?

      Thanks
    • By miggo13
      I formatted my PC yesterday and before i did all was good, but now after format, my tribot Looking glass keeps telling me "No runescape client found".
      i have literally tried over 10 different java versions, 32bit and 64bit and nothing works 
      I have Windows 10 Home
      Currently: Java JDK 161 (64bit), I have tried the 32bit version too, didn't work.
      Yesterday everything was working, i have read trough all posts about this issue and i did everything they suggested, from fixing my java.policy to removing tribot foler, removing hooks.dat, Removing my temp folder, redownloaded tribot and osbuddy, trying the Java JDK 102 version.
      One note, first time i started tribot+osbuddy today after format, it somehow hooked to the client and i could bot, but after i restarted my pc it stopped working :/
      I would really appreciate some help, either from the community or someone who has knowledge about this issue! 
      Also i get these kind of errors when i try to hook to the client.
      [00:38:00] TRiBot Release 9.308_1 loaded. (1.8.0_102:C:\Program Files\Java\jdk1.8.0_102\jre) [00:38:01] Loading human mouse movement data. [00:38:02] Successfully loaded human mouse data. [00:38:04] java.io.IOException: Access denied [00:38:04] at sun.tools.attach.WindowsVirtualMachine.openProcess(Native Method) [00:38:04] at sun.tools.attach.WindowsVirtualMachine.(WindowsVirtualMachine.java:56) [00:38:04] at sun.tools.attach.WindowsAttachProvider.attachVirtualMachine(WindowsAttachProvider.java:69) [00:38:04] at com.sun.tools.attach.spi.AttachProvider.attachVirtualMachine(AttachProvider.java:194) [00:38:04] at obf.Tn.ex(zo:381) [00:38:04] at obf.Tn.rV(zo:603) [00:38:04] at obf.kl.run(fk:13) [00:38:04] at java.lang.Thread.run(Thread.java:745) [00:38:04] AGENT PATH: C:\Users\maged\AppData\Local\Temp\t1_agent_1093080100.jar [00:38:04] No RuneScape client was found.
    • By miggo13
      I formatted my PC yesterday and before i did all was good, but now after format, my tribot keeps telling me "No runescape client found".
      i have literally tried over 10 different java versions, 32bit and 64bit and nothing works
      I have Windows 10 Home
      Currently: Java JDK 161 (64bit), I have tried the 32bit version too, didn't work.
      Yesterday everything was working, i have read trough all posts about this issue and i did everything they suggested, from fixing my java.policy to removing tribot foler, removing hooks.dat, Removing my temp folder, redownloaded tribot and osbuddy, trying the Java JDK 102 version.
      One note, first time i started tribot+osbuddy today after format, it somehow hooked to the client and i could bot, but after i restarted my pc it stopped working :/
      I would really appreciate some help, either from the community or someone who has knowledge about this issue!
      Also i get these kind of errors when i try to hook to the client.
      [00:38:00] TRiBot Release 9.308_1 loaded. (1.8.0_102:C:\Program Files\Java\jdk1.8.0_102\jre) [00:38:01] Loading human mouse movement data. [00:38:02] Successfully loaded human mouse data. [00:38:04] java.io.IOException: Access denied [00:38:04] at sun.tools.attach.WindowsVirtualMachine.openProcess(Native Method) [00:38:04] at sun.tools.attach.WindowsVirtualMachine.(WindowsVirtualMachine.java:56) [00:38:04] at sun.tools.attach.WindowsAttachProvider.attachVirtualMachine(WindowsAttachProvider.java:69) [00:38:04] at com.sun.tools.attach.spi.AttachProvider.attachVirtualMachine(AttachProvider.java:194) [00:38:04] at obf.Tn.ex(zo:381) [00:38:04] at obf.Tn.rV(zo:603) [00:38:04] at obf.kl.run(fk:13) [00:38:04] at java.lang.Thread.run(Thread.java:745) [00:38:04] AGENT PATH: C:\Users\maged\AppData\Local\Temp\t1_agent_1093080100.jar [00:38:04] No RuneScape client was found.
  • Our picks

    • This release will:

      Fix LG for both OSBuddy and RuneLite


      Fix issue where the resizable client isn't able to be made smaller (Thanks @JoeDezzy1)


      Fix detection of the logout game tab when resizable mode and side panels are enabled (Thanks @JoeDezzy1)


      Add initial support for Sentry to allow us to identify and easily debug exceptions happening with all TRiBot users


      Add methods to determine if the bank is actually loaded, and not just the overarching interface (Thanks @wastedbro)



      Upcoming updates:

      Improved CLI support


      Full Sentry support


      Much more
        • Like
      • 50 replies
    • This release will:

      Fix NPE in Camera API (Thanks @wastedbro)


      Update deposit box interface ids (Thanks @Encoded)


      Add various bank methods (Thanks @wastedbro)


      Banking#getWithdrawXQuantity


      Banking#getDefaultWithdrawQuantity


      Banking#arePlaceholdersOn




      Fix resizeable minimap bug (Thanks @wastedbro)


      Remove Java 8 requirement


      Please note: TRiBot is not yet fully compatible with Java 10+




      Fix the break handler issues by ensuring the break handler thread never gets paused


      Fix broken settings hooks



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 68 replies
    • This release will:

      Add support for using custom F key bindings to switch between game tabs (Thanks @erickho123)


      Fix tab opening for "Skills" and "Kourend Tasks" (Thanks @erickho123)



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 34 replies
    • This release will:

      Fix an issue where breaks would stop firing


      Fix Combat#getWildernessLevel, use dynamic search for text and cache ID for later calls


      Fix an NPE in the Combat API


      Fix Mouse#leaveGame bug where the mouse wouldn't actually leave the game screen
        • Like
      • 21 replies
    • This release will:

      Add LG support for Runelite


      Fix NPCChat issues


      Fix a bug where the camera angle setter would just hold down a key for 5 seconds (the timeout)


      Slightly adjust the rotation via keys to be more accurate


      Add the ability for asynchronous camera movement via keys


      Make Camera rotation via mouse more fluid, with more antiban, and work much better in resizable mode


      Add a "Camera#setCamera" method, allowing the rotation and angle to be set in parallel


      Increase the likelihood of using the mouse for camera movements


      Add support for adjusting the camera to positionable entities (Positionable#adjustCameraTo)



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Thanks
        • Like
      • 59 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×