Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Einstein

Relative Agility - Written by Einstein

Your feedback allows me to further improve this script  

92 members have voted

You do not have permission to vote in this poll, or see the poll results. Please sign in or register to vote in this poll.

Recommended Posts

17 hours ago, bearhead said:

Hey, Just wondering how to get the camelot teleport to work? i have runes in my rune pouch but it doesn't teleport? thanks!

It only supports using runes from the inventory, runes from inventory & wielded staff, or teleport tabs in the inventory.

 

Share this post


Link to post
Share on other sites
13 hours ago, CyberWizard said:

Out of curiosity, it should obviously run to the bank to get teleports if not in inventory, no? Not sure how it works currently

The script will simply use what it has, prioritizing the cheapest method: staff > runes > teleport tabs > no teleport

If there are no teleporting items available, the script will not teleport. Currently, the bank is never accessed in any way by this script. I said 'currently' because the upcoming golfarming mode might need to do so, in order to gather any additional marks that might be kept in the bank.

 

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, Einstein said:

The script will simply use what it has, prioritizing the cheapest method: staff > runes > teleport tabs > no teleport

If there are no teleporting items available, the script will not teleport. Currently, the bank is never accessed in any way by this script. I said 'currently' because the upcoming golfarming mode might need to do so, in order to gather any additional marks that might be kept in the bank.

 

Alright good to know, would you consider adding an option in the gui (or just making it automatic) for the script to check bank for teleports? On my gold farming accounts, I usually only keep the teleports I need for the next course in my inventory (sometimes I forget that too) and to optimize for food efficiency

 

Does script even check bank for food? (Haven't used script much yet waiting on gold farming support)

 

Share this post


Link to post
Share on other sites
20 hours ago, CyberWizard said:

Alright good to know, would you consider adding an option in the gui (or just making it automatic) for the script to check bank for teleports? On my gold farming accounts, I usually only keep the teleports I need for the next course in my inventory (sometimes I forget that too) and to optimize for food efficiency

Thank you for the suggestion.

 

20 hours ago, CyberWizard said:

Does script even check bank for food? (Haven't used script much yet waiting on gold farming support)

The script does not interact with the bank in any way, at the moment. :)

 

  • Like 1

Share this post


Link to post
Share on other sites
Guest

Questions:

1. Any chance for randomizing the time for hopping worlds?  Hopping at the exact same amount of minutes every time is pretty bot-like, unless there's randomization not shown already (I haven't exactly been timing it). 

2. Can sara brews/strawberry baskets be supported?  Doesn't look like it supports brews, which is a bit of a head scratcher.  Angular fish are working fine for now.

3. The bot turns on run energy at exactly 40% every single time.  Can this be randomized too? Very inhuman.

 

Edit: @Einstein Things I've noticed that weren't working as intended:

 

1. Bot got stuck at beginning of werewolf course trying to world hop.  Tried to go to world in low 300s, just sat on the screen hovering over one of the worlds in the 500s.  Had to manually fix.  May have fixed itself after getting logged out due to afk.  Only log was 'Script failed to hop worlds, retrying'.

2. The bot also always decides to afk in the corner west of the first stepping stone.  Doesn't get stuck, but doesn't look natural.  No logs here except the ones about disabling antiban for afk.

4. And finally, and this is rather important, if the bot runs out of food at werewolf, it doesn't log out.  I caught it continuing the course as low as 22hp.  Failing the final obstacle can do up to 30hp in damage, so if I had left the bot I most likely would have died and lost graceful pieces. Also no logs here.

 

Otherwise, the actual completing of the course is going well.  All problems are either with the anti-ban or food consumption.

Edited by Bottingman9000

Share this post


Link to post
Share on other sites

Hello Mr Einstein,

 

First of all, thank you for this awesome script. i have some questions before i consider buying .

1.) Does this script support refilling waterskins in Nardah while using the Agility Pyramid?

 

2.) Would it be possible, for the agility pyramid, to not take several Pyramid tops as they are quite heavy and soak up the running speed and efficiency?

I didnt read the whole thread before asking this, so if these questions got answered before im sorry for asking again.

 

Ty in Advance

Share this post


Link to post
Share on other sites
On 2/17/2019 at 6:53 AM, Bottingman9000 said:

1. Any chance for randomizing the time for hopping worlds?  Hopping at the exact same amount of minutes every time is pretty bot-like, unless there's randomization not shown already (I haven't exactly been timing it). 

The value is already randomized.

 

On 2/17/2019 at 6:53 AM, Bottingman9000 said:

2. Can sara brews/strawberry baskets be supported?  Doesn't look like it supports brews, which is a bit of a head scratcher.

This will be added in the next release.

 

On 2/17/2019 at 6:53 AM, Bottingman9000 said:

3. The bot turns on run energy at exactly 40% every single time.

Toggling run is handled by ABC2 and it should have a broader spectrum of values.

 

@Bottingman9000 Thank you for the rest of the reports.

 

 

12 hours ago, Karuz0 said:

Hello Mr Einstein,

Hello Mr. Karuz0.

 

12 hours ago, Karuz0 said:

First of all, thank you for this awesome script.

You're welcome. Thank you for using my software.

 

12 hours ago, Karuz0 said:

1.) Does this script support refilling waterskins in Nardah while using the Agility Pyramid?

At the time of writing there is no additional support for waterskins. The script will simply stop after it runs out of water.

 

12 hours ago, Karuz0 said:

2.) Would it be possible, for the agility pyramid, to not take several Pyramid tops as they are quite heavy and soak up the running speed and efficiency?

If you would like to limit the amount of pyramids that will be kept in the inventory, simply get more waterskins to fill up the inventory. The number of free inventory slots will determine the maximum amount of pyramids kept in the inventory before selling them.

 

Share this post


Link to post
Share on other sites
Guest
6 hours ago, Einstein said:

The value is already randomized.

 

This will be added in the next release.

 

Toggling run is handled by ABC2 and it should have a broader spectrum of values.

 

@Bottingman9000 Thank you for the rest of the reports.

 

 

Hello Mr. Karuz0.

 

You're welcome. Thank you for using my software.

 

At the time of writing there is no additional support for waterskins. The script will simply stop after it runs out of water.

 

If you would like to limit the amount of pyramids that will be kept in the inventory, simply get more waterskins to fill up the inventory. The number of free inventory slots will determine the maximum amount of pyramids kept in the inventory before selling them.

 

Thanks for the info, I guess run energy would be an ABC problem then.  Could you comment on the werewolf agility food problem?  

Share this post


Link to post
Share on other sites
Guest
5 hours ago, Einstein said:

I agree that continuing the course after the player runs out of food is a problem, and a solution to it will be included in the next patch.

 

Happy to hear, thanks.

  • Like 1

Share this post


Link to post
Share on other sites

Hey! Trying this script out on a mac before I buy it and having an issue with the gui

It's completely broken :') I've attached a screenshot and pastebin of the log while loading the script 

https://pastebin.com/A0sMSca1

Screenshot_2019-02-27_at_11.21.59.png?width=1442&height=611

 

Any recommendations on how to fix it? Let me know if you need any more info or anything else :)

 

EDIT: Works fine on a windows VM so I can use it, but would be amazing if it worked on mac since performance is affected on a VM

Edited by Protoprize

Share this post


Link to post
Share on other sites
Guest

Having an issue in Al Kharid where the mark of grace gets stuck behind a pillar that the camera can't see because of the angle it chooses, so the bot gets stuck until the camera is manually turned. Will post screenshot soon. I can also post a log if you tell me how to please.

Share this post


Link to post
Share on other sites
Guest

Bot gets stuck looking for mark of grace or just completely doesn't pick it up at all sometime unless I manually turn the camera. Happened in varrock and al kharid

Edited by michaelp433809
Forgot information

Share this post


Link to post
Share on other sites
5 minutes ago, michaelp433809 said:

Bot gets stuck looking for mark of grace or just completely doesn't pick it up at all sometime unless I manually turn the camera. Happened in varrock and al kharid

The script will only attempt to pick up the marks if they are on the same roof as the character. Next time it happens, please let the script execute normally (without rotating the camera) and post the results afterwards.

 

Share this post


Link to post
Share on other sites
Guest
29 minutes ago, Einstein said:

The script will only attempt to pick up the marks if they are on the same roof as the character. Next time it happens, please let the script execute normally (without rotating the camera) and post the results afterwards.

 

Im new to scripting but decent with computers, can you tell me where the log is generated and which section I should post? Thank you sir

edit:Bot debug?

Edited by michaelp433809

Share this post


Link to post
Share on other sites
20 hours ago, michaelp433809 said:

Im new to scripting but decent with computers, can you tell me where the log is generated and which section I should post? Thank you sir

edit:Bot debug?

Posting the debug won't be very useful in this situation, as the script will only print out messages in certain situations, this one not being one of them.

 

46 minutes ago, Uomanihs said:

I sent you a DM about an issue I'm having with the script.

It seems only tele tabs can be used, and the bot will not use the teleport spell to seer's

Thanks for the report, I will try to replicate this bug.

 

Share this post


Link to post
Share on other sites
58 minutes ago, Einstein said:

Thanks for the report, I will try to replicate this bug.

You're welcome! Thank you for the quick reply.

I just thought of something, I wonder if since I set it to "Configure" for Seer's teleport, maybe that is causing a problem?

Let me know what you find, thanks again.

Share this post


Link to post
Share on other sites
Guest

I need help with the AFK settings also. What would be an example of afking out for a 10 minute break every hour?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Hi everyone,

      I'd like to thank everyone for their patience in this transition period. Since last week, we've worked out the remaining bugs with this integration.

      Some users have still been having issues with connecting their forums account to their Auth0 account. To resolve this, we've imported all forums accounts into Auth0.

      Unfortunately, the accounts which were imported today were using an unsupported password hashing algorithm. Hence, random passwords were set during the import.

      What does this mean for me?

      If you've previously linked your forums account to your Auth0 account, you don't have to do anything. Nothing changes for you.


      If you haven't logged in via our new login yet,

      Try logging in with your forums email address and the last password you used


      If you are unable to login, please use the "Forgot password" tool on the login page:
      Follow the instructions to reset your password
       
      • 2 replies
    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 71 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
      • 50 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...