Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
TRiLeZ

TRiBot Release 10.10_0 & 10.10_1

Recommended Posts

This release will (10.10_0):

  • Add support for using custom F key bindings to switch between game tabs (Thanks @erickho123)
  • Fix tab opening for "Skills" and "Kourend Tasks" (Thanks @erickho123)

This release will (10.10_1):

  • Fix a script pausing logic error where threads such as the AI anti-ban and the break handler thread will never be un-paused
    • In other words, fix the main break handler bug

Note: If you are using LG, please restart both the RS client and TRiBot

Edited by TRiLeZ
10.10_1
  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, TRiLeZ said:

This release will (10.10_1):

  • Fix a script pausing logic error where threads such as the AI anti-ban and the break handler thread will never be un-paused
    • In other words, fix the main break handler bug
 

I'd like to thank everyone who has contributed useful information regarding this bug, and I'd especially like to thank everyone for their patience.

  • Like 4

Share this post


Link to post
Share on other sites
2 hours ago, guywithlsd said:

@TRiLeZ Same bug happens again - Does not come back from break handler

6ec4766395a02745a1303848bc8226fc.png
https://gyazo.com/6ec4766395a02745a1303848bc8226fc

f4c9b7d3534f6b102ac91058ae289105.png

Could you please provide the break handler stack trace when it's stuck like this? Or better yet, provide some instructions for me to replicate the bug?

Share this post


Link to post
Share on other sites

@TRiLeZ

Bot activated the break like 20-30 mins after the break was supposed to occur, and then didn't login back.
I have it recorded, will try to get it for you asap.

[15:53:41] Break Handler Stack Trace:
[15:53:41] java.lang.Thread.sleep(Native Method)
[15:53:41] obf.Jb.CA(cc:106)
[15:53:41] obf.VD.run(pj:180)
[15:53:41] java.lang.Thread.run(Unknown Source)

Edit: pmed you.

Edited by NinjadGuy

Share this post


Link to post
Share on other sites

@TRiLeZ

I don't think it's the break handler that's being broken,

39O2vl2.png

 

I'm not using the break handler, just simple General.sleep and they get stuck.

I'm honestly starting to think that the problem is General.sleep itself.

It keeps screwing up on my other script, doing things that it's not suppose to.

Edited by theholyone

Share this post


Link to post
Share on other sites

Break handler stack trace

[12:35:55] Break Handler Stack Trace:
[12:35:55]  obf.ie.rh(jf:355)
[12:35:55]  org.tribot.api2007.types.RSInterface.click(hm:1050)
[12:35:55]  org.tribot.api2007.types.RSInterface.click(hm:656)
[12:35:55]  org.tribot.api2007.types.RSInterface.click(hm:1167)
[12:35:55]  org.tribot.api2007.GameTab.open(mf:191)
[12:35:55]  org.tribot.api2007.GameTab$TABS.open(mf:286)
[12:35:55]  org.tribot.api2007.Login.LO(uk:1015)
[12:35:55]  org.tribot.api2007.Login.logout(uk:943)
[12:35:55]  obf.VD.FF(pj:102)
[12:35:55]  obf.VD.run(pj:182)
[12:35:55]  java.lang.Thread.run(Unknown Source)

Share this post


Link to post
Share on other sites
13 hours ago, theholyone said:

@TRiLeZ

I don't think it's the break handler that's being broken,

39O2vl2.png

 

I'm not using the break handler, just simple General.sleep and they get stuck.

I'm honestly starting to think that the problem is General.sleep itself.

It keeps screwing up on my other script, doing things that it's not suppose to.

Interesting, I've noticed similar behavior before on a different script, where "time until break ends" went into negatives in paint.

On a side note, this break/login bug now happens much more often than a couple Tribot versions ago. If accounts are running with frequent breaks, almost half of them get stuck at one point or another every day.

Share this post


Link to post
Share on other sites
On 10/31/2018 at 9:54 PM, TRiLeZ said:

Could you please provide the break handler stack trace when it's stuck like this? Or better yet, provide some instructions for me to replicate the bug?

There is no instruction. It happens absolute random. This one happened on VPS with 2 same scripts running. only one got error with login bot not loggin back after break. Looks like error looks same all the time for me.

163c580bfbdc46c3ce37964246ae67f7.png

 

Another account - different vps

70eaea02efae58c34c695ba0c2acb052.png

 

Edited by guywithlsd

Share this post


Link to post
Share on other sites
18 hours ago, RedHawkLuffy said:

Sometimes the bot doen't login after the 6 hour timeout? It's been like this for a few months now. Is this a known bug?

yah, they know it and they SHOULD fix it..but no one now when and if it will be ever done..I lost my hope time ago but maybe they will..you never know

5 hours ago, Cypher said:

@TRiLeZ have noticed after a break has ended I arrive back to see the client on the world select screen. Has anyone else noticed this?

Yah, i have seen this - it was some sort of update or smth that sometimes when you logout / DC you appear straight to world select screen. Login handler then fails to select world in some cases. not sure if it happens often or not as i don't see this bug often.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 63 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...