Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
TRiLeZ

TRiBot Release 10.4_0

Recommended Posts

This release will:

  • Fix bytecode manipulation in order to prevent the modification of parameters within the Filter and Condition classes themselves (thanks @wastedbro)
  • Fix NPE caused by non-null value in GE API (thanks @erickho123)
  • Add and fix equals methods for api2007.types (thanks @JoeDezzy1)
  • Modify Mouse#leaveGame to make the mouse leave the game from top, left, right, or bottom (thanks @erickho123)
  • Add Entrana area to Ships API (thanks @erickho123)
  • Fix raid prayers index/settings in Prayer API (thanks @erickho123)

Upcoming updates:

  • Break handler bug fix
  • Improved CLI support
  • Much more

Note: If you are using LG, please restart both the RS client and TRiBot

  • Like 4

Share this post


Link to post
Share on other sites
Guest

Hey , Please  , i want to know why when the account hopping worlds , its bug and no work ! ? 

  • Haha 1
  • thonking 3

Share this post


Link to post
Share on other sites
42 minutes ago, Moleymoles said:

Auto Wintertotd not working after update, Do we have to wait for script author to update? or should this work with your updates?

Please let me know.

 

Thanks for you quick responses to OSRS updates.

Did delete hooks and cache then restart tribot twice?

Share this post


Link to post
Share on other sites
25 minutes ago, Moleymoles said:

How does one with a simple mind do such a thing? haha

After deleting Cache and restarting PC, scripts had to be redownloaded and had to setup account handler / break handler etc. etc.

I get this... same as before..

 

Any suggestions or do I need to wait on devs?

error.png

Share this post


Link to post
Share on other sites
1 minute ago, Moleymoles said:

After deleting Cache and restarting PC, scripts had to be redownloaded and had to setup account handler / break handler etc. etc.

I get this... same as before..

 

Any suggestions or do I need to wait on devs?

error.png

I believe Encoded has to reupload the script to the repository, for it to work with the new changes.

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, jrnb123 said:

Fairly sure world hopping is broken. It will continually click the world you are on and the scroll bar, but never actually hop to anything. 

That may actually be a script issue, if the Script author has implemented their own world hopper. The TRiBot one seems to be working for most people, after the update by Encoded, so the not functioning world hopper might be the script!

What script are you using? ?

Share this post


Link to post
Share on other sites
52 minutes ago, Moleymoles said:

After deleting Cache and restarting PC, scripts had to be redownloaded and had to setup account handler / break handler etc. etc.

I get this... same as before..

 

Any suggestions or do I need to wait on devs?

error.png

EncodedSERVER OWNERYesterday at 5:41 PM

 
 
Change all methods which accept Filter and Condition to Predicate and BooleanSupplier, respectively (thanks @wastedbro)
 
 
 
that's responsible for the current down time

Share this post


Link to post
Share on other sites

Tribot seems to be moving in a really good direction with all of these improvements. It's making me think of botting again. 

When the licensing model changed I was not positive about it at first. Mainly because I bought quite a few lifetime scripts that I didn't use much but decided on because lifetime seemed the best value for the money. 

However seeing now that with that change a lot of improvement to the overall structure of tribot came i like it. An extra administrator and more developers got added to the client. A lot of improvements to the client got made. And I'm sure many more will follow now. 

  • Like 5
  • Thanks 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
      • 10 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
      • 26 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...