Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
TRiLeZ

TRiBot Release 9.400_2

Recommended Posts

This update includes:

  • Fix broken hooks
  • Fix login bot for the message "No reply from login server. Please wait 1 minute and try again."
  • Fix bug relating to which bot tab is sent human input
  • General#randomLong bug fix involving negative numbers
  • Fix GE API

Please note: There are still some issues with the login bot due to a change in the game mechanisms handling the login screen. We're working on a fix and will upload it when ready.

  • Like 6
  • Thanks 2

Share this post


Link to post
Share on other sites
Array
1 minute ago, TRiLeZ said:

This update includes:

  • Fix broken hooks
  • Fix login bot for the message "No reply from login server. Please wait 1 minute and try again."
  • Fix bug relating to which bot tab is sent human input
  • General#randomLong bug fix involving negative numbers
  • Fix GE API

Please note: There are still some issues with the login bot due to a change in the game mechanisms handling the login screen. We're working on a fix and will upload it when ready.

❤️❤️❤️ u da best trilez

Share this post


Link to post
Share on other sites
5 minutes ago, TRiLeZ said:

This update includes:

  • Fix broken hooks
  • Fix login bot for the message "No reply from login server. Please wait 1 minute and try again."
  • Fix bug relating to which bot tab is sent human input
  • General#randomLong bug fix involving negative numbers
  • Fix GE API

Please note: There are still some issues with the login bot due to a change in the game mechanisms handling the login screen. We're working on a fix and will upload it when ready.

It looks like the update broke LG. Just restarted my TRiBot Loader and now it can't hook onto OSBuddy. Not sure why?

EDIT: Looks like I had to restart the OSBuddy clients. Works fine now!

Edited by coffeedog

Share this post


Link to post
Share on other sites

@TRiLeZ I used to be able to minimize clients and reduce my cpu usage to about 1/3 of what it would be when it is open/visible in desktop, but now it has the same cpu usage for every client even when it is minimized. Is there a fix on this problem? Is anyone else here having the same problem?

Share this post


Link to post
Share on other sites
36 minutes ago, mike9021 said:

@TRiLeZ I used to be able to minimize clients and reduce my cpu usage to about 1/3 of what it would be when it is open/visible in desktop, but now it has the same cpu usage for every client even when it is minimized. Is there a fix on this problem? Is anyone else here having the same problem?

Turn up your paint delay to save cpu usage

Share this post


Link to post
Share on other sites
36 minutes ago, tarxan said:

Turn up your paint delay to save cpu usage

I have been running for months and this is the first time a minimized client with no account logged in and no script running consumes 14% of my cpu usage it has always averaged around 4% only. Not even disabling graphics would help. My paint delay has always been the same 20ms and I need it that way for the scripts I run.

I have added a picture of the cpu usage of my clients. The first three are running around killing npcs etc, and the highlighted fourth one is a freshly launched minimized client(no running script and no logged in account). This wasn't the case before the update. I need this to be the way it used to before because I need my cpu usage to run other accounts while some of them are on a break. Any help would be much appreciated.

 

cpu usage.PNG

Edited by mike9021
image of cpu usage added

Share this post


Link to post
Share on other sites
4 hours ago, H22A4 said:

Looking glass is now a black screen for me after this update. Ive deleted and re installed tribot, osbuddy and java, Still the same issue.

 

3 hours ago, Leonidas said:

Running into the same issue.

 

6 hours ago, coffeedog said:

It looks like the update broke LG. Just restarted my TRiBot Loader and now it can't hook onto OSBuddy. Not sure why?

EDIT: Looks like I had to restart the OSBuddy clients. Works fine now!

I found a fix for the black screen issue. First load a client within Tribot without using LG, then close the client open up a new one and LG should work. Happened to me and this fixed the issue.

  • Like 3

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • Come give us feedback on the next version of TRiBot!
      • 29 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
      • 19 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
      • 90 replies
    • This release will:

      Add new internal framework for capturing exceptions


      Fix issue with not selecting the last column in world hopper (Thanks @Todd)


      Add a message about pin usage in Banking#openBank (Thanks @Todd)


      Disable the firewall by default (Thanks @Todd)


      Fix handling of the welcome screen after login (Thanks @Encoded)


      Fix wrong amount bank withdrawal (Thanks @Encoded)


      Fix Screen#isInViewport


      Fix Game#isInViewport (Thanks @Encoded)


      Call onBreakEnd for ListenerManager Breaking Listeners (Thanks @Encoded)


      Fix Prayer#getPrayerPoints NumberFormatException (Thanks @JoeDezzy1)



      Note: If you are using LG, please restart both the RS client and TRiBot.
      • 28 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...