Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Einstein

Einstein's Woodcutter ² - Probably the best Woodcutter on TRiBot

Recommended Posts

17 hours ago, rs06botHein said:

Woke up this morning to a stopped script. When I logged in the script moved 40 tiles south west. Just now checked the bot again (approx 8h later) and it did exactly the same thing!! Same plac same tree, worked flawless before update?  

I am going to need more details in order to troubleshoot this issue.

What is the message from the debug? The script will always specify the encountered problem before shutting down.

 

12 hours ago, Callistocub1 said:

Fossil Island tree patch doesn't contain an option for Mahogany trees?

Mahogany trees haven't been included anywhere outside the Hardwood Grove.

Teak can be chopped on Fossil Island. Based on what I've seen, they are the most popular.

Do you think Mahogany should also be added? If so, why? I am going to create a voting poll for this matter.

 

Share this post


Link to post
Share on other sites
1 hour ago, Einstein said:

I am going to need more details in order to troubleshoot this issue.

What is the message from the debug? The script will always specify the encountered problem before shutting down.

  

Mahogany trees haven't been included anywhere outside the Hardwood Grove.

Teak can be chopped on Fossil Island. Based on what I've seen, they are the most popular.

Do you think Mahogany should also be added? If so, why? I am going to create a voting poll for this matter.

 

Sent you private message with bot debug, sorry for bad info. ;)

Share this post


Link to post
Share on other sites

Hey @Einstein

Whenever I try to chop regular trees with progressive mode, it doesn't detect any trees in custom areas i think, the script just immediately stops upon clicking start. It works fine in the exact same area when using normal mode.

GUI Settings

daJeZba.png

Client debug:

[15:07:55] Downloading script 'Einstein's Woodcutter'.
[15:07:57] Script Started: Einstein's Woodcutter.
[15:07:58] No previously saved profle was found.   
[15:07:58] If this is your first time running Einstein's Woodcutter, welcome to the team!   
[15:07:58] Script successfully loaded: 0.704 seconds.
[15:08:59] Successfully saved profile: 1-35 WC   
[15:09:00] Disabled all randoms.
[15:09:00] [Progressive mode] Based on how you configured the GUI, there are no more trees that can be cut at your current level (1).   
[15:09:00] The script will now exit.   
[15:09:00] Thank you for running Einstein's Woodcutter!
[15:09:00] Script Ended: Einstein's Woodcutter.

Am I missing something? :P  Kinda sucks because I purchased it mainly for the progressive mode.

  • Like 1

Share this post


Link to post
Share on other sites
17 hours ago, Flax said:

Whenever I try to chop regular trees with progressive mode, it doesn't detect any trees in custom areas i think, the script just immediately stops upon clicking start. It works fine in the exact same area when using normal mode. 

I successfully identified the issue and submitted an update. Now the script will start targeting trees as soon as the player has the required level (1 in this case). Thank you for the report.

Also, nice area name F4aWzLx.png. :lol:

 

@cheeko Thanks for providing @Flax a workaround until I managed to fix the issue.

 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited)

New version is trying to burn logs inside houses and on wall tiles, and ignores walls when walking towards starting "burning lane" point. Script sometimes ends up stuck clicking in a loop on the same spot, unable to reach it.

It would be good if you added a feature for custom "burning lanes" in addition to current custom woodcutting area, or at least an option to burn inside custom zone only.

Different issue - Save/Load profile popup being hidden below settings window. It's only visible once I move settings GUI out of the way.

[EDIT] Something's wrong with tile finding in general. This happens often while cutting in an open area:

[17:44:19] Tile finding algorithm started.
[17:50:17] Tile finding algorithm execution time: 357.521 seconds.
[17:50:17] Tile finding algorithm started.
[17:53:46] Thank you for running Einstein's Woodcutter!
[17:53:47] Script Ended: Einstein's Woodcutter.

Usually script doesn't recover and I have to stop it manually.

Edited by contemporary

Share this post


Link to post
Share on other sites
Posted (edited)

The provided zone for for Fally South seems to make the bot confused? All the Oak tress are there and available. To be honest I just started the bot in the South Fally bank and it walked to that location seen in the picture and just stood there unable to find a tree.spacer.png 

image.png

Edited by stlambe
Fixed text for clarity

Share this post


Link to post
Share on other sites

@Einstein

Error with Burning Logs option. It burns logs in the inventory fine, but once it reaches the end of the tile strip, the bot just idles out with the message, "Tile finding algorithm started" and doesn't do anything, even when the tile strip it just did is clear again.

Tried this in Draynor and ran into the error. Might want to take a look.

Share this post


Link to post
Share on other sites

The issues with Firemaking have been addressed:

  • The algorithm is now capable of detecting tile arrays that traverse through walls.
  • The script will update itself at runtime: if there are not enough usable tiles in the area, the minimum tile array length will be decreased.

ToMEay6.png

 

Note about future issues with houses / walls:

Those objects' IDs need to be manually hardcoded, there is no workaround. If you happen to find a building or wall through which the script is attempting to create a tile array, I will need to know exactly which building is it (map location) and a patch will follow shortly.

 

Thanks @contemporary and @gabrielspecter for your help.

 

  • Like 1

Share this post


Link to post
Share on other sites

It seems every once in a while the bot will right click next to the tree but since no menu pops up the bot will try to right click again in the same spot. Basically enters a right clicking loop.

Found my guy doing it for about 20mins < any idea why this happens?

Camera is default, Area is custom, Using LG, Chopping willows + fming.

Share this post


Link to post
Share on other sites
20 minutes ago, dayzsa said:

It seems every once in a while the bot will right click next to the tree but since no menu pops up the bot will try to right click again in the same spot. Basically enters a right clicking loop.

Unfortunately, this is caused by a client issue which was introduced in the latest game update.

 

Share this post


Link to post
Share on other sites
On 5/29/2019 at 10:42 PM, rs06botHein said:

There is no failsafe when script is trying to hop and level up screen is up.

This will be solved in a future update.

 

23 hours ago, dayzsa said:

are the developers aware?:O  

and here's a GIF of the bug:

https://gyazo.com/2cc3e9b5062422049dd11988fff24307

I think they are aware of the fact that objects are no longer being hooked properly.

If you want to see how the problem actually looks, load up TRiBot and open the entity debug (under the tools menu). Then hover over the willow tree that had this issue and see what happens.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • [READ TO THE END FOR A TEASER]

      I've noticed some new TRiBotters have had some troubles finding out sources of how to do certain things, such as using advanced scripts and often get lost in the forums.

      We are still getting posts asking where to start, what to do, recommended scripts, etc. 

      As many of you know, I am new to the team, and had troubles myself learning how to bot, let alone script. 

      So, what our team decided to do was make it easier to learn how to bot, how to script, and just become an overall better botter and scripter faster. 

      As some of you might have seen, I've posted 3 new blogs, you can check it out by clicking on the following picture or here.


      These first 3 blogs are the first of many blogs that will be TRiBot official. They are encouraged to be challenged, improved upon and act as A Best Practices Guide for Botters.

      What information would you like to see in the blogs?

      👇 [TEASER] 👇

      .

      .

      .

      We are going to be hosting a  CONTEST  this  OCTOBER.

      Its scary to think how soon you'll find out.👻

      Stay tuned.


      - RileyZ
      • 7 replies
    • Today marks a big day for TRiBot! To make it easier for users to use TRiBot, we've created installers available for every platform! These installers are all bundled with the latest version of OpenJDK 1.8 (Java 😎, which is LG compatible.

      Using TRiBot is now easy. Simply download the installer for your platform, install TRiBot, and run it. The TRiBot Loader will correctly identify the bundled JDK so there's no need to change the Java selection.

      Windows

      EXE installer: TRiBot-windows-x64-4.0.3.exe


      MSI installer: TRiBot-windows-x64-4.0.3.msi


      Portable version: TRiBot-windows-x64-4.0.3.zip


      Mac OS

      Installer: TRiBot-macos-4.0.3.dmg


      Portable version: TRiBot-macos-4.0.3.tgz


      Unix/Linux

      Installer: TRiBot-unix-4.0.3.sh


      RPM installer (CentOS/Fedora): TRiBot-linux-4.0.3.rpm


      DEB installer (Debian): TRiBot-linux-4.0.3.deb


      Portable version: TRiBot-unix-4.0.3.tar.gz


      Platform Independent

      JAR file: tribot-loader-4.0.3.jar


      Note that this jar file does not include the bundled JDK.



      Windows and Mac OS users may notice a warning message stating that the installer/application is un-recognized or un-trusted. Please ignore this message and proceed with running the installer/application. We need to acquire a code signing certificate so that we can sign the installers letting the operating system know that these files can be trusted. It will take a week or more to acquire one, so please hold tight.

      Other notable changes to the TRiBot Loader:

      Support getting the version from OpenJDK distributions


      Add check for bundled JDK


      Copy OpenJDK tools.jar to the bundled JDK if not present


      Set the current java as the first available list entry


      Ignore Java versions which are symbolic links


      Make the bundled JDK the preferred Java version


      Update icon images


      Reduce the number of HTTP calls
        • Thanks
        • Like
      • 17 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 17 replies
    • Hello TRiBot,

      Today we have a significant release that has been in the works for the last month addressing several key issues, features and bugs in the backlog.

      With these changes, we are also including a new TRiBot Loader which will allow you to select any version that is released. This adds the flexibility of allowing you to revert to a previous version should an issue arise, run development only builds, view an accurate change log between versions etc. we are very proud to offer this feature and think it will add a lot more functionality down the road as we continue to release new versions.

      These changes include 80+ commits by our development team, a list of them is summarized below and also available for your viewing pleasure in the new TRiBot Loader.

      In addition, we have taken additional steps to improve as a development team by adding continuous integration and deployment into our workflow to assist in delivering timely releases such as bug fixes as well as new features on a weekly basis depending on our development cycle.
        • Thanks
        • Like
      • 39 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...