Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
r0ot

Linux/Ubuntu Dependencies Bug

Recommended Posts

I've nearly got TRiBot running on an Ubuntu machine but have run into an error with the loader.  When I run the loader for the first time and it populates the dependencies folder, the file togl.dll get's downloaded instead of libTOGL.so which TRiBot.jar eventually looks for.  Error looks like this:

Loading TOGL

Loading: /home/<user>/.tribot/dependancies/libTOGL.so

Exception in thread "AWT-EventQueue-1" java.lang.UnsatisfiedLinkError: Can't load library /home/<user>/.tribot/dependancies/ibTOGL.so

Inside my dependencies folder there's a file called togl.dll.  The bug report forum says I need to post here before I can post there.

Share this post


Link to post
Share on other sites
Array

I'm able to login ok and the loading window only stays up for a second or two then the whole thing exits.

Attempting to use the previous session.
The previous session is valid. SID: 1170c-KvmxgtpcWUjNLKntMa2jC7bGNG8S3KLkRpd3WBZKWX4F3R8H.
Command: /bin/sh -c /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java -Xmx256m -Xss2m -Dsun.java2d.noddraw=true -XX:CompileThreshold=1500 -Xincgc -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -Xbootclasspath/p:"/home/ian/.tribot/dependancies/xboot840.jar" -classpath "/usr/lib/jvm/java-8-openjdk-amd64/lib/tools.jar:/home/ian/.tribot/bin:/home/ian/.tribot/dependancies/substance.jar:/home/ian/.tribot/dependancies/trident.jar:/tmp/tribot_fccf9b44a8.jar" org.tribot.TRiBot SID1170c-KvmxgtpcWUjNLKntMa2jC7bGNG8S3KLkRpd3WBZKWX4F3R8H MEM256 OLDSCHOOL

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

    • By Rosetintedmonocle
      Hey all! Been using Tribot for a while now. While I'm certainly not experienced I can usually solve my own issues (although I am a bit of a noob) considering I'm generally quite tech savvy. However, my Google-Fu and trying all the steps I can think of has not yielded results in this case.
      So, I've been using Tribot fine for months now and suddenly today it simply doesn't work anymore. I didn't change anything on my laptop or edit any settings anywhere. One moment it was working, the next it's dead. Whenever I start Tribot and try to login I get an error. The error I get depends on whether or not I have Console Mode enabled. When I have Console Mode enabled I get an "Unable to create client instance" error and when I have Console Mode disabled I get a "Session Invalid" error message (screenshots below, let me know if you need any error files or anything). I'm 100% entering the correct password (can log into website with it fine), I tried deleting the cache folder in Appdata (didn't delete anything else though, such as Script profiles etc, could this be worth trying?).
      Overall, I'm stumped. I've restarted, redownloaded, deleted cache, and checked my login details are correct. I would really appreciate some advice or assistance (or the ability to post this in the client bug forum if that's required). Happy to try anything to make this work, as I said I'm not super experienced with Tribot but I have some general tech knowledge so I should be able to follow along to an extent regardless of how complex the potential solution is. 
      Thanks,
      Rose


    • By DizFunk
      Hi guys, I just started attempting to script. I bought VIP so I could write my own scripts. I've been having the hardest time setting up my eclipse to work with TRIBot. So far I have set up my eclipse to compile with JDK/JRE 8, TRIBot is being launched with JDK 8. Everything seems to be setup correctly, however I get this odd error message in my bot debug logs. I've attached a photo of the logs. 
      Here is what my class file looks like: 
      package scripts;
      import org.tribot.script.Script;
      import org.tribot.script.ScriptManifest;
      @ScriptManifest (authors = { "DizFunk" }, category = "Test", name = "Test")
      public class Test extends Script {
          @Override
          public void run() {
              println("Hello World!1");
          }
      }
       If anyone knows whats going on here it would be a big help

    • By schenkelenkel
      Getting this error, client won't start.

    • By Flax
      Debian 7.0 VPS Setup Guide for TRiBot Botting. 
      By: Flax
       
      Hey guys today I'm going to show you how to setup a VPS for TRiBot botting, I'm making it because I got so many questions from people about this & most VPS guides here are pretty outdated.
      Make sure your VPS operating system is Debian 7 32 or 64bit, or else this guide will not work for you!
      Okay, let's begin.
       
      First off you'll need these programs:
      - PuTTy
      - TightVNC Viewer
      Once you've downloaded those files we can begin setting up your VPS.
       
      Step 1: Open PuTTy and enter your IP and click connect (You should keep the port 22)

       
      Step 2: Now a command prompt will pop up and it'll ask you for a username, Type ' root ' and after that it'll ask you for a password, type in the password that was given to you by your VPS provider.
       
      Step 3: Now you should enter the following commands one-by-one, it can take awhile to install depending on the speed:
      apt-get update apt-get install curl curl https://dl.dropboxusercontent.com/s/jabcbltmn5fuevx/install.sh | sh apt-get install iceweasel Step 4: After that's done you should be able to connect with the VPS through TightVNC.
      REMEMBER: MAKE SURE TO ADD :1 BEHIND THE IP.

       
      This is how it should look:
      Once connected, you can download TRiBot/OSBuddy via the Iceweasel browser(similiar to Firefox).
       
      If you're unable to open TRiBot, try this:
       
      Looking for cheap VPS deals and don't know where to look? Check out Lowendbox, FinalHosting
    • By jesusgj18
      Tengo un problema ya que compré un script premium.
      Es que después de que el bot se ejecuta durante 2 horas, se detiene.
      y cuando intentó ejecutar el bot de nuevo, me muestra el error que se muestra en la imagen.
      Es un bot increíble, pero tengo ese problema ya que lo tengo y es desalentador

      Como el bot no funciona más de 2 horas , le pedí ayuda al creador del bot, pero él respondió que ya es un problema con tribot.

      AYUDA
       
    • By ltztakechi
      I try to open the bot and it says no java runtime present requesting install, I have installed javas last update about 4 times restarted my computer and my browsers and still same error. someone pls help.

    • By Fluffee
      Fluffee's Server Setup 3.0
      As some of you may know, I released an automated server setup script a little over a year ago. Albeit that script worked well, I was never fully satisfied with it, as I found it to be kind of messy to use. As a result, I rewrote the script, and restructured it, to add more, and stronger support for the different versions of Debian, the different versions of CentOS and the different versions of Ubuntu. However, with so many different Operating Systems being supported, and many different server providers having different setups, it's hard for me to test every possible scenario on my own. Which is why I've been privately handing this script out, and am now publicly looking for help.

      What does the script do?
      Similar to my previous setup script, this script changes the SSH port and creates a new user for connecting and using the server and disables root SSH connections; it installs the latest version of TightVNC Server (1.3.10) and sets that up with the desired port and password. It installs JDK 102 (32 or 64 bit depending on the OS), and installs TRiBot and OSBuddy and sets up the appropriate .jar file associations.
      What operating systems does it support?
      - CentOS (6.x and 7.x) (32 and 64 bit)
      - Debian (7.x and 8.x) (32 and 64 bit)
      - Ubuntu (12.x, 14.x and 16.x) (32 and 64 bit)
      Does it work?
      As far as I know, yes it does in fact work, and it works well if I might add. However, given that I can't test every possible setup, there is the potential for differences and issues
      How do I run the script?
      Login as root to a fresh VPS/dedi running one of the supported operating systems. From there run the commands listed below and follow the onscreen instructions. For those who would like to see the script's code, it can be found on my bitbucket here. The commands to run are as follows:
      wget --no-check-cert https://bitbucket.org/teamfluffee/fluffees-server-setup/raw/add-shared-functions/fluffees-server-setup.sh && chmod +x fluffees-server-setup.sh && bash fluffees-server-setup.sh -v Version History
       
    • By Rajo
      Hello, i am new here. 
      I need help. I can't login at all.
      As you can see the picture

      I can't fill the right captca because i can't resize the windows. Only small window like that xD.
      And second. When i try login my account. The result is...

      So what's the problem it is? What's solution? 
       
      Thank You.
    • By Medieval
      Hello, firstly i'd like to say that running a bot on mac is 1000x more difficult than running a bot on a windows. I've downloaded Tribot and have jdk-11.0.1.
      I keep getting an error which I've linked below. Please help as I've been trying to run a bot on this macbook forever. It seems impossible.
      Thanks,
      Medieval 

    • By rvqx
      I have got 10 instances of aAgility and  currently i can only run one account at same time. When i try to run 2nd acc it says "The maximum amount of instances for this script has been surpassed. Cannot run script."
      And yes i did check instance manager and there it seems only one instance is used. (I even tried to kill that instance and then tried to start script again, still same) @TRiLeZ @Fluffee @Todd  @Aropupu 
       
      Edit: Sorry, the problem was the VIP, Fixed.
  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 25 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...