Jump to content
Sign in to follow this  
Letsmakemoneybitch

Help with new oficial CLI start

Recommended Posts

55 minutes ago, Deluxes said:

If that dogshit work around doesn't work, mine should still be functional. https://github.com/deluxes/TribotCMDStarter/releases/tag/1.3

@Deluxes
Your starter works fine... the only problem is that the ~scriptargument field on your script, perhaps, works differently from the official CLI Starter...
I'm implementing 
 Arguments Interface and trying to get the String content the same way I did on Trilez Starter, but for some reason it returns null.
Do you have any advice on how to use your -scriptargument field? I`ve already looked into your code on github but I couldn`t understand how it works
 

Share this post


Link to post
Share on other sites
32 minutes ago, Letsmakemoneybitch said:

@Deluxes
Your starter works fine... the only problem is that the ~scriptargument field on your script, perhaps, works differently from the official CLI Starter...
I'm implementing 
 Arguments Interface and trying to get the String content the same way I did on Trilez Starter, but for some reason it returns null.
Do you have any advice on how to use your -scriptargument field? I`ve already looked into your code on github but I couldn`t understand how it works
 


Guys, thank you for the help. I just found out I was using scriptargument when calling the Deluxes starter, instead of scriptarguments. Now it works. The official thread ( https://tribot.org/forums/topic/74116-tribot-cli-client-starter/) is saying to use scriptargument instead of scriptarguments... all working fine thank you all

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Our picks

    • This release will:

      Fix key event handling issue


      Fix other event handling issue


      Fix RSServer hook


      Update world hopper to have it use OCR, thanks to Todd


      Use proper disposal of old Graphics objects


      Reformat code


      Rearrange code


      Organize code imports


      Apply around 8000 automated code refactorings


      Make preparations for Java 9


      Fix 11 various bugs


      Add more reliable debugging support


      Fix mouseEntered/Exited event dispatching bug


      Fix minimap walking bug where it opens the map


      Fix broken hooks for today's game update
        • Thanks
        • Like
      • 87 replies
    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
        • Like
      • 27 replies
    • This release will:

      Fix some ClosedChannelException bug


      Fix bug in RSObject#getAllTiles


      Add game tab support for "Kourend Favour"
        • Like
      • 15 replies
    • This release will:

      Fix Settings UI placement bug


      Fix game object location bug


      Fix small layout bug making the client shift up and down


      Fix client crashing bug where loading the client with a small display area will cause the client to crash


      Fix annoying Linux bug relating to painting events and peers


      Fix settings saving bug where settings are saved to disk more often than they should


      Fix RSInterface#isBeingDrawn bug affecting a limited amount of people


      Drop Java 1.7 bytecode version for 1.8


      Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date).


      This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support.
        • Like
      • 40 replies
    • This update will:

      Fix the RSMenuNode bug which also fixes the bug with bank opening


      Fix the incorrect object positions bug


      Fix and re-enable the LG Objects API Accelerator


      Fix the RSObject#getAllTiles bug
        • Like
      • 22 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×