Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Sign in to follow this  
Guest

Loading client params

Recommended Posts

Guest

Hi, whenever I try to start an advanced client with proxies it gets stuck on "loading client params". I've seen another post about it ( from 2015 ) and it didnt correct my problem.

I use the last version of Java 8_161 and I tried both 32 bit, 64 bit for windows. I've tried deleting .tribot, changing heap size , changing in CMD to make sure I was connecting in IPV4 and not IPV6... I'm kinda stuck right now ! ( Also uninstalled and reinstalled both Java, tried Jdk, not working )

Here's the client debug

Spoiler
  1. [21:23:00]  at sun.net.www.http.HttpClient.New(HttpClient.java:339)
  2. [21:23:00]  at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:1227)
  3. [21:23:00]  at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1175)
  4. [21:23:00]  at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1040)
  5. [21:23:00]  at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1038)
  6. [21:23:00]  at java.security.AccessController.doPrivileged(Native Method)
  7. [21:23:00]  at java.security.AccessController.doPrivilegedWithCombiner(AccessController.java:782)
  8. [21:23:00]  at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1037)
  9. [21:23:00]  at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:984)
  10. [21:23:00]  at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1564)
  11. [21:23:00]  at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:91)
  12. [21:23:00]  at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1484)
  13. [21:23:00]  at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1482)
  14. [21:23:00]  at java.security.AccessController.doPrivileged(Native Method)
  15. [21:23:00]  at java.security.AccessController.doPrivilegedWithCombiner(AccessController.java:782)
  16. [21:23:00]  at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1481)
  17. [21:23:00]  at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480)
  18. [21:23:00]  at obf.dE.Nh(vl:265)
  19. [21:23:00]  at obf.jk.YJ(ag:206)
  20. [21:23:00]  at obf.jk.<init>(ag:8)
  21. [21:23:00]  at obf.RK.Da(ao:8)
  22. [21:23:00]  at obf.xk.m(wm:562)
  23. [21:23:00]  at obf.xk.<init>(wm:161)
  24. [21:23:00]  at obf.Ql.<init>(bh:162)
  25. [21:23:00]  at obf.RK.<init>(ao:192)
  26. [21:23:00]  at obf.vJ.<init>(gg:113)
  27. [21:23:00]  at obf.EG.run(af:738)
  28. [21:23:00]  at java.lang.Thread.run(Thread.java:748)
  29. [21:23:01] java.net.SocketException: SOCKS: Connection not allowed by ruleset
  30. [21:23:01]  at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:553)
  31. [21:23:01]  at java.net.Socket.connect(Socket.java:589)
  32. [21:23:01]  at sun.net.NetworkClient.doConnect(NetworkClient.java:175)
  33. [21:23:01]  at sun.net.www.http.HttpClient.openServer(HttpClient.java:463)
  34. [21:23:01]  at sun.net.www.http.HttpClient.openServer(HttpClient.java:558)
  35. [21:23:01]  at sun.net.www.http.HttpClient.<init>(HttpClient.java:242)
  36. [21:23:01]  at sun.net.www.http.HttpClient.New(HttpClient.java:339)
  37. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:1227)
  38. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1175)
  39. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1040)
  40. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1038)
  41. [21:23:01]  at java.security.AccessController.doPrivileged(Native Method)
  42. [21:23:01]  at java.security.AccessController.doPrivilegedWithCombiner(AccessController.java:782)
  43. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1037)
  44. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:984)
  45. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1564)
  46. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:91)
  47. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1484)
  48. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1482)
  49. [21:23:01]  at java.security.AccessController.doPrivileged(Native Method)
  50. [21:23:01]  at java.security.AccessController.doPrivilegedWithCombiner(AccessController.java:782)
  51. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1481)
  52. [21:23:01]  at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480)
  53. [21:23:01]  at obf.dE.Nh(vl:265)
  54. [21:23:01]  at obf.jk.YJ(ag:206)
  55. [21:23:01]  at obf.jk.<init>(ag:8)
  56. [21:23:01]  at obf.RK.Da(ao:8)
  57. [21:23:01]  at obf.xk.m(wm:562)
  58. [21:23:01]  at obf.xk.<init>(wm:161)
  59. [21:23:01]  at obf.Ql.<init>(bh:162)
  60. [21:23:01]  at obf.RK.<init>(ao:192)
  61. [21:23:01]  at obf.vJ.<init>(gg:113)
  62. [21:23:01]  at obf.EG.run(af:738)
  63. [21:23:01]  at java.lang.Thread.run(Thread.java:748)
  64. [21:23:01] java.net.SocketException: SOCKS: Connection not allowed by ruleset
  65. [21:23:01]  at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:553)
  66. [21:23:01]  at java.net.Socket.connect(Socket.java:589)
  67. [21:23:01]  at sun.net.NetworkClient.doConnect(NetworkClient.java:175)
  68. [21:23:01]  at sun.net.www.http.HttpClient.openServer(HttpClient.java:463)
  69. [21:23:01]  at sun.net.www.http.HttpClient.openServer(HttpClient.java:558)
  70. [21:23:01]  at sun.net.www.http.HttpClient.<init>(HttpClient.java:242)
  71. [21:23:01]  at sun.net.www.http.HttpClient.New(HttpClient.java:339)
  72. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:1227)
  73. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1175)
  74. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1040)
  75. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:1038)
  76. [21:23:01]  at java.security.AccessController.doPrivileged(Native Method)
  77. [21:23:01]  at java.security.AccessController.doPrivilegedWithCombiner(AccessController.java:782)
  78. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:1037)
  79. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:984)
  80. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1564)
  81. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:91)
  82. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1484)
  83. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1482)
  84. [21:23:01]  at java.security.AccessController.doPrivileged(Native Method)
  85. [21:23:01]  at java.security.AccessController.doPrivilegedWithCombiner(AccessController.java:782)
  86. [21:23:01]  at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1481)
  87. [21:23:01]  at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:480)
  88. [21:23:01]  at obf.dE.Nh(vl:265)
  89. [21:23:01]  at obf.jk.YJ(ag:206)
  90. [21:23:01]  at obf.jk.<init>(ag:8)
  91. [21:23:01]  at obf.RK.Da(ao:8)
  92. [21:23:01]  at obf.xk.m(wm:562)
  93. [21:23:01]  at obf.xk.<init>(wm:161)
  94. [21:23:01]  at obf.Ql.<init>(bh:162)
  95. [21:23:01]  at obf.RK.<init>(ao:192)
  96. [21:23:01]  at obf.vJ.<init>(gg:113)
  97. [21:23:01]  at obf.EG.run(af:738)
  98. [21:23:01]  at java.lang.Thread.run(Thread.java:748)
  99. [21:23:03] java.net.SocketException: SOCKS: Connection not allowed by ruleset
  100. [21:23:03]  at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:553)
  101. [21:23:03]  at java.net.Socket.connect(Socket.java:589)
  102. [21:23:03]  at sun.net.NetworkClient.doConnect(NetworkClient.java:175)

and it just keep repeating...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By DizFunk
      Hi guys, I just started attempting to script. I bought VIP so I could write my own scripts. I've been having the hardest time setting up my eclipse to work with TRIBot. So far I have set up my eclipse to compile with JDK/JRE 8, TRIBot is being launched with JDK 8. Everything seems to be setup correctly, however I get this odd error message in my bot debug logs. I've attached a photo of the logs. 
      Here is what my class file looks like: 
      package scripts;
      import org.tribot.script.Script;
      import org.tribot.script.ScriptManifest;
      @ScriptManifest (authors = { "DizFunk" }, category = "Test", name = "Test")
      public class Test extends Script {
          @Override
          public void run() {
              println("Hello World!1");
          }
      }
       If anyone knows whats going on here it would be a big help

    • By Fluffee
      Fluffee's Tutorial Island v4
      TRiBot's best Tutorial Island Script
      • Completes Tutorial Island
      • Supports loading of bulk accounts
      • Script Argument/Queue/Client Starter support
      • Tons of customization options
      • Random account profiling
      • Full ABC2 support
      • Post tutorial island tasks
      • Account Creation
      • Task based, chose the options for every account
      • Resizable mode support
      Get it here!
      GUI

      Script Arguments
      Script arguments must be entered as follows (with the following keys):
      settingsFile:saved_settings_file_name.json; The only argument required now is the name of the settings file to load. If the file specified does not exist, an error will be printed in the debug, and the script will show the GUI instead.
      Source
    • By schenkelenkel
      Getting this error, client won't start.

    • By Rileyz
      TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.
      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.
      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).
      Love, 
      RileyZ
    • By ltztakechi
      I try to open the bot and it says no java runtime present requesting install, I have installed javas last update about 4 times restarted my computer and my browsers and still same error. someone pls help.

    • Guest
      By Guest
      Hello, i am new here. 
      I need help. I can't login at all.
      As you can see the picture

      I can't fill the right captca because i can't resize the windows. Only small window like that xD.
      And second. When i try login my account. The result is...

      So what's the problem it is? What's solution? 
       
      Thank You.
    • Guest
      By Guest
      Hello, firstly i'd like to say that running a bot on mac is 1000x more difficult than running a bot on a windows. I've downloaded Tribot and have jdk-11.0.1.
      I keep getting an error which I've linked below. Please help as I've been trying to run a bot on this macbook forever. It seems impossible.
      Thanks,
      Medieval 

    • By TheIronPride
      Hey everyone i been using looking glass for a few months now, and just today i no longer see it as an option, i only see "new Client" and "New Client (advanced)" where there is normally a "new Client (looking Glass)" option, any suggestions?
  • Our picks

    • Hello everyone,

      Last week we tried to roll out Auth0 Login, but we lost that battle. Now it's time to win the war!

      Important changes

      When logging into the client, you'll now have to enter your Auth0 account credentials instead of your forums credentials

      Note: 2FA is still handled through your forums account (for the time being)



      Changes for existing users

      You'll have to link your Auth0 account to your forums account here: https://tribot.org/forums/settings/login/?service=11


      Auth0 accounts have been created for most existing users. Please use your forums email address and password to login.



      Important notes

      Make sure to verify your email address upon creating a new Auth0 account


      When we mention your Auth0 account, we mean your account used for auth.tribot.org as displayed below
      • 69 replies
    • To better support the upcoming changes (TRiBot X, new repository), we're switching our login handler to Auth0. Instead of logging in with the standard form, you'll now be required to login through our Auth0 application.

      All existing accounts which have been used within approximately the past year have been imported into Auth0 using the same email and password combination which has been stored on the forums.

      What does this mean for users?

      Your account credentials are now even more securely stored


      You'll be able to login via Facebook, Google, and others in the future


      Is there anything users have to do differently now?

      Existing users: You'll have to login with the standard login, open your Account Settings, then link your Auth0 account


      New users: You'll be redirected to our Auth0 app (auth.tribot.org) where you'll be able to create an account


      Why was this change made?

      The new apps we are creating (such as the new repository) aren't able to use the forums to handle user logins


      To centralize all user accounts in one area


      To ensure that the client login doesn't go down when the forums are having problems


      To speed up our development


      Other considerations

      There's no documentation or official support for using Invision Community combined with Auth0, so there are still a few kinks we're working out


      We're in the works of creating an account management panel specifically for Auth0 accounts (ETA August)


      It's not possible to change email addresses for the time being (this will be resolved this August)


      Changing passwords is a weird process for the time being. To change your password, you'll have to use the "Don't remember your password" tool on the Auth0 login page
        • Like
      • 11 replies
    • Over the past month, we've been working hard on TRiBot's new repository - a much needed update. This change has been deemed necessary for TRiBot X, and will allow us to really speed up development of all aspects of TRiBot.

      Today we are going to share what we've been working on!


      Now you must be wondering what kind of features the new repository will have.... well, you'll have to be patient for a little while longer. We're still figuring out various technical aspects so we can't provide answers to all possible questions. We're also focusing on development rather than writing about it so that everyone can get access to our latest developments at lightning speed. I will however answer a few users' questions.

      We're planning on a release of this early to mid August, giving users some goodies before TRiBot X's release.

      Thank you all for being patient. I hope everyone is excited as much as I am!
        • Like
      • 17 replies
    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...