Jump to content
erickho123

TRiBot CLI Client Starter

Recommended Posts

I wasn't having much luck getting this to work on linux centos 6. I was trying to use it with the terminal and this was coming up.
[mike Desktop]$ java -jar TribotClientStarter.jar -accountemail [email protected] -scriptname TRiChickens
[-accountemail, [email protected], -scriptname, TRiChickens]
Exception in thread "main" java.lang.NullPointerException
    at Main.main(Main.java:91)

Tried looking at the code and couldn't really tell what was wrong. Saw someone else had an issue and deluxe said set the java home variable so i googled how to do it on centos 6 and entered these two lines into the terminal and now it's working. Not sure if ill have to have these lines in the .sh file but we'll see.

$> export JAVA_HOME=/usr/java/jdk.1.5.0_12

$> export PATH=$PATH:$JAVA_HOME

Yeh the .sh file doesn't work even with those 2 lines in it :/

Edited by lets be friends

Share this post


Link to post
Share on other sites

Can't edit post but Got it working using this guide and also I didnt know the .sh file needed the full directory even though it was in the same place as the jar file.

 

Spoiler

The easiest way to set an environment variable in CentOS is to use export as in

$> export JAVA_HOME=/usr/java/jdk.1.5.0_12

$> export PATH=$PATH:$JAVA_HOME

However, variables set in such a manner are transient i.e. they will disappear the moment you exit the shell. Obviously this is not helpful when setting environment variables that need to persist even when the system reboots. In such cases, you need to set the variables within the system wide profile. In CentOS (I’m using v5.2), the folder /etc/profile.d/ is the recommended place to add customizations to the system profile. For example, when installing the Sun JDK, you might need to set the JAVA_HOME and JRE_HOME environment variables. In this case: Create a new file called java.sh

vim /etc/profile.d/java.sh

Within this file, initialize the necessary environment variables

export JRE_HOME=/usr/java/jdk1.5.0_12/jre
export PATH=$PATH:$JRE_HOME/bin

export JAVA_HOME=/usr/java/jdk1.5.0_12
export JAVA_PATH=$JAVA_HOME

export PATH=$PATH:$JAVA_HOME/bin

Now when you restart your machine, the environment variables within java.sh will be automatically initialized (checkout /etc/profile if you are curious how the files in /etc/profile.d/ are loaded).

PS: If you want to load the environment variables within java.sh without having to restart the machine, you can use the source command as in:

$> source java.sh
 

 

Share this post


Link to post
Share on other sites
1 hour ago, tim128 said:

Still getting an exception when trying to use it.

 

vq5g7r.png

 

 

Works for me. Maybe try deleting hookData.ini in the settings folder, deleting tribot.jar in the dependancies folder then running tribot normally once and trying it again.

  • Like 1

Share this post


Link to post
Share on other sites
10 minutes ago, Deluxes said:

Works for me. Maybe try deleting hookData.ini in the settings folder, deleting tribot.jar in the dependancies folder then running tribot normally once and trying it again.

That fixed it, works perfect now. Thanks

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×