Jump to content
Netami

[ABCL10] nBarrows

Recommended Posts

Posted (edited)

Thanks, fixed it. Hey quick question. is there a way you can give the option to deposit the items in the bank with the "all" feature for that particular item, it looks kinda bot like since no one rly just deposits exactly 123 coins you know.. just putting it out there, also can there be a random feature for the order the brothers are killed in? I keep switching it up every so often to not make it look botty. 

One last thing, idk if it matters but when in the tunnel would it be better to just click the door to go through it instead of clicking walk then selecting the door. just seems like more than the average person would do you know? anyways thats my two senses, bot is amazing tho. 

 

 

also maybe shift drop option for empty vials, just saiyan. 

 

thanks dude

Edited by Novasyn

Share this post


Link to post
Share on other sites
36 minutes ago, Novasyn said:

Thanks, fixed it. Hey quick question. is there a way you can give the option to deposit the items in the bank with the "all" feature for that particular item, it looks kinda bot like since no one rly just deposits exactly 123 coins you know.. just putting it out there, also can there be a random feature for the order the brothers are killed in? I keep switching it up every so often to not make it look botty. 

One last thing, idk if it matters but when in the tunnel would it be better to just click the door to go through it instead of clicking walk then selecting the door. just seems like more than the average person would do you know? anyways thats my two senses, bot is amazing tho. 

 

 

also maybe shift drop option for empty vials, just saiyan. 

 

thanks dude

Hey, the banking thing is caused by a change in the TRiBot API recently, that'd have to be taken up with TRiLeZ. The door walking is designed that way in case we can't see a door on the screen we won't get stuck, I don't want to mess with that too much at the risk of breaking it. I'll take a look at shift dropping, the vials thing was added before shift dropping existed. Cheers!

Share this post


Link to post
Share on other sites

Is there a certain respawn location the script needs to be set to to begin deathwalking? I noticed that I died a few times and when I checked my character it would would always just be standing in the Falador respawn location for hours logging in and out and not attempting to go to the bank.

Share this post


Link to post
Share on other sites
3 minutes ago, samnguyen20161 said:

Is there a certain respawn location the script needs to be set to to begin deathwalking? I noticed that I died a few times and when I checked my character it would would always just be standing in the Falador respawn location for hours logging in and out and not attempting to go to the bank.

Also I don't know if this has been fixed but I noticed that every time my character died, it looks like it was probably trying to get the KC but had auto-retal turned off since all the barrows brothers were done and my stats/gear/inventory/settings are pretty good to have died. I'll have to babysit it next time to be sure but just wondering.

Share this post


Link to post
Share on other sites
3 hours ago, samnguyen20161 said:

Also I don't know if this has been fixed but I noticed that every time my character died, it looks like it was probably trying to get the KC but had auto-retal turned off since all the barrows brothers were done and my stats/gear/inventory/settings are pretty good to have died. I'll have to babysit it next time to be sure but just wondering.

I'll do some more testing concerning deathwalking, it should support any respawn location. Let me know if you catch how it was dying. 

Share this post


Link to post
Share on other sites
35 minutes ago, BlankLwlo said:
35 minutes ago, BlankLwlo said:

somthing change? Script only doing 2 chests / 30 mins... was doin one / 5 mins typically and i did 500+ at that speed

Just bought the script. I it just banks grabs items and then tries to click the bank again, exits and repeats. what am i doing wrong lol

 

 

Share this post


Link to post
Share on other sites
On 10/18/2017 at 6:50 AM, nylout said:

@Netami Problems with bot (these problems doesn't happen every run):

· bot fail to use clan wars portal and goes to barrows with low hp, no pray, no energy

· bot skips 1 brother and goes into tunnels with 2 brothers alive and that usually ends with bot getting stuck in chest room, if acc dies bot don't death walk, just stands in lumb with status: Walking to the chest

· in tunnels bot seems like tries to avoid fighting barrows until chest room and that cause some problems, for example bot open doors and 1 st barrows appears bot goes to another doors and 2nd barrows appears, so now there are 2 brothers and bot decides to fight, doesn't even matter which one he will fight in the end bot will get stuck until gets killed, and don't even death walk. If bot decides to run sometimes barrows won't spawn in chest room because he already spawned few time or he still on in another room and bot get stuck again. 

· bot tries to open every door in the tunnels even if it leads to opposite direction, he just go through the doors comes back and goes to another one, wasting time and run energy.

I'm actually encountering the last two problems mentioned in this post once in a while. I was watching the bot and it got stuck behind a door in the tunnel with auto-retal turned off and I had to manually intervene before it died. HP dropped to below 20 (I had it set to eat at below 59 HP) with a full inventory of food. All I did was manually move the camera angle and the bot was able to start working again (it started running through the tunnels and eating). Is this something related to starting the bot at a certain camera angle? I'm fully zoomed out and using fixed screen. I've only run into this issue maybe 5-6 times in 500+ runs.

  • Sad 1

Share this post


Link to post
Share on other sites
10 hours ago, samnguyen20161 said:

I'm actually encountering the last two problems mentioned in this post once in a while. I was watching the bot and it got stuck behind a door in the tunnel with auto-retal turned off and I had to manually intervene before it died. HP dropped to below 20 (I had it set to eat at below 59 HP) with a full inventory of food. All I did was manually move the camera angle and the bot was able to start working again (it started running through the tunnels and eating). Is this something related to starting the bot at a certain camera angle? I'm fully zoomed out and using fixed screen. I've only run into this issue maybe 5-6 times in 500+ runs.

It might be due to camera returning objects are on screen when they're not actually able to be clicked. I'll be working on this script this afternoon, sorry for the wait everyone!

Share this post


Link to post
Share on other sites

Not sure what's going on with the script, but it hasn't been working like usual today. The script has a hard time clicking actions. Like it's hovering close to what it's supposed to click but keeps missing. Like when attempting to fight a barrows brother in the tunnel, it will keep clicking very close to him but never on him. When trying to tele out after looting the chest, it will hover over to the tele options but never tele. A bunch of other small things like forgetting to turn prayer on, eating late, etc. that I've never seen before. Script ran flawlessly last night, not sure what the problem may be. I'm running on fixed, deleted hooks, restarted the client 3 times and still seeing these problems after 5ish runs.

Share this post


Link to post
Share on other sites
3 minutes ago, samnguyen20161 said:

Not sure what's going on with the script, but it hasn't been working like usual today. The script has a hard time clicking actions. Like it's hovering close to what it's supposed to click but keeps missing. Like when attempting to fight a barrows brother in the tunnel, it will keep clicking very close to him but never on him. When trying to tele out after looting the chest, it will hover over to the tele options but never tele. A bunch of other small things like forgetting to turn prayer on, eating late, etc. that I've never seen before. Script ran flawlessly last night, not sure what the problem may be. I'm running on fixed, deleted hooks, restarted the client 3 times and still seeing these problems after 5ish runs.

Check the tribot announcements.

Share this post


Link to post
Share on other sites
3 hours ago, samnguyen20161 said:

Not sure what's going on with the script, but it hasn't been working like usual today. The script has a hard time clicking actions. Like it's hovering close to what it's supposed to click but keeps missing. Like when attempting to fight a barrows brother in the tunnel, it will keep clicking very close to him but never on him. When trying to tele out after looting the chest, it will hover over to the tele options but never tele. A bunch of other small things like forgetting to turn prayer on, eating late, etc. that I've never seen before. Script ran flawlessly last night, not sure what the problem may be. I'm running on fixed, deleted hooks, restarted the client 3 times and still seeing these problems after 5ish runs.

Yep we're currently awaiting a patch for hooks broke last night.

Share this post


Link to post
Share on other sites
2 hours ago, Deathadder said:

@Netami Any way to have the bot train my defence while doing this. Both in Mage and Melee for KC? I've tried doing it manually before i start the bot but it always changes back when it swaps gear.

Make sure it's set to that combat style when you load what mage gear/melee gear you're using. 

Share this post


Link to post
Share on other sites

please update the camera angles for the tunnels, i shouldn't have to baby it, its been like this for 1/2 of the wks ive had it..are you going to extend our time or anything cause this is bull for a bot that was re approved and i do like it but im losing a lot of time while and increasing the ban rate with us just standing there....

 

Share this post


Link to post
Share on other sites
Posted (edited)
7 hours ago, Novasyn said:

please update the camera angles for the tunnels, i shouldn't have to baby it, its been like this for 1/2 of the wks ive had it..are you going to extend our time or anything cause this is bull for a bot that was re approved and i do like it but im losing a lot of time while and increasing the ban rate with us just standing there....

 

You haven't given me any valid information about what's happening. Make sure your game zoom is set to default as well.

Edited by Netami

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Please welcome our new developers, @JoeDezzy1, @erickho123, @Encoded, and @wastedbro.

      These members will be responsible for working on, maintaining, and improving TRiBot.

      This means that bug fixes and improvements will now come at a much faster pace! We're committed to providing users with the best botting experience possible!
        • Thanks
        • Like
      • 30 replies
    • This release includes:

      More 3rd party libraries for script writers to use


      Apache Commons Codec


      Apache Commons Collections


      Apache Commons Configuration


      Apache Commons IO


      Apache Commons Lang


      Apache Commons Math


      GSON


      Guava


      JFoenix




      Hint arrow API


      Game#getHintArrowX


      Game#getHintArrowY




      Fix player hooks including Player#getSkullIcon and Prayer#getPrayerIcon
        • Thanks
        • Like
      • 41 replies
    • This update includes:

      Fix broken hooks


      Fix login bot for the message "No reply from login server. Please wait 1 minute and try again."


      Fix bug relating to which bot tab is sent human input


      General#randomLong bug fix involving negative numbers


      Fix GE API



      Please note: There are still some issues with the login bot due to a change in the game mechanisms handling the login screen. We're working on a fix and will upload it when ready.
        • Thanks
        • Like
      • 37 replies
    • This release will:

      Fix key event handling issue


      Fix other event handling issue


      Fix RSServer hook


      Update world hopper to have it use OCR, thanks to Todd


      Use proper disposal of old Graphics objects


      Reformat code


      Rearrange code


      Organize code imports


      Apply around 8000 automated code refactorings


      Make preparations for Java 9


      Fix 11 various bugs


      Add more reliable debugging support


      Fix mouseEntered/Exited event dispatching bug


      Fix minimap walking bug where it opens the map


      Fix broken hooks for today's game update
        • Thanks
        • Like
      • 100 replies
    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
        • Like
      • 27 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×