Jump to content
TRiLeZ

TRiBot Release 9.305_1 - Temporary Patch

Recommended Posts

The red banner and update posts are definitely much more helpful for us this time around compared to the last time we had a major update break the client. Hope Todd + Trilez stay on top of it like this for all future issues. To everyone crying, I get it, but other clients were hit hard too and we have an incomplete but still semi usable client right now at the very least. If it doesn't get fixed after a while then your complaints are justified, but the improvement in how they dealt with satisfying us is why a lot of us aren't going to side with the community this time around. Cry in like 2 days if nothing is done and every other client is up and running, for now relax and deal with the current client. Seizures come free of charge!

  • Like 4

Share this post


Link to post
Share on other sites

Screen flickering (or w/e is behind it) causes fatal script errors.

 

Java Version: multiple different javas on different devices

Operating System: windows 7 and CentOS 6

Issue I'm Having:

Got problems with clicking, login and camera roatations.

Login sometimes fails to input correct credentials (a letter or 2  is simply "lost"). When I type in the information myself and the screen flickers while I do it, some letters/numbers are not inputted to the login window. e.g. instead of "username" and "password" I get "usernme" and "passord".

Clicks made during the flicker are not always recognised by the game. (right-clicking, NPC interaction etc.)

Camera rotation is jumpy, trying to rotate myself is not always possible (pressing the arrow not always works), scripts stop with this error for example:

rfY68sI.png

What Script I'm trying to use:

many. TauGE, combat scripts, some of my own.

Share this post


Link to post
Share on other sites

I only use looking glass. my problem seems to be as soon as i click the looking glass option on the client. it runs the update and seems to find the rs client, but then the screen stays black and in the console it says "Starting client." but never does, it just stays like that. hope this helps

  • Like 1

Share this post


Link to post
Share on other sites
12 minutes ago, Veggiebox said:

I only use looking glass. my problem seems to be as soon as i click the looking glass option on the client. it runs the update and seems to find the rs client, but then the screen stays black and in the console it says "Starting client." but never does, it just stays like that. hope this helps

yup same thing

  • Like 1

Share this post


Link to post
Share on other sites

Clicking will break sometimes. Often when using Clicking#click the bot will try to right click and then left click the item directly after, resulting in spam clicking and nothing happening.

dC05198.gif

 

Operating System: Windows 10

Java Version: JDK8u112

Stack Trace:

[21:49:45]  java.lang.Thread.sleep(Native Method)
[21:49:45]  obf.Nb.Zc(jc:29)
[21:49:45]  org.tribot.api.General.sleep(su:116)
[21:49:45]  org.tribot.api.Timing.waitCondition(vr:109)
[21:49:45]  org.tribot.api.Timing.waitMenuOpen(vr:98)
[21:49:45]  org.tribot.api2007.types.RSGroundItem.click(bh:768)
[21:49:45]  org.tribot.api2007.types.RSGroundItem.click(bh:594)
[21:49:45]  org.tribot.api2007.types.RSGroundItem.click(bh:259)
[21:49:45]  org.tribot.api.Clicking.click(xv:36)
[21:49:45]  org.tribot.api.Clicking.click(xv:89)
[21:49:45]  scripts.zulrahslayer.c.f.c(ZulrahShrine.java:151)
[21:49:45]  scripts.zulrahslayer.c.f.B(ZulrahShrine.java:57)
[21:49:45]  scripts.api.framework.script.NodeScript.B(NodeScript.java:38)
[21:49:45]  scripts.api.framework.script.core.BasicScript.run(BasicScript.java:142)
[21:49:45]  java.lang.Thread.run(Thread.java:745)



 

@Todd @TRiLeZ I have experienced this in other scripts of mine using the Clicking class.

 

Share this post


Link to post
Share on other sites

 

On 2017-5-26 at 8:44 AM, TRiLeZ said:

I'm still working on fixing LG.

LG should have a patch released within the next few hours.

Edit2: LG is still out of commission and is expected to be fixed later tonight.

 

 

 

On 2017-5-27 at 9:44 AM, TRiLeZ said:

LG is still out of commission and is expected to be fixed later tonight.

Any update on looking glass? @TRiLeZ

  • Like 2

Share this post


Link to post
Share on other sites
[22:38:10] TRiBot Release 9.305_2 loaded. (1.8.0_45:C:\Program Files\Java\jdk1.8.0_45\jre)
[22:38:10] Loading human mouse movement data.
[22:38:11] Successfully loaded human mouse data.
[22:39:53] Exception in thread "AWT-EventQueue-1" 
[22:39:53] java.lang.NullPointerException
[22:39:53] 	at obf.pk.dispose(ye:366)
[22:39:53] 	at sun.awt.RepaintArea.paint(RepaintArea.java:243)
[22:39:53] 	at sun.awt.windows.WComponentPeer.handleEvent(WComponentPeer.java:358)
[22:39:53] 	at java.awt.Component.dispatchEventImpl(Component.java:4957)
[22:39:53] 	at java.awt.Component.dispatchEvent(Component.java:4703)
[22:39:53] 	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
[22:39:53] 	at java.awt.EventQueue.access$500(EventQueue.java:97)
[22:39:53] 	at java.awt.EventQueue$3.run(EventQueue.java:709)
[22:39:53] 	at java.awt.EventQueue$3.run(EventQueue.java:703)
[22:39:53] 	at java.security.AccessController.doPrivileged(Native Method)
[22:39:53] 	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
[22:39:53] 	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:86)
[22:39:53] 	at java.awt.EventQueue$4.run(EventQueue.java:731)
[22:39:53] 	at java.awt.EventQueue$4.run(EventQueue.java:729)
[22:39:53] 	at java.security.AccessController.doPrivileged(Native Method)
[22:39:53] 	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
[22:39:53] 	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
[22:39:53] 	at obf.uI.dispatchEvent(ei:237)
[22:39:53] 	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
[22:39:53] 	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
[22:39:53] 	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
[22:39:53] 	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
[22:39:53] 	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
[22:39:53] 	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
[22:44:01] Exception in thread "AWT-EventQueue-1" 
[22:44:01] java.lang.NullPointerException
[22:44:01] 	at obf.pk.dispose(ye:366)
[22:44:01] 	at sun.awt.RepaintArea.paint(RepaintArea.java:243)
[22:44:01] 	at sun.awt.windows.WComponentPeer.handleEvent(WComponentPeer.java:358)
[22:44:01] 	at java.awt.Component.dispatchEventImpl(Component.java:4957)
[22:44:01] 	at java.awt.Component.dispatchEvent(Component.java:4703)
[22:44:01] 	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
[22:44:01] 	at java.awt.EventQueue.access$500(EventQueue.java:97)
[22:44:01] 	at java.awt.EventQueue$3.run(EventQueue.java:709)
[22:44:01] 	at java.awt.EventQueue$3.run(EventQueue.java:703)
[22:44:01] 	at java.security.AccessController.doPrivileged(Native Method)
[22:44:01] 	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
[22:44:01] 	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:86)
[22:44:01] 	at java.awt.EventQueue$4.run(EventQueue.java:731)
[22:44:01] 	at java.awt.EventQueue$4.run(EventQueue.java:729)
[22:44:01] 	at java.security.AccessController.doPrivileged(Native Method)
[22:44:01] 	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
[22:44:01] 	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
[22:44:01] 	at obf.uI.dispatchEvent(ei:237)
[22:44:01] 	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
[22:44:01] 	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
[22:44:01] 	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
[22:44:01] 	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
[22:44:01] 	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
[22:44:01] 	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
[22:48:25] Exception in thread "AWT-EventQueue-1" 
[22:48:25] java.lang.NullPointerException
[22:48:25] 	at obf.pk.dispose(ye:366)
[22:48:25] 	at sun.awt.RepaintArea.paint(RepaintArea.java:243)
[22:48:25] 	at sun.awt.windows.WComponentPeer.handleEvent(WComponentPeer.java:358)
[22:48:25] 	at java.awt.Component.dispatchEventImpl(Component.java:4957)
[22:48:25] 	at java.awt.Component.dispatchEvent(Component.java:4703)
[22:48:25] 	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
[22:48:25] 	at java.awt.EventQueue.access$500(EventQueue.java:97)
[22:48:25] 	at java.awt.EventQueue$3.run(EventQueue.java:709)
[22:48:25] 	at java.awt.EventQueue$3.run(EventQueue.java:703)
[22:48:25] 	at java.security.AccessController.doPrivileged(Native Method)
[22:48:25] 	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
[22:48:25] 	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:86)
[22:48:25] 	at java.awt.EventQueue$4.run(EventQueue.java:731)
[22:48:25] 	at java.awt.EventQueue$4.run(EventQueue.java:729)
[22:48:25] 	at java.security.AccessController.doPrivileged(Native Method)
[22:48:25] 	at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:75)
[22:48:25] 	at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
[22:48:25] 	at obf.uI.dispatchEvent(ei:237)
[22:48:25] 	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
[22:48:25] 	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
[22:48:25] 	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
[22:48:25] 	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
[22:48:25] 	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
[22:48:25] 	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
[22:49:43] Exception in thread "AWT-EventQueue-1" 
[22:49:43] java.lang.NullPointerException
[23:02:55] Exception in thread "AWT-EventQueue-1" 
[23:02:55] java.lang.NullPointerException

Experiencing a new error

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×