Jump to content
TRiLeZ

TRiBot Release 9.305_1 - Temporary Patch

Recommended Posts

so i start my bot which is a smithing one , and it runs while it's flickering and suddently it stops after 2 trips while i'm in Edgeville smithing cannonballs ? it just logs me off it used to run for like 4 hrs straight no problems now it runs for 12minutes maybe look into the issue trillz

 

ps: running it on MAC OSX if that helps anyhow

 

i will update as my script progresses.. since restart i'm at 5min runtime working well.

Edited by Rane12

Share this post


Link to post
Share on other sites
21 minutes ago, llamasoup111 said:

Yeah script won't start, using aMinerV2. 

 

3 minutes ago, Rane12 said:

so i start my bot which is a smithing one , and it runs while it's flickering and suddently it stops after 2 trips while i'm in Edgeville smithing cannonballs ? it just logs me off it used to run for like 4 hrs straight no problems now it runs for 12minutes maybe look into the issue trillz

 

ps: running it on MAC OSX if that helps anyhow

 

i will update as my script progresses.. since restart i'm at 5min runtime working well.

Perfect examples of how not to report a problem with scripts or the client. No error details given whatsoever, and just in general very vague information that only does harm in that it dilutes meaningful posts with actual information.

Share this post


Link to post
Share on other sites
1 minute ago, Naton said:

My client keeps saying loginbot started but continues to do nothing while I'm already logged in, making it so that no script can perform any actions because the loginbot takes control of the client

If I think I know what you mean... just do it manually. don't hook ur account to the client.

Share this post


Link to post
Share on other sites
4 minutes ago, Enano25 said:

https://gyazo.com/809bf2bb6d476b10e55a74336f12b899

 

After deleting hooks, all accounts get stuck trying to click inventory when it's blinking in tutorial island.

 

After I click it manually all of tutorial island works fine.

Not gonna lie minimizing the screen even tho its flickering like crazy actually makes my bot run past 15minutes flawlessly so once Trillz fixes the flickering i believe no one will have any problems. But try minimizing it with the tutorial island scripts see if there is a change 

Share this post


Link to post
Share on other sites
1 minute ago, Rane12 said:

Not gonna lie minimizing the screen even tho its flickering like crazy actually makes my bot run past 15minutes flawlessly so once Trillz fixes the flickering i believe no one will have any problems. But try minimizing it with the tutorial island scripts see if there is a change 

Called it! keep spreading the word! its a temporary Band-Aid while He reworks the flickering.

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Rane12 said:

Not gonna lie minimizing the screen even tho its flickering like crazy actually makes my bot run past 15minutes flawlessly so once Trillz fixes the flickering i believe no one will have any problems. But try minimizing it with the tutorial island scripts see if there is a change 

Already tried, still gets stuck on trying to click the inventory. It actually just spam clicks the skill tab.

Share this post


Link to post
Share on other sites
Just now, Enano25 said:

Already tried, still gets stuck on trying to click the inventory. It actually just spam clicks the skill tab.

This isn't an issue with tribot. The id interface for the blinking inventory tab changed with this update. I don't think the generic Tabs.open worked for this part on tutorial.

  • Like 1

Share this post


Link to post
Share on other sites
20 minutes ago, Enano25 said:

Deluxes right, checked my script code and it was the inventory tab, not the skilling one. The problem is that the scripts you're using are probably using hard-coded interface ID's to click the inventory tab, which would need to be updated as the inventory tab interface must of have been changed

As for actual tribot issues, I haven't spot any hook issues so far. Only noticed flickering, as well as auto refocus that I haven't seen anyone else write about. Open up a few clients and you will see them switch between them back and forth, at least on Windows 7. I'm assuming it's connected to the flicker issue. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • This release will:

      Add LG support for Runelite


      Fix NPCChat issues


      Fix a bug where the camera angle setter would just hold down a key for 5 seconds (the timeout)


      Slightly adjust the rotation via keys to be more accurate


      Add the ability for asynchronous camera movement via keys


      Make Camera rotation via mouse more fluid, with more antiban, and work much better in resizable mode


      Add a "Camera#setCamera" method, allowing the rotation and angle to be set in parallel


      Increase the likelihood of using the mouse for camera movements


      Add support for adjusting the camera to positionable entities (Positionable#adjustCameraTo)



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 35 replies
    • This update will:

      Allow for clicking through the chat box when possible (Thanks @Todd)


      Fix Combat#selectIndex (Thanks @Encoded)


      Ensure worlds stay sorted and added a check to avoid misclicks in the in-game world hopper (Thanks @erickho123)


      Fix out-dated Options API interface indices (Thanks @Todd)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 12 replies
    • This release will:

      Fix login bot after today's game update (Thanks @JoeDezzy1)


      Fix latest in-game world hopping issues (Thanks @erickho123)


      Compact Settings UI and set location relative to TRiBot (Thanks @JoeDezzy1)


      Fix an older implementation of GrandExchange#getWindowState (Thanks @JoeDezzy1)


      Improve the preformance of NPCChat by only searching in certain interface parents (Thanks @JoeDezzy1)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      LG support for RuneLite


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 16 replies
    • This release will:

      Fix bytecode manipulation in order to prevent the modification of parameters within the Filter and Condition classes themselves (thanks @wastedbro)


      Fix NPE caused by non-null value in GE API (thanks @erickho123)


      Add and fix equals methods for api2007.types (thanks @JoeDezzy1)


      Modify Mouse#leaveGame to make the mouse leave the game from top, left, right, or bottom (thanks @erickho123)


      Add Entrana area to Ships API (thanks @erickho123)


      Fix raid prayers index/settings in Prayer API (thanks @erickho123)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 29 replies
    • This update will:

      Implement better canvas locking/synchronization mechanism


      Fix small Login API bug


      Remove the requirement for xbooting Java classes


      Use ExecutorService to perform canvas work in parallel


      Add "Account Management" game tab to GameTab API (thanks @Encoded)


      Fix NPCChat#getMessage (thanks @Encoded )


      Fix NPCChat#selectOption (thanks @Encoded )


      Fix Banking API after today's update (thanks @Encoded )


      Fix in-game world hopper after today's update (thanks @Encoded )



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 38 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×