Jump to content
darkmanfreakout

The client isn't starting up (linux user).

Recommended Posts

Just now, Adventure_Time said:

What version of java did you install? Make sure it's the correct version for your OS.

Be sure that it's trying to open it with java and not something else by default

I'm using Java 7 and OSbot and RSbot all work well so I don't really have a clue about what's happening.

 

When I left click to check and see whats going on it says that it's trying to open with java 7 but it's not doing it. I the file the permission to be opened as well so.

Share this post


Link to post
Share on other sites

Ok, you can try this:

Open a new text file (notepad or the linux equivalent you have) and type this into it:

java -jar tribot.jar

Note: 'tribot.jar' should be whatever the Jar file is named as. Then, save it as run.bat.  Then, put run.bat, and the tribot.jar in a folder together, either on your desktop or anywhere else. Then, open the run.bat and it should open tribot for you.

If that doesn't work, try installing JDK if you haven't already. you shouldn't need jdk to open tribot but it couldn't hurt to try.

Share this post


Link to post
Share on other sites
5 minutes ago, Adventure_Time said:

Ok, you can try this:

Open a new text file (notepad or the linux equivalent you have) and type this into it:

java -jar tribot.jar

Note: 'tribot.jar' should be whatever the Jar file is named as. Then, save it as run.bat.  Then, put run.bat, and the tribot.jar in a folder together, either on your desktop or anywhere else. Then, open the run.bat and it should open tribot for you.

If that doesn't work, try installing JDK if you haven't already. you shouldn't need jdk to open tribot but it couldn't hurt to try.

Tried this already got this error.

 

"Error: Unable to access jarfile tribot.jar"

I have JDK installed already as well.

Edited by darkmanfreakout

Share this post


Link to post
Share on other sites
18 minutes ago, Deluxes said:

Holy shit run the exact command iFluffee posted you fucking retard.

Exception in thread "main" java.lang.NoClassDefFoundError: javafx/fxml/Initializable
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:763)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:467)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:73)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:368)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:362)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:361)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    at org.tribot.loader.LoaderMain.main(LoaderMain.java:65)
    at org.tribot.loader.Main.main(Main.java:75)
Caused by: java.lang.ClassNotFoundException: javafx.fxml.Initializable
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    ... 14 more

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • This update will:

      Fix the RSMenuNode bug which also fixes the bug with bank opening


      Fix the incorrect object positions bug


      Fix and re-enable the LG Objects API Accelerator


      Fix the RSObject#getAllTiles bug
        • Like
      • 22 replies
    • Try our development release by checking "Development Release" on the TRiBot Loader. Note that these new features are currently in beta.

      This release features:

      Re-sizable mode support for both LG and the regular client


      Slightly improved login bot


      Removed final access modifiers from API classes


      Added RSServer hook wrapper to get the client's cached list of server/world info


      [NEW] Bug fix for intelligent banking


      [NEW] Improvement to the stability of LG over time


      [NEW] Vastly improved the reliability and speed of Screen#getColorAt on both LG and the regular client


      [NEW] Fix LG login problems


      [NEW] Fixed re-sizable mode container bug


      [NEW] Fixed re-sizable mode mouse bug


      [NEW] Use of public constants in the Banking API


      [NEW] Use of other various constants such as Projection#NULL_PT and Screen#EMPTY_COLOR



      More features to come very soon!

      Please test it and let us know here if there are any new bugs introduced in this release.
        • Thanks
        • Like
      • 12 replies
    • Try our development release by checking "Development Release" on the TRiBot Loader. Note that these new features are currently in beta.

      This release features:

      Re-sizable mode support for both LG and the regular client


      Slightly improved login bot


      Removed final access modifiers from API classes


      Added RSServer hook wrapper to get the client's cached list of server/world info


      Bug fix for intelligent banking


      Improvement to the stability of LG over time



      More features to come very soon!

      Please test it and let us know here if there are any new bugs introduced in this release.
        • Thanks
        • Like
      • 10 replies
    • - Updated the banking API to use the game item cache instead of interfaces. This will result in less delay, greater efficiency, and greater reliability. LG will especially benefit from this update.
      - Fixed a bug with the Grand Exchange API relating to searching for items.
        • Like
      • 5 replies
    • This release includes:

      * Banking update fix
      * Cache loader bug fix
      ** When TRiBot detects the cache reader has issues loading the cache, it will reload it all. This fixes the problem of loading an old cache which is re-written after loading a new client update.
        • thonking
        • Sad
        • Haha
        • Thanks
        • Like
      • 43 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×