Jump to content
Sign in to follow this  
beake

Massive CPU usage running Tribot (MAC)

Recommended Posts

7 minutes ago, beake said:

When running tribot, it uses a huge amount of CPU and the fan is constantly running... is there any way i can reduce this?

 

 

I use a mac,  2.6 GHz Intel Core i7 processor and 8 GB 1600 MHz DDR3 memory 

go to File>settings and increase client paint delay from 20-80 to your preference.

When running LG use only 512MB, when running 4-5 Normal Clients use 1024MB Heap Size(MB)[This can be found in the tribot launcher].

  • Like 1

Share this post


Link to post
Share on other sites
18 minutes ago, beake said:

When running tribot, it uses a huge amount of CPU and the fan is constantly running... is there any way i can reduce this?

 

 

I use a mac,  2.6 GHz Intel Core i7 processor and 8 GB 1600 MHz DDR3 memory 

You can also look into either  VPS or a dedicated server - basically online computers that run your bots for you. 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By ExploreWithDior
      Hello, Willing to pay someone $20 to help me get this set up by using skype chat. I currently have a Macbook Pro and have tried everything possible on all forums. Uninstalled java, removed firewall, anti virus, reinstalled java and reinstalled osrs while deleting all cache on both accounts. done this multiple times and still no luck. 
    • By RedClifford
      Hey guys first time posting on TriBot but I am really struggling to get it to run on my Mac. It wants to run but it always encounters the same error which is it says Exception in thread "AWT-EventQue-1"java.lang.unsatisfiedlinkerror:Cant load library: / Usersxxxxxxx/Library/application support/tribot/dependancies/libtogl.so . I know that anyone with minor knowledge of computers could fix this problem in seconds, but I don't have the slightest clue as to how to fix this. All i am trying to do is run TriBot with a private proxy for RS3. If anyone can help me resolve this issue comment on here or leave another way I can contact you I'd really appreciate it. Willing to pay $10 to anyone that can help me. Thank you. 

    • By jibpann
      Hello,
      So I found the Mac guide that works through most common errors and issues with the Mac install, but I'm still having issues. 
      Here are screenies of everything that was commonly asked for in the previous thread I read to work through this. 
      The 'you need Java...' message is what launches whenever I try to load Tribot
      Any help would be greatly appreciated!




    • By Shibalicious
      Hello,

      I have been doing some research recently and speculating on the ways Jagex trace devices and networks that players play on.

      Firstly, we know that your global IP address can be seen easily outside your local network.

      Secondly, your MAC address. I understand that it's not visible outside your router. I have seen a lot of people say that Jagex aren't able to see your MAC address but I am certain there are software and scripts that allow them to collect your devices information, including HWID and MAC address. I know this because, here, in the U.K gambling websites install a tracing tool whenever you make a new account that collects vasts amounts of data, anything there is to know about your device (device information, specifications, operating system version and even browsing history) and stores it on remote servers. This is to prevent people creating multiple accounts and abusing their promotional offers. The tool is called "iesnare" or "mpsnare" and it is completely legal for them to collect your information as it's stated in their terms and conditions. Now back to Jagex, as the Runescape client is a downloadable software, it is completely possible for them to collect various information about your device. In fact, their Privacy Policy states it clearly that they DO collect your device information as stated in this post here: https://tribot.org/forums/topic/67175-can-runescape-see-my-system-information/

      Now to my main questions:

      1. I read many threads on this forum and people suggest using proxies for multiple account botting. So if I wanted to bot on 25 different accounts and had set 25 different proxies for every single one of them, that would result in me botting on 25 different clients with unique IP addresses. Nevertheless, people who do this don't get chain-banned frequently and I have no idea why as Jagex can clearly see that you are running those clients from the same device.

      2. Lastly, if I were to setup 5 virtual machines and run 5 clients through 5 proxies on each VM, would that be seen by Jagex as 5 different devices running 5 clients each through proxies (so each client would have a different IP but they would still be able to see every 5 clients originating from the same device)?

      Any input and suggestions are really appreciated!

      Shibalicious
       
    • By mollywhopped
      Hello I need help with something that is probably a simple solution. When I try to run Tribot loader the only java version that appears in the dropbox is version 6. I have downloaded version number 8, please help?
    • By vichop11
      my mac do not start the tribot.jar it load to a point and then say:
      error ocurred during the intialization of vm
      java/unsoportedclassversionerror: java/lang/class unssoporte major minor version 51.0
      tribot has finished his proces but somo error have ocurred
       
      i actualized to the last version of java and this still dosent works
    • By Dollarbill
      Hi,
       
      My LG works fine and it successfully finds OSbuddy and reflects it, however upon it reflecting osbuddy screen, LG immediately lags incredibly much and I can barely type anything into it and in console I see this:
      http://imgur.com/a/NzAmz
      and second error it shows:
      http://imgur.com/a/egfDM
      **UPDATE**: LG screen does not lag anymore, however errors continue to be spewed out, and when i run scripts it does not run. Also, the script thinks I am not logged into game yet.
      http://imgur.com/a/Oipuu
      http://imgur.com/a/TD0s8
      Its spewing out red errors like a jet engine. (xd)
      How do I fix this error?
      pls help!!!
    • By Dollarbill
      Hello,
      Im going to be buying VIP or VIP E, which option VIP or VIP E provides looking glass client tho? In addition, VIp- E says it has proxy options, but cant you control to a VPn like expressvpn and then login on Tribot to bot?
      And also when purchasing a script It says e.g Price 2.99 Per Auth, timespan 30 days.
      Does that mean when you purchase the script it is available for 30 days however each login use of that script requires another 2.99$?
      What does Per Auth mean?
       
      Im sorry but im noob to this, please explain it to me, Thanks:)
       
       
    • By GoofyMcGoof
      This isn't going to be comprehensive or backed by expert knowledge, it's just a few general things I learned from having a low performance PC in the past
      1. Physically cleaning your pc - pcs collect a lot of dust and slow down the fans and suffocate your CPU making it run hotter, when it runs hotter your computer limits it's performance in an attempt to stop it from over heating. The best way to do this is get a can of compressed air, open your pc and spray all of the dust out. If you're really paranoid about breaking something you can touch grounded metal like a sink pipe or any metal that is grounded to discharge your static electricity lol. also try and keep your fans still when you're spraying them, having them spin from the compressed air could wear on the bearings
      Here are ways you should not do it: use a leaf blower, or a vacuum this risks the chance of creating static and messing up your computers motherboard, also do not get any water on it, don't try and clean things with a wet rag (obvious). 
       
      2. Tribot Settings - Visit this guide to tweak tri bot directly, I can attest that changing the client paint delay from 0 to 60 has made my cpu usage go from 100% to ~60%
      3. Startup - Press ctrl + r and type msconfig and go to start up tab, this will control what starts up with your computer, a lot of times people's computers are slow because a lot of unnecessary programs start up. You can remove everything here unless you truly want something to automatically start up
       
      4. Services - This step is similar to the last in that you will be removing more things that cause stuff to run on your computer. http://www.blackviper.com/service-configurations/ this link will show you what services are safe to remove, be more careful here then you were in start up because some things can actually mess stuff up. You can configure services by either going to msconfig and going to services tab and then checking "hide all microsoft services" this will hide all the important services that you don't want to disable. I recommend you search for "services" in windows and use that instead, black viper guides will go into more detail for all of this
       
      5. Defragging - You can search for the windows defrag tool or you can download a third party one like https://www.auslogics.com/en/software/disk-defrag/, I use the third party one and use the options optimize & defrag, this will clean up your harddrive and make things load faster
       
      6. CCleaner - You can use this https://www.piriform.com/ccleaner/download to clear cache and old unused files to free up space, it also has a registry scanner but in my experience reg cleaners do little to nothing when it comes to increasing performance
       
      If anyone has anything they want to add or clarify let me know
  • Our picks

    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
        • Like
      • 23 replies
    • This release will:

      Fix some ClosedChannelException bug


      Fix bug in RSObject#getAllTiles


      Add game tab support for "Kourend Favour"
        • Like
      • 15 replies
    • This release will:

      Fix Settings UI placement bug


      Fix game object location bug


      Fix small layout bug making the client shift up and down


      Fix client crashing bug where loading the client with a small display area will cause the client to crash


      Fix annoying Linux bug relating to painting events and peers


      Fix settings saving bug where settings are saved to disk more often than they should


      Fix RSInterface#isBeingDrawn bug affecting a limited amount of people


      Drop Java 1.7 bytecode version for 1.8


      Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date).


      This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support.
        • Like
      • 40 replies
    • This update will:

      Fix the RSMenuNode bug which also fixes the bug with bank opening


      Fix the incorrect object positions bug


      Fix and re-enable the LG Objects API Accelerator


      Fix the RSObject#getAllTiles bug
        • Like
      • 22 replies
    • Try our development release by checking "Development Release" on the TRiBot Loader. Note that these new features are currently in beta.

      This release features:

      Re-sizable mode support for both LG and the regular client


      Slightly improved login bot


      Removed final access modifiers from API classes


      Added RSServer hook wrapper to get the client's cached list of server/world info


      [NEW] Bug fix for intelligent banking


      [NEW] Improvement to the stability of LG over time


      [NEW] Vastly improved the reliability and speed of Screen#getColorAt on both LG and the regular client


      [NEW] Fix LG login problems


      [NEW] Fixed re-sizable mode container bug


      [NEW] Fixed re-sizable mode mouse bug


      [NEW] Use of public constants in the Banking API


      [NEW] Use of other various constants such as Projection#NULL_PT and Screen#EMPTY_COLOR



      More features to come very soon!

      Please test it and let us know here if there are any new bugs introduced in this release.
        • Thanks
        • Like
      • 12 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×