Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0
deadskulz

Unable to Purchase VIP (already bought credits)

2 posts in this topic

So the first problem was the client said I had multiple instances running which wasn't the case. Verified with Task manager. After restart I received the same error. So I purchased VIP since I was planning on doing so anyway. Now the transaction was approved, however apparently I was double charged? I'm not concerned because it's only a dollar but it's sill a little frustrating. The main problem is that it shows my account has 8 credits but I'm unable to purchase VIP. When I click "purchase" after the "get started" portal, the screen turns to a blue overlay without any content. Tried in Chrome and Firefox (win7). 

I'd appreciate any help, thank you! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.