Jump to content
laniax

[ABC2 L10] LAN Thiever [AIO] [Stalls] [Npcs] [Chests + Alching] [Blackjacking 230K XP/hr] [Cheap! ]

Recommended Posts

* Fixed blackjacking curtains open/closing.
* Improved experimental luring slightly.

I just checked most aspects from blackjacking, looks like the worldhopper is working again, food works, combat detection works and for those reporting that it doesn't detect a failed knock-out, this is not true, the script is supposed to pickpocket right after a failed knockout in order to prevent combat.

Share this post


Link to post
Share on other sites
Posted (edited)

Black jacking is still iffy aswell for me.

 

Especially if another player comes in the house the script stops which looks sketchy... Can you allow it to ignore players?

 

 

other than that getting 22k xp/hr on bandits, sometimes getting into combat every 2-4minutes.

 

 

which npc attack option is best? hidden?

Edited by W8621

Share this post


Link to post
Share on other sites
Posted (edited)

Getting 100k xp an hour with 70 thieving (+ ardy med diary); HOWEVER, just wanted to let you know when banking it skips eating the second food slot out of the 5 withdrawn, and just goes to the third. @laniax\

 

Edit for explanation: it's not exactly skipping it, just not giving your character enough time to eat the second one before moving to the third.

Edited by flashg92

Share this post


Link to post
Share on other sites
17 hours ago, W8621 said:

Black jacking is still iffy aswell for me.

 

Especially if another player comes in the house the script stops which looks sketchy... Can you allow it to ignore players?

 

 

other than that getting 22k xp/hr on bandits, sometimes getting into combat every 2-4minutes.

 

 

which npc attack option is best? hidden?

There is no way to ignore players, this is intended so you won't screw up someone else's cycle, and you'll move if someone screws up yours. If you add me on Skype or Discord i can check out what is causing your low xp/hour.

16 hours ago, flashg92 said:

Getting 100k xp an hour with 70 thieving (+ ardy med diary); HOWEVER, just wanted to let you know when banking it skips eating the second food slot out of the 5 withdrawn, and just goes to the third. @laniax\

 

Edit for explanation: it's not exactly skipping it, just not giving your character enough time to eat the second one before moving to the third.

Thanks for the report, i'll take a look :) 

15 hours ago, rspkplayer said:

Hey there. Every time I try to open the script Tribot freezes and I'm forced to shut it down. The one time it didn't freeze the GUI never opened... any advice? Thanks!

When open TRiBot, before you log in, please check the 'Console Mode' option. It should open a window where errors messages are shown. Then start the script and please show me what it says in the console.

Share this post


Link to post
Share on other sites
3 hours ago, laniax said:

There is no way to ignore players, this is intended so you won't screw up someone else's cycle, and you'll move if someone screws up yours. If you add me on Skype or Discord i can check out what is causing your low xp/hour.

Thanks for the report, i'll take a look :) 

When open TRiBot, before you log in, please check the 'Console Mode' option. It should open a window where errors messages are shown. Then start the script and please show me what it says in the console.

Thanks for responding! I tried again today, and everything loaded and it has been going strong for a solid few hours now. Sorry for worrying you; thank you for the script!

Share this post


Link to post
Share on other sites
Just now, rspkplayer said:

Thanks for responding! I tried again today, and everything loaded and it has been going strong for a solid few hours now. Sorry for worrying you; thank you for the script!

Great, glad to hear everything is running OK :) It might've been that you have to restart the client 2x after every runescape game update. I think the game updated earlier today.

If you have any questions or suggestions feel free to contact me!

Share this post


Link to post
Share on other sites

trying this script in ardy on bakery stalls and keep getting this error which stops the script when it goes to bank.

 

Quote
  • [14:10:20] [Banking]: Using the deposit all button.
  • [14:10:25] java.lang.NullPointerException
  • [14:10:25] at org.tribot.api2007.types.RSObject.getModel(zm:614)
  • [14:10:25] at org.tribot.api.DynamicClicking.clickRSObject(uq:334)
  • [14:10:25] at org.tribot.api2007.Banking.openBank(id:245)
  • [14:10:25] at scripts.lanframework.script.prefabs.BankAction.f(BankAction.java:118)
  • [14:10:25] at scripts.lanframework.script.prefabs.BankAction.m(BankAction.java:447)
  • [14:10:25] at scripts.lanframework.script.p.run(ScriptAction.java:96)
  • [14:10:25] at scripts.lanapi.game.script.LANScript.run(LANScript.java:281)
  • [14:10:25] at java.lang.Thread.run(Thread.java:748)
  • [14:10:37] [Inventory]: Got the following items in this session (time: 00:06:14):
  • [14:10:37] [Inventory]: - [7x] Chocolate slice
  • [14:10:37] [Inventory]: - [19x] Cake
  • [14:10:37] [Inventory]: - [9x] Bread
  • [14:10:40] Script Ended: LAN Thiever.

 

Any ideas?

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, laniax said:

Are you using Looking Glass? It sounds like an old client bug that should've been fixed a while ago. I can reopen the issue if you are on LG.

Yea i am using looking glass. Also another wierd thing i am having is the bot is going to the safe spot at the bakers stall and just clicking on the safe tile instead of constantly stealing. Like it will steal once then spam click the ground like 10 times before stealing again. i have a gif showing the problem here https://gyazo.com/dfaf5f5df7188765f677d618ab99c6f5

Edit: had another script doing wierd things aswell and was advised to stop using LG with the osrs client and instead use osbuddy, since then the banking problem seems to have gone away but it still does the safe spot spam.

Edited by Randoom

Share this post


Link to post
Share on other sites
8 hours ago, Randoom said:

Yea i am using looking glass. Also another wierd thing i am having is the bot is going to the safe spot at the bakers stall and just clicking on the safe tile instead of constantly stealing. Like it will steal once then spam click the ground like 10 times before stealing again. i have a gif showing the problem here https://gyazo.com/dfaf5f5df7188765f677d618ab99c6f5

Edit: had another script doing wierd things aswell and was advised to stop using LG with the osrs client and instead use osbuddy, since then the banking problem seems to have gone away but it still does the safe spot spam.

Can you try again? I pushed a update which should fix this.

Share this post


Link to post
Share on other sites
1 hour ago, Charvie said:

hey @laniax is the client bug preventing you from implementing shift dropping fixed yet? Would be a great addition for master farmers 

Sadly no, but i'm working on some antiban stuff that will allow me to add a workaround.

(PS. I wouldn't trust other scripts with shift dropping, because most of them press shift instantly before clicking on the items)

Share this post


Link to post
Share on other sites
On 8/18/2017 at 1:22 AM, laniax said:

Sadly no, but i'm working on some antiban stuff that will allow me to add a workaround.

(PS. I wouldn't trust other scripts with shift dropping, because most of them press shift instantly before clicking on the items)

No worries, thanks for the info :) Really enjoying the script. 

just had a minor issue with the ardy knight house, with "the door seems to be stuck". Bot would just keep trying to click the door to close it. I was babysitting so just moved it manually, nothing in the debug either.  Might've been someone trying to fuck with bots? not sure if there's something you can do for the in your upcoming antiban update :)

Spoiler

N237F9j.png

 

  • Like 1

Share this post


Link to post
Share on other sites
54 minutes ago, EKOx REACTZz said:

Blackjacking is just broken once again, as soon as you start the script it just logs off and ends itself...

The login bot is broken, use the luring option to prevent it from hopping worlds. If you have other issues please post the details of your problem and the content of the bot debug log.

Share this post


Link to post
Share on other sites
13 minutes ago, laniax said:

The login bot is broken, use the luring option to prevent it from hopping worlds. If you have other issues please post the details of your problem and the content of the bot debug log.

Does the same thing even when I use the  luring option or world hopper, start the script then it logs off and closes the script.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

×