Jump to content
Athylius

Connection error using VPN when loading client

Recommended Posts

Hi all,

 

I can't seem to get my Tribot client to load, I have connected to a VPN, and it just says 'connection error exception' and nothing else, no other messages etc. when I click login, I have logged in on the website via the vpn connection no problems, but the client itself will not let me.

 

Any suggestions?

 

Regards,

 

Athy:P

Share this post


Link to post
Share on other sites
Just now, Athylius said:

Hi all,

 

I can't seem to get my Tribot client to load, I have connected to a VPN, and it just says 'connection error exception' and nothing else, no other messages etc. when I click login, I have logged in on the website via the vpn connection no problems, but the client itself will not let me.

 

Any suggestions?

 

Regards,

 

Athy:P

There is potential the CloudFlare used to protect TRiBot's servers has the IP of your VPN blacklisted, and as a result this prevents you from connecting to TRiBot. If you can connect without the VPN, then I would assume that is the case and would advise trying a different VPN server.

Share this post


Link to post
Share on other sites
16 hours ago, iFluffee said:

There is potential the CloudFlare used to protect TRiBot's servers has the IP of your VPN blacklisted, and as a result this prevents you from connecting to TRiBot. If you can connect without the VPN, then I would assume that is the case and would advise trying a different VPN server.

Thanks, I'll give it a go. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Fluffee
      How to Run Most Applications Through a Proxy on both Windows and Linux
      Windows Instructions
      Note: Chrome and Firefox portable do not work with WideCap.
      1. Download WideCap from here (http://widecap.ru/en/download/)
      2. Run through the installer, and launch WideCap, you should see this screen.

      3.Go ahead and click on Settings (First option under the Widecap section on the left hand side). Then uncheck the box that says Run with system startup.

      4. Now go ahead and click on New proxy (First option under the proxies section on the left hand side).
      5.You should see this screen, in the top field enter the IP address and port (IP:Port format). Confirm that the protocol is set to SOCKS v5 (which is the default), and tick the box for Authentication if necessary. If using an authenticated proxy, enter your username in the login field, and obviously your password in the password field. Then hit the Create New button, next to Chain, and type in a name for your Proxy, then Hit OK

      6. Now that you're back to the main screen, click on the Proxy List section (Second option under the proxies section on the left hand side). Right click on your newly added proxy, and click check selected, to make sure you entered all the information correctly. If the status field rolls over to OK, you're good to go, and can move on to the next step

      7. Find WideCap in your System tray, right click, and uncheck the box that says Enable Widecap.

      8. Click on View Programs (Second option under the Programs section on the left hand side). Then drag and drop the icon for the application you want to proxify (run behind a proxy) into WideCap. WideCap supports the proxifying of both .exe and .jar files!

      9. Right Click on your newly added program, and click on Modify Application, you should see a similar screen depending on what you added. Then click on Create New... (to create a new rule)

      10. In the Chain tab, select the Proxy Chain you created earlier, then under the Main tab, give your new rule a name and hit OK. Then Hit OK again on the modify Application screen.

      11. Hit Apply and OK in the main window of WideCap, and then find it in your System Tray again, but this time click the box to Enable Widecap
      12.Open your Proxified application, and check to see if the proxy worked! If your IP is changed, congrats, you've got WideCap working!
      Linux Instructions (Based off of a Debian Installation)
      1. Open a new terminal and run this command
      sudo apt-get update && sudo apt-get install -y proxychains 2. Now that proxychains is installed, we're going to go ahead and create a user specific configuration file. To do this, we'll make a directory, then copy the standard proxychains configuration file to it and change the ownership of the configuration file to your user. Run the command below as your user.
      mkdir ~/.proxychains/ && cp /etc/proxychains.conf ~/.proxychains/proxychains.conf && sudo chown ${USER:=$(/usr/bin/id -run)} $HOME/.proxychains/proxychains.conf && sudo chgrp ${USER:=$(/usr/bin/id -run)} $HOME/.proxychains/proxychains.confroxychains.conf 3. Once the command is finished, open the proxychains config file in your favorite Linux text editor, for ease of use, I'm going to use nano. To install nano run this command
      sudo apt-get install -y nano To edit the proxychains config file, with nano, run this command
      nano ~/.proxychains/proxychains.conf 4. Now, what you'll want to do is scroll all the way down to the bottom, and you should see something like this

      That last line that says
      socks4    127.0.0.1    9050
      That's the line we'll be editing. Firstly, we'll go ahead and erase everything on that line, don't worry we'll put it back. The format for the configuration file is
      Proxy Type(lowercase) (tab) IP address (tab) Port (tab) Username (tab) Password
      Therefore if your proxy was a Socks5 proxy, with an IP of 192.168.1.1, a port of 1080, a username of Fluffee and a password of TRiBot, your final line would look like this:
      socks5    192.168.1.1    1080    Fluffee    TRiBot
      So, go ahead and modify your last line to fit your own proxy and then hit Control+X to exit, and then hit Y to save (instructions are based off of using nano to edit the file).
      5. Proxychains is now setup, but how do you use it? Go ahead and VNC into your Server and open a terminal, or open a Terminal inside your Desktop Environment (if using Linux installed on a PC). From there run the command proxychains followed by the application you would like to run, or the path to the application. For example, try running, if you have Firefox installed:
      proxychains firefox Then navigate to an IP checking website, and see if your proxy worked!
      That concludes the tutorial on how to use a proxy with Oldschool or any browser, on both Linux and Windows. If you have any questions feel free to post in the comments!
    • By r0ot
      I've nearly got TRiBot running on an Ubuntu machine but have run into an error with the loader.  When I run the loader for the first time and it populates the dependencies folder, the file togl.dll get's downloaded instead of libTOGL.so which TRiBot.jar eventually looks for.  Error looks like this:
      Loading TOGL Loading: /home/<user>/.tribot/dependancies/libTOGL.so Exception in thread "AWT-EventQueue-1" java.lang.UnsatisfiedLinkError: Can't load library /home/<user>/.tribot/dependancies/ibTOGL.so Inside my dependencies folder there's a file called togl.dll.  The bug report forum says I need to post here before I can post there.
    • By adog75
      Hi Tribot,
      About to purchase proxies from blazing proxies. Anyone have a promo code they'd like to share ^^? Thanks in advance
    • By Jigglepurf
      So i try to start triBot and it says "Files loaded triBot will now start" and then the window closes and Nothing else happens. Am i doing something wrong?
    • By sgt p0wned
      hey guys, im getting an error
      [23:20:56] TRiBot Release 9.307_0 loaded. (1.8.0_102:C:\Program Files (x86)\Java\jre1.8.0_102)
      [23:20:56] Loading human mouse movement data.
      [23:20:57] Successfully loaded human mouse data.
      [23:21:09] Exception in thread "0"
      [23:21:09] java.lang.ArrayIndexOutOfBoundsException: 1
      [23:21:09]     at java.util.ArrayList.elementData(Unknown Source)
      [23:21:09]     at java.util.ArrayList.get(Unknown Source)
      [23:21:09]     at obf.nh.kH(bd:304)
      [23:21:09]     at obf.nh.yg(bd:75)
      [23:21:09]     at obf.Ql.LK(bh:523)
      [23:21:09]     at obf.RK.Da(ao:27)
      [23:21:09]     at obf.xk.m(wm:562)
      [23:21:09]     at obf.xk.<init>(wm:161)
      [23:21:09]     at obf.Ql.<init>(bh:162)
      [23:21:09]     at obf.RK.<init>(ao:192)
      [23:21:09]     at obf.vJ.<init>(gg:113)
      [23:21:09]     at obf.EG.run(af:738)
      [23:21:09]     at java.lang.Thread.run(Unknown Source)
      [23:21:09] Exception in thread "-1"
      [23:21:09] java.lang.ArrayIndexOutOfBoundsException: 1
      [23:21:09]     at java.util.ArrayList.elementData(Unknown Source)
      [23:21:09]     at java.util.ArrayList.get(Unknown Source)
      [23:21:09]     at obf.nh.kH(bd:304)
      [23:21:09]     at obf.nh.yg(bd:75)
      [23:21:09]     at obf.Ql.LK(bh:523)
      [23:21:09]     at obf.RK.Da(ao:27)
      [23:21:09]     at obf.xk.m(wm:562)
      [23:21:09]     at obf.xk.<init>(wm:161)
      [23:21:09]     at obf.Ql.<init>(bh:162)
      [23:21:09]     at obf.RK.<init>(ao:192)
      [23:21:09]     at obf.vJ.<init>(gg:113)
      [23:21:09]     at obf.EG.run(af:738)
      [23:21:09]     at java.lang.Thread.run(Unknown Source)
       
      Is there a known fix?
      FOUND A FIX.. I'm Blind..
      A username and password helps.. forgot i just deleted .tri file.
      My bad..
    • By rtorry
      Im new to tribot and runscape. I was told theres go money to be made selling gold off the game. For this I need proxies..I have that or can easily get them..my problem is connecting Tor with tribot, no clue how to get them to connect to each other. Is it needed for me to run multiple accounts or are the proxies good enough? Either way I would like to know how to do so
    • By rtorry
      I just bought a VIP membership but I can't even get the client to install. When I download the file it comes as a jar file. Once extracted it just give me 4 folders,. Im completely lost and videos I look at show something completely different going on. Please help
    • By zawok
      Hi, whenever I try to start an advanced client with proxies it gets stuck on "loading client params". I've seen another post about it ( from 2015 ) and it didnt correct my problem.
      I use the last version of Java 8_161 and I tried both 32 bit, 64 bit for windows. I've tried deleting .tribot, changing heap size , changing in CMD to make sure I was connecting in IPV4 and not IPV6... I'm kinda stuck right now ! ( Also uninstalled and reinstalled both Java, tried Jdk, not working )
      Here's the client debug
      and it just keep repeating...
  • Our picks

    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
      • 23 replies
    • This release will:

      Fix some ClosedChannelException bug


      Fix bug in RSObject#getAllTiles


      Add game tab support for "Kourend Favour"
      • 15 replies
    • This release will:

      Fix Settings UI placement bug


      Fix game object location bug


      Fix small layout bug making the client shift up and down


      Fix client crashing bug where loading the client with a small display area will cause the client to crash


      Fix annoying Linux bug relating to painting events and peers


      Fix settings saving bug where settings are saved to disk more often than they should


      Fix RSInterface#isBeingDrawn bug affecting a limited amount of people


      Drop Java 1.7 bytecode version for 1.8


      Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date).


      This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support.
      • 40 replies
    • This update will:

      Fix the RSMenuNode bug which also fixes the bug with bank opening


      Fix the incorrect object positions bug


      Fix and re-enable the LG Objects API Accelerator


      Fix the RSObject#getAllTiles bug
      • 22 replies
    • Try our development release by checking "Development Release" on the TRiBot Loader. Note that these new features are currently in beta.

      This release features:

      Re-sizable mode support for both LG and the regular client


      Slightly improved login bot


      Removed final access modifiers from API classes


      Added RSServer hook wrapper to get the client's cached list of server/world info


      [NEW] Bug fix for intelligent banking


      [NEW] Improvement to the stability of LG over time


      [NEW] Vastly improved the reliability and speed of Screen#getColorAt on both LG and the regular client


      [NEW] Fix LG login problems


      [NEW] Fixed re-sizable mode container bug


      [NEW] Fixed re-sizable mode mouse bug


      [NEW] Use of public constants in the Banking API


      [NEW] Use of other various constants such as Projection#NULL_PT and Screen#EMPTY_COLOR



      More features to come very soon!

      Please test it and let us know here if there are any new bugs introduced in this release.
      • 12 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×