Jump to content
iant06

[ABC2] iClueSolver by iant06 [H.A.M.][Men][Implings][Grand Exchange][Low Reqs]

Recommended Posts

iant06    155
54 minutes ago, foxfall said:

One question. Why does the script walk all the way to the grandtree for the big mushroom clue. wouldnt it be faster to use a tab or tele spell? ( i do not have ardy tele unlocked) could be the factor in this.)

Pretty much this, if you don't have ardougne teleport unlocked it will teleport to camelot instead and walk from there.

Share this post


Link to post
Share on other sites
rvqx    28

looks like combat part has a bag. Whenever i start the script with combat option, attacks a ham guard then script ends immediately.

Clent Debug:

  • [20:19:46] Starting client.
  • [20:20:38] Downloading script 'iClueSolver'.
  • [20:20:40] Script Started: iClueSolver.
  • [20:20:41] Starting script for: D********
  • [20:20:41] D******, COMBAT, TABS, Lobster, 10
  • [20:20:44] Starting iClueSolver by iant06.
  • [20:20:44] Acquiring Clues using: Combat
  • [20:20:44] Teleporting using: Tabs
  • [20:20:44] Bringing 10 Lobster for food.
  • [20:20:44] Eating food if HP is below 54%
  • [20:20:44] Setting Equipment: Mithril full helm, Obsidian cape, Adamant scimitar, Mithril platebody, Mithril kiteshield, Mithril platelegs, Mithril boots,
  • [20:20:51] The script's paint appears to be frozen. Attempting to recover the paint thread.
  • [20:20:51] Stack Trace:
  • [20:20:51] - java.net.SocketInputStream.socketRead0(Native Method)
  • [20:20:51] - java.net.SocketInputStream.socketRead(Unknown Source)
  • [20:20:51] - java.net.SocketInputStream.read(Unknown Source)
  • [20:20:51] - java.net.SocketInputStream.read(Unknown Source)
  • [20:20:51] - java.io.BufferedInputStream.fill(Unknown Source)
  • [20:20:51] - java.io.BufferedInputStream.read1(Unknown Source)
  • [20:20:51] - java.io.BufferedInputStream.read(Unknown Source)
  • [20:20:51] - sun.net.www.http.HttpClient.parseHTTPHeader(Unknown Source)
  • [20:20:51] - sun.net.www.http.HttpClient.parseHTTP(Unknown Source)
  • [20:20:51] - sun.net.www.protocol.http.HttpURLConnection.getInputStream0(Unknown Source)
  • [20:20:51] - sun.net.www.protocol.http.HttpURLConnection.access$200(Unknown Source)
  • [20:20:51] - sun.net.www.protocol.http.HttpURLConnection$9.run(Unknown Source)
  • [20:20:51] - sun.net.www.protocol.http.HttpURLConnection$9.run(Unknown Source)
  • [20:20:51] - java.security.AccessController.doPrivileged(Native Method)
  • [20:20:51] - java.security.AccessController.doPrivilegedWithCombiner(Unknown Source)
  • [20:20:51] - sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
  • [20:20:51] - scripts.a.e.A(Methods.java:265)
  • [20:20:51] - scripts.a.e.A(Methods.java:249)
  • [20:20:51] - scripts.clues.t.(Constants.java:342)
  • [20:20:51] - scripts.clues.Main.onPaint(Main.java:538)
  • [20:20:51] - obf.Vi.h(lg:750)
  • [20:20:51] - obf.Bh.run(cp:120)
  • [20:20:51] - java.lang.Thread.run(Unknown Source)
  • [20:20:54] The script's paint thread was recovered.
  • [20:21:03] java.lang.IllegalArgumentException: Waiting time must be in the range [0, 2^28).
  • [20:21:03] at org.tribot.api.util.abc.ABCProperties.setWaitingTime(mg:175)
  • [20:21:03] at scripts.clues.Main.A(Main.java:438)
  • [20:21:03] at scripts.clues.actions.t.E(InteractEntity.java:269)
  • [20:21:03] at scripts.clues.Main.A(Main.java:225)
  • [20:21:03] at scripts.clues.Main.handleState(Main.java:48)
  • [20:21:03] at org.tribot.script.EnumScript.run(vj:84)
  • [20:21:03] at java.lang.Thread.run(Unknown Source)
  • [20:21:03] Script Ended: iClueSolver.

 

Bot Debug:

  • [20:18:54] TRiBot Release 9.300_8 loaded. (1.8.0_91:C:\Program Files\Java\jre1.8.0_91)
  • [20:18:55] Loading human mouse movement data.
  • [20:18:58] Successfully loaded human mouse data.
  • [20:20:40] java.lang.NullPointerException
  • [20:20:40] at scripts.clues.Main.onPaint(Main.java:536)
  • [20:20:40] at obf.Vi.h(lg:750)
  • [20:20:40] at obf.Bh.run(cp:120)
  • [20:20:40] at java.lang.Thread.run(Unknown Source)
  • [20:20:40] java.lang.NullPointerException
  • [20:20:40] at scripts.clues.Main.onPaint(Main.java:536)
  • [20:20:40] at obf.Vi.h(lg:750)
  • [20:20:40] at obf.Bh.run(cp:120)
  • [20:20:40] at java.lang.Thread.run(Unknown Source)
  • [20:20:44] Successfully saved profile for account: D********

 

I have no problem with thieving option but combat.  @iant06

Share this post


Link to post
Share on other sites
iant06    155
6 minutes ago, iprocheat said:

Added more info

It's because the minimum amount of food required was set to 2 and your food amount was set to 1. 

Fixed it so you can now carry 1 piece of food :)

Edited by iant06

Share this post


Link to post
Share on other sites
iant06    155
3 hours ago, balvons said:

Script often fails to find items in bank for emote clue and then stops.

Thanks for letting me know, just updated the script to wait a little longer when searching for items in your bank, let me know if the problem persists! :)

Share this post


Link to post
Share on other sites
balvons    19
5 hours ago, iant06 said:

Thanks for letting me know, just updated the script to wait a little longer when searching for items in your bank, let me know if the problem persists! :)

I think time is not the problem. I left only clue items in bank so its not hard to find the right ones, but the script takes only 1 item at the time and then stops. Then when i try to rerun it it takes another one and stops again. I dont know if anyone else is having this issue, but at the moment this is the only error i get, without it script is working very well. 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×