Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

ollien18

Running Looking Glass on mac help

10 posts in this topic

Hi all, having trouble running LG on my mac. 

I use the OSbuddy client as recommended alongside the tribot client running looking glass, however when looking for client to attach to it just states that 'cant find client' and that 'osbuddy is running 32bit (most likely) and that tribot is running 64 bit, when it should be running 32bit. How do i resolve this ? 

 

Many Thanks, Ollie

Share this post


Link to post
Share on other sites
Just now, ollien18 said:

Hi all, having trouble running LG on my mac. 

I use the OSbuddy client as recommended alongside the tribot client running looking glass, however when looking for client to attach to it just states that 'cant find client' and that 'osbuddy is running 32bit (most likely) and that tribot is running 64 bit, when it should be running 32bit. How do i resolve this ? 

 

Many Thanks, Ollie

Check your installed Java versions, and confirm you only have one version installed. The easiest solution is to just leave a 32 bit Java, and then you'll have no issues hooking to OSBuddy. However, if you only have a 64 bit version installed you can either uninstall the 64 bit and install a 32 bit version (link here), or you can run OSBuddy from the .jar file instead of the .dmg which you are using now. Link to the .jar file can be found here (direct download link): http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

Share this post


Link to post
Share on other sites
9 minutes ago, iFluffee said:

Check your installed Java versions, and confirm you only have one version installed. The easiest solution is to just leave a 32 bit Java, and then you'll have no issues hooking to OSBuddy. However, if you only have a 64 bit version installed you can either uninstall the 64 bit and install a 32 bit version (link here), or you can run OSBuddy from the .jar file instead of the .dmg which you are using now. Link to the .jar file can be found here (direct download link): http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

Thanks for the reply iFluffee, i think mac only supports 64bit java, so i went ahead and used the .jar file like you recommended and now I'm able to get past the problem but instead in the Tribot client where runescape should be its just a Whited out square ( but can hear the runescape music)

 

Any ideas ?

 

Thanks again

 

Share this post


Link to post
Share on other sites
Just now, ollien18 said:

Thanks for the reply iFluffee, i think mac only supports 64bit java, so i went ahead and used the .jar file like you recommended and now I'm able to get past the problem but instead in the Tribot client where runescape should be its just a Whited out square ( but can hear the runescape music)

 

Any ideas ?

 

Thanks again

 

Is there anything being printed in the bot/client debug? Does the RS client ever appear in TRiBot?

Share this post


Link to post
Share on other sites
3 minutes ago, iFluffee said:

s there anything being printed in the bot/client debug? Does the RS client ever appear in TRiBot?

It just says 'Client Started'

 

Where the runescape client should have appeared in tribot is just a big white square

Share this post


Link to post
Share on other sites
  • [01:27:51] TRiBot Release 9.300_6 loaded. (1.8.0_77:/Library/Java/JavaVirtualMachines/jdk1.8.0_77.jdk/Contents/Home/jre)
  • [01:27:52] Loading human mouse movement data.
  • [01:27:54] Successfully loaded human mouse data.
  • [01:27:59] java.io.IOException: Connection refused
  • [01:27:59] at sun.tools.attach.BsdVirtualMachine.connect(Native Method)
  • [01:27:59] at sun.tools.attach.BsdVirtualMachine.(BsdVirtualMachine.java:108)
  • [01:27:59] at sun.tools.attach.BsdAttachProvider.attachVirtualMachine(BsdAttachProvider.java:78)
  • [01:27:59] at obf.VO.g(et:575)
  • [01:27:59] at obf.VO.g(et:407)
  • [01:27:59] at obf.Yl.run(xj:154)
  • [01:27:59] at java.lang.Thread.run(Thread.java:745)
  • [01:27:59] java.io.IOException: Connection refused
  • [01:27:59] at sun.tools.attach.BsdVirtualMachine.connect(Native Method)
  • [01:27:59] at sun.tools.attach.BsdVirtualMachine.(BsdVirtualMachine.java:108)
  • [01:27:59] at sun.tools.attach.BsdAttachProvider.attachVirtualMachine(BsdAttachProvider.java:78)
  • [01:27:59] at obf.VO.g(et:575)
  • [01:27:59] at obf.VO.g(et:407)
  • [01:27:59] at obf.Yl.run(xj:154)
  • [01:27:59] at java.lang.Thread.run(Thread.java:745)
  • [01:28:00] java.lang.SecurityException: Internet Connection Denied: 10.29.33.172
  • [01:28:00] at obf.hC.checkPermission(nd:752)
  • [01:28:00] at java.lang.SecurityManager.checkConnect(SecurityManager.java:1051)
  • [01:28:00] at java.net.Socket.connect(Socket.java:584)
  • [01:28:00] at java.net.Socket.connect(Socket.java:538)
  • [01:28:00] at java.net.Socket.(Socket.java:434)
  • [01:28:00] at java.net.Socket.(Socket.java:211)
  • [01:28:00] at sun.rmi.transport.proxy.RMIDirectSocketFactory.createSocket(RMIDirectSocketFactory.java:40)
  • [01:28:00] at sun.rmi.transport.proxy.RMIMasterSocketFactory.createSocket(RMIMasterSocketFactory.java:148)
  • [01:28:00] at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:613)
  • [01:28:00] at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:216)
  • [01:28:00] at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:202)
  • [01:28:00] at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:130)
  • [01:28:00] at javax.management.remote.rmi.RMIServerImpl_Stub.newClient(Unknown Source)
  • [01:28:00] at javax.management.remote.rmi.RMIConnector.getConnection(RMIConnector.java:2430)
  • [01:28:00] at javax.management.remote.rmi.RMIConnector.connect(RMIConnector.java:308)
  • [01:28:00] at javax.management.remote.JMXConnectorFactory.connect(JMXConnectorFactory.java:270)
  • [01:28:00] at javax.management.remote.JMXConnectorFactory.connect(JMXConnectorFactory.java:229)
  • [01:28:00] at obf.VO.g(et:379)
  • [01:28:00] at obf.Yl.run(xj:154)
  • [01:28:00] at java.lang.Thread.run(Thread.java:745) 

This was in the bot debug

Edited by ollien18
Left something out

Share this post


Link to post
Share on other sites
1 minute ago, ollien18 said:
  • [01:27:51] TRiBot Release 9.300_6 loaded. (1.8.0_77:/Library/Java/JavaVirtualMachines/jdk1.8.0_77.jdk/Contents/Home/jre)
  • [01:27:52] Loading human mouse movement data.
  • [01:27:54] Successfully loaded human mouse data.
  • [01:27:59] java.io.IOException: Connection refused
  • [01:27:59] at sun.tools.attach.BsdVirtualMachine.connect(Native Method)
  • [01:27:59] at sun.tools.attach.BsdVirtualMachine.(BsdVirtualMachine.java:108)
  • [01:27:59] at sun.tools.attach.BsdAttachProvider.attachVirtualMachine(BsdAttachProvider.java:78)
  • [01:27:59] at obf.VO.g(et:575)
  • [01:27:59] at obf.VO.g(et:407)
  • [01:27:59] at obf.Yl.run(xj:154)
  • [01:27:59] at java.lang.Thread.run(Thread.java:745)
  • [01:27:59] java.io.IOException: Connection refused
  • [01:27:59] at sun.tools.attach.BsdVirtualMachine.connect(Native Method)
  • [01:27:59] at sun.tools.attach.BsdVirtualMachine.(BsdVirtualMachine.java:108)
  • [01:27:59] at sun.tools.attach.BsdAttachProvider.attachVirtualMachine(BsdAttachProvider.java:78)
  • [01:27:59] at obf.VO.g(et:575)
  • [01:27:59] at obf.VO.g(et:407)
  • [01:27:59] at obf.Yl.run(xj:154)
  • [01:27:59] at java.lang.Thread.run(Thread.java:745)
  • [01:28:00] java.lang.SecurityException: Internet Connection Denied: 10.29.33.172
  • [01:28:00] at obf.hC.checkPermission(nd:752)
  • [01:28:00] at java.lang.SecurityManager.checkConnect(SecurityManager.java:1051)
  • [01:28:00] at java.net.Socket.connect(Socket.java:584)
  • [01:28:00] at java.net.Socket.connect(Socket.java:538)
  • [01:28:00] at java.net.Socket.(Socket.java:434)
  • [01:28:00] at java.net.Socket.(Socket.java:211)
  • [01:28:00] at sun.rmi.transport.proxy.RMIDirectSocketFactory.createSocket(RMIDirectSocketFactory.java:40)
  • [01:28:00] at sun.rmi.transport.proxy.RMIMasterSocketFactory.createSocket(RMIMasterSocketFactory.java:148)
  • [01:28:00] at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:613)
  • [01:28:00] at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:216)
  • [01:28:00] at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:202)
  • [01:28:00] at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:130)
  • [01:28:00] at javax.management.remote.rmi.RMIServerImpl_Stub.newClient(Unknown Source)
  • [01:28:00] at javax.management.remote.rmi.RMIConnector.getConnection(RMIConnector.java:2430)
  • [01:28:00] at javax.management.remote.rmi.RMIConnector.connect(RMIConnector.java:308)
  • [01:28:00] at javax.management.remote.JMXConnectorFactory.connect(JMXConnectorFactory.java:270)
  • [01:28:00] at javax.management.remote.JMXConnectorFactory.connect(JMXConnectorFactory.java:229)
  • [01:28:00] at obf.VO.g(et:379)
  • [01:28:00] at obf.Yl.run(xj:154)
  • [01:28:00] at java.lang.Thread.run(Thread.java:745) 

Here's your issue: java.lang.SecurityException: Internet Connection Denied: 10.29.33.172

Have you denied anything in your TRiBot firewall? If not, check your Mac's firewall and see if you can disable it; then relaunch TRiBot.

Edit: Are you using a proxy?

Edited by iFluffee

Share this post


Link to post
Share on other sites
1 minute ago, iFluffee said:

Here's your issue: java.lang.SecurityException: Internet Connection Denied: 10.29.33.172

Have you denied anything in your TRiBot firewall? If not, check your Mac's firewall and see if you can disable it; then relaunch TRiBot.

Edit: Are you using a proxy?

I think i might have declined something from Tribot :blush: - how do i go about reversing it 

Share this post


Link to post
Share on other sites
3 minutes ago, ollien18 said:

I think i might have declined something from Tribot :blush: - how do i go about reversing it 

In TRiBot itself? Follow the .gif below :)

NkdTKN6.gif

Share this post


Link to post
Share on other sites
1 minute ago, iFluffee said:

In TRiBot itself? Follow the .gif below :)

Worked Perfectly bro ! Thanks for all the help !!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.