Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  
Followers 0

I can open old school runescape but not rs3

3 posts in this topic

Title says it all

picture is what it says when I tried to start it up

Ive tried deleting and re-installing java

ive downloaded the java 8 jdk

Using windows 10

The client never actually loads

Also the runescape 3 client barely runs on my computer. any idea as is what could it be?


Edited by zeldastolemypot

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.