Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

RaynorJames

"Java JDK" error loading "Looking Glass"

8 posts in this topic

I already have the web client up and running before I even launch TriBot. And I have already downloaded Java JDK 8 with the 32-bit, but I still get the same error that says, "You must run TriBot using the java JDK in order to use looking glass". I'm sure there is a easy solution but I am not sure what it is. any suggestions?

Share this post


Link to post
Share on other sites

On the TRiBot loader, there is a drpodown box for selecting java version.
Make sure you select JDK before loading.

Share this post


Link to post
Share on other sites
3 minutes ago, YoHoJo said:

On the TRiBot loader, there is a drpodown box for selecting java version.
Make sure you select JDK before loading.

Thank you, how do you check what bit you are running you TriBot in, is it the same bit that you downloaded the JDK as?

Share this post


Link to post
Share on other sites
3 minutes ago, RaynorJames said:

Thank you, how do you check what bit you are running you TriBot in, is it the same bit that you downloaded the JDK as?

That's correct. Your path should look something like C:\Program Files(x86)\Java\jdk1.8XXX. Make sure it's not the \jre1.8XXX.

Share this post


Link to post
Share on other sites
28 minutes ago, chrismoon said:

That's correct. Your path should look something like C:\Program Files(x86)\Java\jdk1.8XXX. Make sure it's not the \jre1.8XXX.

Ok well I downloaded the 32 bit and was having errors even though it says 32 bit is recommended because that was runescape runs, but I am going to try the 64 bit. 

(Update) : I ran the 64-bit and it says I need a 32 bit but it still wont run with a 32 bit JDK. Any suggestions?

Edited by RaynorJames

Share this post


Link to post
Share on other sites
14 hours ago, RaynorJames said:

Ok well I downloaded the 32 bit and was having errors even though it says 32 bit is recommended because that was runescape runs, but I am going to try the 64 bit. 

(Update) : I ran the 64-bit and it says I need a 32 bit but it still wont run with a 32 bit JDK. Any suggestions?

What error is occuring? A picture could help. Also, uninstall all Java versions but one (whether that be 64 or 32) that should help tidy things up. The thing is TRiBot and the RuneScape client need to be in the same bits. The reason 32 bit is recommended is that most browsers and clients are 32 bit therefore it's easier to use LG with 32 bit. I'd recommend uninstalling all Java's then reinstalling the 32 bit (x86) JDK from here: http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

Share this post


Link to post
Share on other sites
On 4/16/2016 at 0:42 PM, iFluffee said:

What error is occuring? A picture could help. Also, uninstall all Java versions but one (whether that be 64 or 32) that should help tidy things up. The thing is TRiBot and the RuneScape client need to be in the same bits. The reason 32 bit is recommended is that most browsers and clients are 32 bit therefore it's easier to use LG with 32 bit. I'd recommend uninstalling all Java's then reinstalling the 32 bit (x86) JDK from here: http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

Ok thank you, I have it running but I am running it in 32 bit, is there any way to run looking glass in 64 bit because with 32 bit I can only allocate 1250mb of RAM to the client, which isn't a lot. So if I had 64 bit running I could do up to 5000mb of RAM. Any way on how to find a 64 bit client?

Share this post


Link to post
Share on other sites
4 hours ago, RaynorJames said:

Ok thank you, I have it running but I am running it in 32 bit, is there any way to run looking glass in 64 bit because with 32 bit I can only allocate 1250mb of RAM to the client, which isn't a lot. So if I had 64 bit running I could do up to 5000mb of RAM. Any way on how to find a 64 bit client?

To run a 64 bit client, have only the 64 bit JDK installed, and then run OldSchool via the OSBuddy.jar, or download a 64 bit version of your browser and use that. I know Firefox has a 64 bit version, I can't speak for the other browsers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.