Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Cssacc

Payment failed: We cannot process this order because we suspect it may be fraudulent.

24 posts in this topic

Payment failed: We cannot process this order because we suspect it may be fraudulent.

 

trying to pay with my bank card.

Share this post


Link to post
Share on other sites
2 hours ago, Cssacc said:

Payment failed: We cannot process this order because we suspect it may be fraudulent.

 

trying to pay with my bank card.

Are you currently behind a VPN or proxy?

If not, try using a different card, or an alternative payment method such as PayPal or BitCoin

Share this post


Link to post
Share on other sites
6 minutes ago, iFluffee said:

Again, try using BitCoin, that never seems to have issues. Did you verify your paypal with TRiBot? By clicking the link in the email?

they didn't send a email...

Share this post


Link to post
Share on other sites
26 minutes ago, Lax said:

they didn't send a email...

Did you check your PayPal email? Not your TRiBot email

Share this post


Link to post
Share on other sites
8 minutes ago, iFluffee said:

Did you check your PayPal email? Not your TRiBot email

I dont have bitcoin set up.. I don't think most people do either, plus doing all this bitcoin shit for like a $5 payment is nuts. This is obviously a tribot issue trilez just needs to fix it

Share this post


Link to post
Share on other sites
43 minutes ago, loochyx2 said:

Same thing happened to me, I even tried using my debit card too. 

 

43 minutes ago, x0joe0x said:

I dont have bitcoin set up.. I don't think most people do either, plus doing all this bitcoin shit for like a $5 payment is nuts. This is obviously a tribot issue trilez just needs to fix it

The issue seems to be more prominent as of late, however it's been around for a long time and the admin team has made no move to fix it due to the heavy amount of fraud in the runescape botting industry. BitCoin or a reseller are the solutions which you can implement yourself, I'd trying one of those.

Edited by iFluffee

Share this post


Link to post
Share on other sites

Same issue which ive never had before. Too bad nobody is online selling credits

 

Share this post


Link to post
Share on other sites

I'm guessing this is an extremely wide spread issue. I've purchased many credits in the past with no problem. But today I can't do it at all. I'm not a bitcoin user so that is out of the question. Very disappointing to see this is still an issue many hours later.

1 person likes this

Share this post


Link to post
Share on other sites

Still  Not Fixed, Might as well allow tabbed instances for free users that have purchased premium scripts cause this is bullshit

Share this post


Link to post
Share on other sites

Have this problem too.  No proxies or anything.  I cannot believe this hasn't been solved because the forums are FULL of these posts.  

Emailed them 24hours ago with no response, even their Facebook page is unresponsive.

Share this post


Link to post
Share on other sites

Which payment method are you all trying to use?

Share this post


Link to post
Share on other sites
12 minutes ago, fatsquasher said:

Stripe. 

Which country was the credit card issued in?

Share this post


Link to post
Share on other sites

New Zealand.

 

EDIT:

So I looked into Stripe's countries supported list and NZ isn't on there, but NZ is covered under the Australia region in the global image.

Is that just poor geography skills?

Edited by fatsquasher

Share this post


Link to post
Share on other sites

Payment failed: We cannot process this order because we suspect it may be fraudulent. same here bought 4 times before this with no problems at all... help plix

Share this post


Link to post
Share on other sites

I think I've identified and fixed the problem. Please try purchasing credits again.

1 person likes this

Share this post


Link to post
Share on other sites
9 hours ago, TRiLeZ said:

I think I've identified and fixed the problem. Please try purchasing credits again.

Problem fixed for me too :) Thanks man.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.