Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

TacoManStan

AIO TRiBot Support Thread

72 posts in this topic

divider.png

AIO TRiBot Support Thread

divider.png

If you found this thread helpful, please don't forget to like it!

 

Table of Contents

  • Useful Links
  • Frequently Asked Questions (FAQ)
    1. How Much is One Credit Worth?
    2. What is Looking Glass?
    3. Why Can't I See Any of My Local Scripts?
  • Help Guide
    1. A Solution to 99% of All Problems
    2. Opening the .tribot Folder
    3. TRiBot Won't Let Me Start My Script
    4. Upgrading From VIP to VIP-E
    5. How to Purchase TRiBot Credits
    6. Access to My Premium Script Has Disappeared!
    7. The Script I'm Trying to Use Isn't Working Properly
    8. Looking Glass Isn't Displaying Properly
    9. I Can't Open the TRiBot Loader
    10. Common TRiBot Error Messages
      1. java.text.ParseException: Unparseable Date
      2. Client-Side Error. Could not perform login. (Null Result)
      3. java.lang.NoClassDefFoundError
      4. java.lang.ClassCastException
  • Instructions for if You Still Can't Solve Your Problem

 

divider.png

 

Useful Links
Below you will find links to a number of existing guides that will help you with a variety of problems.
If you know of any guide that isn't included in the list below, please send me a PM or comment below and I will add it!

 
Fixing TRiBot Errors

Improving Your Botting Experience

Rules/Guidelines

  1. TRiBot Rules and Regulations
  2. TRiBot Forum Rules
  3. TRiBot FAQ
  4. Black Market Rules
  5. Middleman Overview & Guide

Threads by TRiLeZ (Owner and Founder of TRiBot)

  1. TRiLeZ's Scripting Tutorial
  2. Common TRiBot Loader Problems
  3. Ensuring TRiBot Uses the Right Java
  4. Guide to Implementing Anti-Ban Compliance (ABC) (Outdated)
  5. Guide to Implementing Anti Ban Compliance 2 (ABC2)
  6. Human Mouse Implementation
  7. Human Mouse Project [Data Collection]
  8. Reaction Timing and Other Playing Data [Data Collection]

Looking Glass

  1. Introducing Looking Glass
  2. Looking Glass Information
  3. Looking Glass Progress Reports

Other

  1. List of TRiBot Ranks and Titles
  2. How to Setup TRiBot With Eclipse
  3. API Documentation
  4. TRiBot Change Logs
  5. The Ban Discussion Thread

divider.png

 

Frequently Asked Questions (FAQ)

Below is a list of questions that are frequently asked on the forums.

 

Q: How Much is 1 Credit Worth?

One credit is worth $1 when purchased from TRiBot. However, there are various credit resellers that charge a slight premium for offering various benefits.

 

Some of the benefits of purchasing from a credit reseller (such as quickrsgp.com):

  1. You can purchase less than 5 credits.
  2. You can use additional methods of payment (including RSGP and PayPal).
  3. The credits typically arrive faster because you don't need to go through TRiBot's anti-fraud system.

Q: What is Looking Glass?

Looking glass is a TRiBot exclusive feature that allows you to use TRiBot through OSBuddy or a web browser. To use Looking Glass, you must have an active subscription to VIP Extended.

 

To learn more about looking glass, go to the top of this thread until you find the Useful Links section. One of the categories there will be Looking Glass. There you will find links to threads related to looking glass.

 

Q: Why Can't I See Any of My Local Scripts?

To use local scripts you must have an active VIP or VIP Extended. If you are looking for a guide on how to setup and write local scripts, refer to this guide.

 

divider.png

 

Help Guide

Below you will find answers to the majority of questions you might have about TRiBot.

If you have a question that isn't listed here, please let me know!

 

1. A Solution to 99% of All TRiBot Problems

Spoiler

If you are experiencing a problem with TRiBot, chances are one of the solutions listed below will fix it. Always try ALL of the below fixes before posting anywhere on the forums.

  • Disable Resizable Mode in your RuneScape settings.
  • Read through the "Common TRiBot Error Messages" section of this thread.
  • Delete your .tribot folder (backup everything first!).
  • Make sure you have the most recent Java version installed (Link).
  • Read the rest of this thread (especially the "Fixing TRiBot Errors" section above).
  • If RuneScape has just updated, you might need to just be patient! Check recent posts and see if you need to wait on a TRiBot update.

 

2. Opening the .tribot Folder

Spoiler

For a variety of reasons, you will oftentimes need to access your .tribot folder. To open the .tribot folder, follow these instructions:

  • Open a TRiBot client (if you don't already have one open).
  • Select the File menu.
  • Select the View Local Scripts Folder option.
  • Wait for the scripts folder to open. This will happen automatically.
  • From the scripts folder, go back a couple of times until you are in the .tribot folder.
  • If you are planning on deleting the folder, make sure you backup everything related to your scripts so you don't lose any settings!

yY4NopJ.gif

 

 

 

3. TRiBot Won't Let Me Start My Script

Spoiler

The two most common messages that you might be seeing are "The maximum amount of instances for this script has been surpassed" and "Since you are not VIP, you are only allowed to run on script at a time". There are other messages as well, but these are the two most common.
 
This is a server-side issue. When you run TRiBot, you are telling the TRiBot server that you are running a script, and which script you are running. This is so if you only paid to be able to run 1 instance of a script at a time, you can't cheat the system by using different computers.
 
Wait ~15 minutes for the server to refresh and to realize that you are no longer running any scripts. If you are VIP or VIP-E, you can also use the Instance Manager to manually close any instances without having to wait 15 minutes for the server to refresh.

 

4. Upgrading From VIP to VIP-E

Spoiler

Upgrading from VIP to VIP-E is very easy, and very possible. Note that the upgrade costs 2 credits, so make sure you have 2 credits before proceeding with the following steps.
 
The upgrade process is actually quite straight-forward.

  • Click Here to visit the VIP area.
  • Click the "Upgrade" button, which you will find towards the bottom of the page.

 

5. How to Purchase TRiBot Credits

Spoiler

You can purchase TRiBot credits directly from TRiBot by Clicking Here. If you don't want to use any of the payment options that are listed there, you can click "Unable to use any of these payment options?", which is located right below the "Purchase" button.
 
fG6Eam6.png
 
Alternatively, you can purchase TRiBot credits using practically any payment you would like (rsgp, Riot Points, PayPal, etc) by Clicking Here.


6. Access to My Premium Script has Disappeared!

Spoiler

This is a bug with the TRiBot repository having to do with when you purchase two different variations of the same script (for example, purchasing monthly then unlimited). Unfortunately, there is no way to automatically fix this problem. To fix it, contact @TRiLeZ via PM and ask him to correct the issue for you.

 

7. The Script I'm Trying to Use Isn't Working Properly

Spoiler

Scripts sometimes break. It happens. No one wants it to happen, especially the author of the script, so don't get upset and start yelling at them. When a script isn't working the way you think it should, follow these instructions in order.

1) Look Through the Script's Thread For Other People With the Same Issue
Lots of times there are other users with the same issue, and lots of times the scripter has posted a solution to your problem already. Look through the last 3-4 pages of the script's thread, and you might find the answer that you're looking for.
 
2) Check if the Scripter has a Bug Report System
Many premium scripters have built a system specifically for handling bug reports. Especially when a scripter has many scripts they are managing, it's difficult to check every single thread for bug reports. A bug report system allows the scripter to quickly see what bugs there are in all of their scripts at once, so they can prioritize what they need to work on.
 
Make both your life and the scripter's life easier; If the scripter has a bug report system, use it. If the system allows you to view other users' reports, do that first to see if anyone else has submitted the same report already, and check if the scripter has responded to the report. If it's just a report submission form (daxmagex uses this system, for example), just submit a report and wait patiently.
 
3) Send the Scripter a PM
A lot of the times the issue you are having is an error on your end (even though it might not seem like it), and posting negatively about the script on the script's thread isn't very fair to the author. Other potential customers will see your post, and then think the script is broken.
 
4) Contact the Scripter via Skype
If the scripter has a Skype username posted in their signature, contact them via Skype. Many scripters use Skype to provide the bulk of their customer service, and many (myself included) are much more likely to respond more quickly to a Skype message than to anything else.
 
However, don't pester them! There is nothing more aggravating than a customer who thinks that their problem is more important than the world. No scripter is going to intentionally ignore you, so don't get offended or upset if a scripter doesn't respond right away. It's happened to me many times where I get a message on Skype reporting an issue while I was in the middle of fixing it!
 
5) Post on the Script's Thread
Wait at least 2 days for a reply to your PM and Skype message. At this point, go to the scripter's TRiBot profile. If they are offline, posting on the script's thread isn't going to help them see your message any sooner. Just sit tight for another couple of days and wait for them to get online. If you really want to (and they are online), you can send them another message on Skype to check in.
 
If the scripter has been online recently but hasn't responded to your messages, then it might be time to post on the thread. Try messaging them on Skype one last time to see if you get a response, because your original message might have been drowned in more recent messages from other users.
 
Finally, the most important thing to remember is that premium scripters will never intentionally ignore you.

 

8. Looking Glass Isn't Working Properly

Spoiler

This one is luckily very easy to fix. All you need to do is disable Resizable Mode from inside RuneScape, and Looking Glass will function correctly.
 
If you are still experiencing problems, feel free to browse the Looking Glass Forums for a solution to your problem, as looking glass does occasionally break with RS updates. If you can't find an existing solution to your problem, you should make a new, detailed thread that illustrates your problem.

 

9. I Can't Open the TRiBot Loader

Spoiler

Having issues opening the TRiBot Loader? Getting messages that ask you what program you want to use to open it? The most common problem when the TRiBot Loader won't open is that you don't have Java installed. To install Java, follow these steps:

Note: If you are positive you have the correct version of Java installed, skip to step #6.

  1. Go to Google.com and search "Java 8 JDK Download" (without quotes).
  2. Click on the first link. It should look something like this:
    2IrC0mY.png

     
  3. When you click that link, you will be directed to the Java 8 JDK download page. You don't need the Demos and Samples, so simply click "Accept License Agreement", and then click the download link for your operating system.

    The page will look something like this:

    QeFkBue.png
     
  4. Click the Java 8 JDK installer that you just downloaded, and then follow the on-screen instructions.
  5. One you have Java installed, you should be able to use TRiBot by simply clicking the TRiBot loader. If so, you're done! If not, proceed to the next step.
  6. Java probably isn't setup as the default program to run .jar files, which is what the TRiBot loader is. @Crimson has written an excellent guide illustrating how to select the proper Java version here.

Important: "x86" means 32bit and "x64" means 64bit. I would recommend downloading the 32 bit version. (You only need 32bit Java to run TRiBot and/or RuneScape, and 32bit is required to use TRiBot's Looking Glass feature.) If you want to, there is no harm in downloading both versions.

 

10. Common TRiBot Error Messages

Spoiler

"java.text.ParseException: Unparseable date"

 

This is an error that prevents TRiBot from starting, and can be quite frustrating. The cause of this error is if the date recorded on your computer is not the accurate date. If you get this error, check your date and time to make sure it is accurate, then restart TRiBot.

 

For example, you might get the following error:


java.text.ParseException: Unparseable date: "Sat, 17-Jul-2083 14:59:39 GMT"

Notice how the date is set in July of 2083? That obviously isn't the correct date, which will cause TRiBot to throw this error.

 

 

 

"Client-Side Error. Could not perform login. (Null Result)."

 

This error typically means that your firewall is blocking TRiBot connections. Try disabling your firewall temporarily, and try starting TRiBot again. If the same error occurs, delete your .tribot folder (instructions above) and try starting TRiBot again.

 

 

 

"java.lang.NoClassDefFoundError"

 

This error is typically followed by a file path. For example, the error might look like this:


java.lang.NoClassDefFoundError: metapi/util/Timing$Condition

This usually means 1 of 2 things:

 

One Of Your Local Scripts is Invalid

The first issue might be that one of your local scripts is corrupted or invalid. To fix this, try opening your local scripts folder (File -> View Local Scripts Folder). If you see anything inside, delete it, and then try running TRiBot again.

 

If it is a local script that you are trying to run, this usually means that there is a problem with the local script itself. However, before looking through the code for errors (or asking the author to), try the next step.

 

Your .tribot Folder is Corrupted

Sometimes, especially after a TRiBot update, your .tribot folder might become corrupted. To fix this, simply delete your .tribot folder by following the instructions listed earlier in this post.

 

 

 

"java.lang.ClassCastException"

 

To solve this error, follow these instructions:

  1. Read over this thread and follow its instructions. After reading the thread, see if your issue is solved. 99% of the time, the solution listed in that thread will solve your problem. If not, proceed to step 2.
  2. Try deleting your entire .tribot folder by following the instructions listed earlier in this post. Try running TRiBot again. If this doesn't solve your issue, proceed to step 3.
  3. The first issue might be that one of your local scripts is corrupted or invalid. To fix this, try opening your local scripts folder (File -> View Local Scripts Folder). If you see anything inside, delete it, and then try running TRiBot again. If you still get the error, proceed to step 4.
  4. Uninstall and reinstall Java. Sometimes older versions of Java can cause this problem.

Note: In certain situations, this can be a script-related problem rather than a client-related problem. If the above steps don't fix the problem and/or if the problem only happens when running a specific script, contact the author of the script for assistance.

 

divider.png

 

Still Can't Solve Your Problem?

Fill out the form below, and someone will help you out as soon as possible.

 

Describe the problem:

Operating system (Mac OSX, Windows 7, etc):

Was it working at an earlier time? (Yes/No):

If yes:

Approximately when was it working last?:

What changed?:

What steps can be taken to replicate the issue?:

Screenshots (if relevant):

Bot/Client debug (if relevant):

What steps have been taken by you/others in an attempt to solve the problem?:

Additional information (Provide as much as you can):

Edited by TacoManStan
13 people like this

Share this post


Link to post
Share on other sites

What you did here probably took a very long time to gather and organize like you did, huge claps to you for committing to do this for the forum. I commend you lad. You'll be helping a very large amount of people with this compilation of resources all in one spot.

Share this post


Link to post
Share on other sites

Amazing for beginners! I have only one question. How do credits work? For example, i wanna buy a script that costs 6$, how many credits do i need to buy to match those 6$? Thanks. :)

1 person likes this

Share this post


Link to post
Share on other sites

Amazing for beginners! I have only one question. How do credits work? For example, i wanna buy a script that costs 6$, how many credits do i need to buy to match those 6$? Thanks. :)

 

1 credit = $1

Share this post


Link to post
Share on other sites

Describe the Problem: Cant download client? I guess..


Operating System (Mac OSX, Windows 7, etc): Windows 10 toshiba..


Was it Working at an Earlier Time (Yes/No): Just tried to download


Screenshots (If Relevant):


Bot/Client Debug (If Relevant):


Additional Information (Provide as Much as You Can): Requires me to "open with"...


Share this post


Link to post
Share on other sites

So I needed the JDK?

Most likely, yes. Try the steps listed and then report back to me (via PM preferably) if you are still experiencing issues.

Share this post


Link to post
Share on other sites

Describe the Problem: stuck at loading params


Operating System (Mac OSX, Windows 7, etc): windows 10


Was it Working at an Earlier Time? (Yes/No): Yes


If it Yes, Approximately When Was it Working Last?: 2 days ago


Screenshots (If Relevant):


Bot/Client Debug (If Relevant):


Additional Information (Provide as Much as You Can):


 


  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:90)
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1432)
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1430)
  • [18:08:41] at java.security.AccessController.doPrivileged(Native Method)
  • [18:08:41] at java.security.AccessController.doPrivilegedWithCombiner(AccessController.java:782)
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1429)
  • [18:08:41] at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
  • [18:08:41] at obf.XD.G(an:302)
  • [18:08:41] at obf.Nc.G(lc:3)
  • [18:08:41] at obf.Nc.G(lc:31)
  • [18:08:41] at obf.ah.G(al:115)
  • [18:08:41] at obf.vj.paintComponent(al:166)
  • [18:08:41] at javax.swing.JComponent.paint(JComponent.java:1056)
  • [18:08:41] at javax.swing.JComponent.paintToOffscreen(JComponent.java:5210)
  • [18:08:41] at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1579)
  • [18:08:41] at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1502)
  • [18:08:41] at javax.swing.RepaintManager.paint(RepaintManager.java:1272)
  • [18:08:41] at javax.swing.JComponent._paintImmediately(JComponent.java:5158)
  • [18:08:41] at javax.swing.JComponent.paintImmediately(JComponent.java:4969)
  • [18:08:41] at javax.swing.RepaintManager$4.run(RepaintManager.java:831)
  • [18:08:41] at javax.swing.RepaintManager$4.run(RepaintManager.java:814)
  • [18:08:41] at java.security.AccessController.doPrivileged(Native Method)
  • [18:08:41] at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
  • [18:08:41] at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:814)
  • [18:08:41] at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:789)
  • [18:08:41] at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:738)
  • [18:08:41] at javax.swing.RepaintManager.access$1200(RepaintManager.java:64)
  • [18:08:41] at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1732)
  • [18:08:41] at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
  • [18:08:41] at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
  • [18:08:41] at java.awt.EventQueue.access$500(EventQueue.java:97)
  • [18:08:41] at java.awt.EventQueue$3.run(EventQueue.java:709)
  • [18:08:41] at java.awt.EventQueue$3.run(EventQueue.java:703)
  • [18:08:41] at java.security.AccessController.doPrivileged(Native Method)
  • [18:08:41] at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
  • [18:08:41] at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
  • [18:08:41] at obf.Hh.dispatchEvent(rl:271)
  • [18:08:41] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
  • [18:08:41] at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
  • [18:08:41] at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
  • [18:08:41] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
  • [18:08:41] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
  • [18:08:41] at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
  • [18:08:41] java.io.IOException: Server returned HTTP response code: 503 for URL: https://static.tribot.org/images/probemas.gif
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1839)
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:90)
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1432)
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1430)
  • [18:08:41] at java.security.AccessController.doPrivileged(Native Method)
  • [18:08:41] at java.security.AccessController.doPrivilegedWithCombiner(AccessController.java:782)
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1429)
  • [18:08:41] at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
  • [18:08:41] at obf.XD.G(an:302)
  • [18:08:41] at obf.Nc.G(lc:3)
  • [18:08:41] at obf.Nc.G(lc:31)
  • [18:08:41] at obf.ah.G(al:115)
  • [18:08:41] at obf.vj.paintComponent(al:166)
  • [18:08:41] at javax.swing.JComponent.paint(JComponent.java:1056)
  • [18:08:41] at javax.swing.JComponent.paintToOffscreen(JComponent.java:5210)
  • [18:08:41] at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(RepaintManager.java:1579)
  • [18:08:41] at javax.swing.RepaintManager$PaintManager.paint(RepaintManager.java:1502)
  • [18:08:41] at javax.swing.RepaintManager.paint(RepaintManager.java:1272)
  • [18:08:41] at javax.swing.JComponent._paintImmediately(JComponent.java:5158)
  • [18:08:41] at javax.swing.JComponent.paintImmediately(JComponent.java:4969)
  • [18:08:41] at javax.swing.RepaintManager$4.run(RepaintManager.java:831)
  • [18:08:41] at javax.swing.RepaintManager$4.run(RepaintManager.java:814)
  • [18:08:41] at java.security.AccessController.doPrivileged(Native Method)
  • [18:08:41] at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
  • [18:08:41] at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:814)
  • [18:08:41] at javax.swing.RepaintManager.paintDirtyRegions(RepaintManager.java:789)
  • [18:08:41] at javax.swing.RepaintManager.prePaintDirtyRegions(RepaintManager.java:738)
  • [18:08:41] at javax.swing.RepaintManager.access$1200(RepaintManager.java:64)
  • [18:08:41] at javax.swing.RepaintManager$ProcessingRunnable.run(RepaintManager.java:1732)
  • [18:08:41] at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
  • [18:08:41] at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
  • [18:08:41] at java.awt.EventQueue.access$500(EventQueue.java:97)
  • [18:08:41] at java.awt.EventQueue$3.run(EventQueue.java:709)
  • [18:08:41] at java.awt.EventQueue$3.run(EventQueue.java:703)
  • [18:08:41] at java.security.AccessController.doPrivileged(Native Method)
  • [18:08:41] at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
  • [18:08:41] at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
  • [18:08:41] at obf.Hh.dispatchEvent(rl:271)
  • [18:08:41] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
  • [18:08:41] at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
  • [18:08:41] at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
  • [18:08:41] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
  • [18:08:41] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
  • [18:08:41] at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)
  • [18:08:41] java.io.IOException: Server returned HTTP response code: 503 for URL: https://static.tribot.org/images/probemas.gif
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1839)
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:90)
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1432)
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1430)
  • [18:08:41] at java.security.AccessController.doPrivileged(Native Method)
  • [18:08:41] at java.security.AccessController.doPrivilegedWithCombiner(AccessController.java:782)
  • [18:08:41] at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1429)
  • [18:08:41] at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254)
  • [18:08:41] at obf.XD.G(an:302)
  • [18:08:41] at obf.Nc.G(lc:3)
  • [18:08:41] at obf.Nc.G(lc:31)
  • [18:08:41] at obf.ah.G(al:115)
  • [18:08:41] at obf.vj.run(al:694)
  • [18:08:41] at java.lang.Thread.run(Thread.java:745) 

Share this post


Link to post
Share on other sites

Helped a few people out recently. I've noticed a lot of issues are disappearing when users make sure to uninstall all previous Java versions, and instead install JDK 8u60 32bit.. Link

 

@TacoManStan

Edited by zawmbee

Share this post


Link to post
Share on other sites

Hi, I purchased the mutes rock crabs and it works fine, however I cant seem to get it to pick up my arrows.  it asks for the arrow id, then whenever I type it in, for example if I type in steel arrow, it doesn't detect the type of arrow.  I'm not sure if its me doing something wrong but it would be great if I could have some help.  thanks!

Share this post


Link to post
Share on other sites

@gladdy

Hi, I purchased the mutes rock crabs and it works fine, however I cant seem to get it to pick up my arrows.  it asks for the arrow id, then whenever I type it in, for example if I type in steel arrow, it doesn't detect the type of arrow.  I'm not sure if its me doing something wrong but it would be great if I could have some help.  thanks!

Please refer to item #7 in the table of contents, The Script I'm Using Isn't Working Properly. There you will find additional instructions on the best way to get assistance on script-related questions and problems.

Share this post


Link to post
Share on other sites

Posting on behalf of @trip (please fill in the rest of the bug report format)

Describe the problem: java.io.IOException: Access is denied

Operating system (Mac OSX, Windows 7, etc): Windows 7

Was it working at an earlier time? (Yes/No):

If yes:

Approximately when was it working last?:

What changed?:

What steps can be taken to replicate the issue?:

Screenshots (if relevant):

debug2.jpg

Bot/Client debug (if relevant):

What steps have been taken by you/others in an attempt to solve the problem?:

Things we've tried:

 

Try simply going to File > Delete Cached Clients

 

Open a new client tab (non-LG) and let it update and load then close it

Open RuneScape (reload page if open)

Open new LG tab

 

 

If that doesn't work, we're going nuclear: Delete everything and start over. Delete .tribot entirely (backup local scripts), delete and redownload the TRiBot_Loader.jar, uninstall and reinstall JDK 8u66 (Windows x86) - this version works for me at least. Then try opening LG with that version of JDK.

I'm not familiar with the error but its obviously a permissions issue. I have searched the archive and it has presented since 2013 with no obvious solution. Make sure you're giving permission to all of the java.policy files in your Program Files (86) folder just in case. JRE and JDK specifically. The easiest way to do this is open Program Files (86) and locate the Java folder, then search for java.policy in the top right hand corner and just give mass rights to SYSTEM and USERS (first check box on all of them)

 

This is an old thread that might help if the above does not.

 

If neither work, we'll make a thread.

Additional information (Provide as much as you can):

Share this post


Link to post
Share on other sites

Describe the problem: java.io.IOException: Access is denied
Operating system (Mac OSX, Windows 7, etc): Windows 7
Was it working at an earlier time? (Yes/No): yes
If yes:
Approximately when was it working last?: 9 days ago
What changed?: client updated
What steps can be taken to replicate the issue?: 
Screenshots (if relevant):

debug2.jpg

Bot/Client debug (if relevant):

What steps have been taken by you/others in an attempt to solve the problem?: deleting everything. reinstalling java, deleting hook file. clearing cached client, reseting java privileges to full. editing environment variables, made sure firewall wasnt the problem.
 

Edited by trip

Share this post


Link to post
Share on other sites

Describe the problem: java.io.IOException: Access is denied

Operating system (Mac OSX, Windows 7, etc): Windows 7

Was it working at an earlier time? (Yes/No): yes

If yes:

Approximately when was it working last?: 9 days ago

What changed?: client updated

What steps can be taken to replicate the issue?: 

Screenshots (if relevant):

debug2.jpg

Bot/Client debug (if relevant):

What steps have been taken by you/others in an attempt to solve the problem?: deleting everything. reinstalling java, deleting hook file. clearing cached client, reseting java privileges to full. editing environment variables, made sure firewall wasnt the problem.

@Crimson help sensei?

Share this post


Link to post
Share on other sites

@trip

Please try deleting your .tribot folder, then run the TRiBot_Loader.jar again.

 

CAUTION

All of your saved settings, accounts, proxies, etc will be removed by deleting the .tribot folder.

I highly recommend making a backup in case this doesn't resolve your issue.

 

Because you're on windows you can press the WINKEY + R to open the run command, and then paste in:

%appdata%\.tribot

 

Ensure tribot is closed

Delete everything inside

Delete the .tribot folder as well

Re-run TRiBot_Loader.jar

 

@Dukat

If this fails, we can try to help him change permissions of his .tribot folder, and see if that allows him access again.

1 person likes this

Share this post


Link to post
Share on other sites

@trip

Please try deleting your .tribot folder, then run the TRiBot_Loader.jar again.

 

CAUTION

All of your saved settings, accounts, proxies, etc will be removed by deleting the .tribot folder.

I highly recommend making a backup in case this doesn't resolve your issue.

 

Because you're on windows you can press the WINKEY + R to open the run command, and then paste in:

%appdata%\.tribot

 

Ensure tribot is closed

Delete everything inside

Delete the .tribot folder as well

Re-run TRiBot_Loader.jar

 

@Dukat

If this fails, we can try to help him change permissions of his .tribot folder, and see if that allows him access again.

 

@Crimson I'm all out of ideas, we did a lot of troubleshooting listed in my post before his post in this thread. By changing his .tribot folder permissions, do you mean just so that he has full control of the folder or something different? I'm going to suggest that now.

 

I got looking glass to work 1 time last night than i had to restart my computer after restart doesn't work again and only thing i did was delete tribot completely than i started tribot.jar reinstalled everything ran new client first closed out open osbuddy+ looking glass and it worked. but now when i do that same thing it doesn't work. lol so much work just to make this thing work.

Share this post


Link to post
Share on other sites

@Dukat @trip

 

Right click on your .tribot folder, and select properties.

Make sure the folder is NOT selected as "Read-only"

Navigate to the "Security" tab

For each of the Group or user names listed, make sure each group/user has full permissions to the file.

Click on the "Advanced" button, and make sure each Principal has Full control set under the Access tab.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.