Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

TacoManStan

[TUTORIAL] When TRiBot Doesn't Work Correctly

31 posts in this topic

Hello everyone! As you might have guessed, TRiLeZ is incredibly busy working on a lot of updates. Unfortunately, sometimes these updates cause a particular file, "hooks.dat", to get corrupted.
 
This corrupted hooks.dat file can cause your bot to get stuck, appear to endlessly run north, or sometimes even crash scripts completely (the following error might also look familiar to you).

 java.lang.ClassCastException: java.lang.Integer cannot be cast to [I 

The below instructions will help you reset your hooks.dat file and get your scripts working properly again!

 


 

Follow these instructions step by step, and it should resolve your issue.

  • Open TRiBot's Settings folder. You can do this by following these steps:
    • Open a TRiBot client (if you don't already have one open).
    • Select the File menu.
    • Select the View Local Scripts Folder option.
    • Wait for the scripts folder to open. This will happen automatically.
    • From the scripts folder, go back a couple of times until you are in the .tribot folder.
    • From the .tribot folder, open the Settings folder.
    • Leave the Settings folder open, and go to step #2.
  • Close all TRiBot clients.
  • Locate a file called "hooks.dat". This will be inside of the Settings folder that you opened in step #1.
  • Delete the hooks.dat file.
  • Restart your client.
  • Start botting again!

If this doesn't fix your issue, you can try sending the author of the script a PM to check if your problem is script related. Make sure you try the above steps first though!

 


 

Video Guide:

https://imgrush.com/2MlutdKLWvVE.mp4

Edited by TacoManStan
10 people like this

Share this post


Link to post
Share on other sites

Someone should backup their hooks.dat before doing this and upload it so we can send it to trilez to see what's going wrong.

Share this post


Link to post
Share on other sites
 

@TacoManStan

 

Did this but it just wont load any scripts. I can press the "Start Script" at the top of the client but nothing pops up

Wait a bit and then try again. That just means that TRiBot couldn't connect to the server. If it continues to happen, restart the client. Sometimes clients themselves become corrupt and the only thing you can do is restart.

Share this post


Link to post
Share on other sites

Thanks so much! I almost made a post trying to find out how to get the bot working again and this did the trick flawlessly. I appreciate it greatly! :D

Share this post


Link to post
Share on other sites

Thanks! It worked! HOWEVER! I'm unfortunately experiencing high CPU usage. I'm not sure why, Yesterday everything was working smoothly. Anyone have a solution to this problem. 

 

Thank you peace n love

Share this post


Link to post
Share on other sites

Could we get one for mac, because clicking view local settings folder wont open anything on mac client and i cant find the folder

Share this post


Link to post
Share on other sites

i dont see a hooks.dat

You might not have gotten far enough for TRiBot to create the hooks.dat file. Try looking here for any other answers. Also make sure your firewall isn't blocking the TRiBot connection.

Share this post


Link to post
Share on other sites

.lang.classcastexception ljava.lang.object cannot be cast to   

 

ive done what u have told me to do but i cant open view local script folder???

any help please it tells me location but when i look for it its nowhere to be seen""

ive even tried enabiling hidden files but it just not there??  

 

im running mac  

any help please

Edited by hellokitty123

Share this post


Link to post
Share on other sites

like come on, half these scripts are broken trying to toggle quick prayers...really? am i that much of a hardcore botter i am worrying about small percentages? answer :no

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.