Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Compatible JRE with x64bit AMD processors

5 posts in this topic

Hey guys so I used to script in rsbot but I have decided to switch over because I think this is a superior program.  Anyway after I set up my first program and configured the build paths I would get this error when I tried to run.


Loading TOGL
Exception in thread "AWT-EventQueue-1" java.lang.UnsatisfiedLinkError: C:\Users\1\AppData\Local\Temp\togl_31c151da5.dll: Can't load IA 32-bit .dll on a AMD 64-bit platform
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.load0(Unknown Source)
at java.lang.System.load(Unknown Source)
at obf.FL.run(ju:544)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at obf.Hi.dispatchEvent(zh:520)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
So what I thought the answer would be related to my JRE version.
Java 1.8.0_31 amd64 64 (C:\Program Files\Java\jre1.8.0_31)
I grabbed a fresh installation of 8u31 x64 from the archived downloads from http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html and installed only after I removed my previous version.  The Java variables are all correct and point to the fresh installation.  Should I download x84? I'm pretty sure it would not help/work.
I am trying to use the 07 bot, I thought there may be some arguments I could start the bot with to decide allocated memory etc
Edited by jjjkkk

Share this post

Link to post
Share on other sites

To use the 07 bot, make sure to tick this:




Yeah I have my cleint set the same way, made sure to start it again to save the config but still I run into the same problem.  Should I try 8u40?

Share this post

Link to post
Share on other sites

I think my problem is it is trying to run in 32 bit rather than 64 is there any way to force it into 64 bit? This is extremely odd though because 32 restricted programs should be able to run on 64 bit architecture.  Very odd indeed.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.