Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Buy OSRS Gold

Sell OSRS Gold
Sign in to follow this  
Mjkm41

Tribot stuck on "getting latest client revision "

Recommended Posts

Array

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By spac3jesus
      It will not let me start a new script it says I already have one running when I do not, I deleted the client and reinstalled and it still says this …. please help!
    • By drunksigma
      When i try to world hop the bot tries to do it but it repeats world selection.
      I'm using it on OSBuddy btw.
      i use this code.
      if(Game.getGameState() == 30) WorldHopper.changeWorld(WorldHopper.getRandomWorld(members, deadman));  
    • By joeltlou2
      I tried running a script and my client froze, so restarted the laptop. 
      Now the client is saying I cannot be running more than 1 script without being VIP, though no process is stuck in the background (obvious as I did a hard reboot), so think something might be stuck somewhere else? But not sure.

      Thanks
       
    • By Aleks7000
      Hey guys, i tried to remove java, and reinstall it a few times, and the same about tribot, but it doesnt seem to get the problem fixed. i dont know if im doing this right but it used to work. Im downloading the jar file, putting it on desktop, and opening with java. it used to work like this, but now it suddenly doesnt. anybody got a fix for this or any directions? please? 
    • By nardo4game
      Hello,
       
      I tried botting for the first time since like a month ago. I re-downloaded everything and tried to open client but nothing happens.
       
      please help
    • By nardo4game
      Hello,
       
      I thought i had fixed the problem but the problem persist.
      I can spam click and the script will show up but then it will crash after a few minutes. 
       
      I have deleted OSRS and RS3 clients,
      Deleted my .tribot folder and installed it again.
       
      I am not sure as to what to do now.. i havent been able to bot properly for the past 3-4 days.
       
      PLEASE HELP!!!
    • By Rushin
      Need help with a moderator, or anyone really. Had a thunderstorm and computer crashed. I checked the instance manager however it said no active scripts were in play. I keep getting the  error of it saying to close my other instances before starting to run another script. Please help I'm not really sure how to go about this. I'm only a casual botter and I haven't been able to do it for 5 days straight now. Thank you 
    • By Snowbear
      I successfully followed tutorials to the point of getting a single .class file to cause a script to show up in my Tribot client.
       
      Using a single class file = messy code. I am trying to improve organization, and create additional classes under a single "Script project", and utilize imports and what not to have them all work together. My issue is that as soon as I add another class and attempt to have my @scriptmanifest containing class import it, even though I changed NOTHING about the configuration, location, etc. of the class that successfully caused a script to show up in my Tribot client, as soon as I attempt to make use of another class, Tribot no longer shows any local scripts.
       
      If I delete the second class I made (Main) the original class (Test) once again successfully causes the Willow Chopper to appear in my Tribot client.
       
      Does this make any sense at all? I am quite confused. Below are several photos explaining my situation. I would also be overjoyed if someone would like to Skype and assist me (my skype is "live:snowbear.business"
       
      Thank you!
       
      This is what my Eclipse looks like:

       
      This is the content of the class I'm trying to make use of via importing it (Main):

       
      Building Eclipse as shown above results in
       C:\Users\<USER>\AppData\Roaming\.tribot\bin\scripts
      to contain:
       
      Folder: "snowCooker"
      inside of that there is "Main.class"
       
      My  C:\Users\<USER>\AppData\Roaming\.tribot\src\ folder contains:

       
      inside of scripts:

       
      Note: Please forgive the names of my classes and the awful code, just trying to work on organization and actually get a script to show up in my Tribot client. Hopefully my class names don't cause any confusion.
       
      "Test" is actually the main class - what contains the script manifest, what successfully caused the script to show up in the client before I added the second class, etc
       
      "Main" is a class I'm trying to import in Test, so that I can make use of a simple test method (calc). 
       
      My script does not actually do anything, I'm just trying to get it to show up in my Tribot client.
       
       
  • Our picks

    • Over the past few months, I’ve been working diligently on a new project - TRiBot X. Everything has been written from the ground up, with all of the best practices of software engineering. Every aspect of TRiBot has been re-imagined to support three main goals: flexibility, useability, and reliability.
        • Like
      • 50 replies
    • Come give us feedback on the next version of TRiBot!
        • Thanks
        • Like
      • 86 replies
    • TRiBot is looking to improve a lot of its customer relationship management, customer on boarding process, customer experience, design elements, community engagement and pretty much everything else you can imagine when it comes to marketing.

      Our goal: To ensure that the marketing done TRULY reflects the experience and does not shine an inaccurate light on what TRiBot is lacking in.

      So I ask, what do you love about TRiBot and what do you hate about TRiBot? What does O S Bot, Rune M8, PowR Bot and Dre amBot do better? (yes I purposely didn't spell it right 😂).

      Love, 

      RileyZ
        • Like
      • 25 replies
    • Over the last three weeks, I've been working on upgrading our server infrastructure. It's finally ready and is now live!

      Why?

      Increased reliability - less server errors


      Increased availability - less downtime


      Increased security - keeping us and you secure


      Increased capacity - ability to serve you better


      Increased speed - less waiting for things to load


      Faster development - server and service updates will come faster


      What are the changes?

      Move from a single AWS EC2 instance to AWS ECS (Elastic Container Service)


      Distributed computing


      Load balancing


      Git management of server files and filesystem


      Redis caching


      How?

      AWS ECS (with 10 EC2 instances)


      AWS ElastiCache (Redis)


      AWS Load Balancing


      AWS EFS (Elastic file system)


      Please bare with us as I continue to tune the server for maximum performance. Slow loading speeds may occur temporarily. I thank everyone for their patience.

      Please post on this thread if you experience any issues other than slow loading times.
        • Like
      • 51 replies
    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 90 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...