Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

Hey Erick, here's the proper bug report for looking glass.

 

Verison: Verison: 3.15 You can now adjust the item list via arrow keys
Script issue: very slow in Looking Glass
Settings picture: http://i.imgur.com/9lq4ZtA.png
Script status when issue is occuring?: After world hopping, finding and trading with NPC
Script stack trace: http://pastebin.com/g32KNXZG
Client debug: http://pastebin.com/93kwH0SV
Bot debug: http://pastebin.com/wHCyqduN

 

edit: Do you need the JMX stack trace as well?

 

VIDEO:

 

This is a typical loop for me after world hopping. After logging into a world, it takes anywhere between 10 and 30 seconds to open the shop. Once it manages to open the shop, it works pretty much fine, just a little slower than usual. I've tested on multiple computers and get the same result each time.

 

In this example, it also accidentally left-clicked Jiminua instead of right-clicking.

 

Interestingly, the "Status" on the paint shows that it still believes it is world hopping several seconds after logging into the world.

 


  Edited by fatdoobie2

Share this post


Link to post
Share on other sites

Hey Erick, here's the proper bug report for looking glass.

 

Verison: Verison: 3.15 You can now adjust the item list via arrow keys

Script issue: very slow in Looking Glass

Settings picture: http://i.imgur.com/9lq4ZtA.png

Script status when issue is occuring?: After world hopping, finding and trading with NPC

Script stack trace: http://pastebin.com/g32KNXZG

Client debug: http://pastebin.com/93kwH0SV

Bot debug: http://pastebin.com/wHCyqduN

 

edit: Do you need the JMX stack trace as well?

 

VIDEO:

 

This is a typical loop for me after world hopping. After logging into a world, it takes anywhere between 10 and 30 seconds to open the shop. Once it manages to open the shop, it works pretty much fine, just a little slower than usual. I've tested on multiple computers and get the same result each time.

 

In this example, it also accidentally left-clicked Jiminua instead of right-clicking.

 

Interestingly, the "Status" on the paint shows that it still believes it is world hopping several seconds after logging into the world.

 

 

I need more than one script stack trace. 3-5 in a course of 10 seconds DURING the issue works.

Share this post


Link to post
Share on other sites

I need more than one script stack trace. 3-5 in a course of 10 seconds DURING the issue works.

 

ok didn't see that part in the form sorry

 

Although I checked stack trace several times throughout the process, it was exactly the same each time. From the moment I log in, stack trace is the same every time I checked til it logged out and completed the loop.

Edited by fatdoobie2

Share this post


Link to post
Share on other sites

ok didn't see that part in the form sorry

 

Although I checked stack trace several times throughout the process, it was exactly the same each time. From the moment I log in, stack trace is the same every time I checked til it logged out and completed the loop.

Could you do that in anyway, just incase you're not spotting a difference? Just want to make sure.

Share this post


Link to post
Share on other sites

Could you do that in anyway, just incase you're not spotting a difference? Just want to make sure.

 

Sure no problem. Here's some traces from ExShopper Script Thread in JMX, these are the general traces I see for the 3 different parts (world hopping, opening shop, trading items)

 

http://pastebin.com/vW6E4GkP

 

Here's some more detailed traces from the main problem area, after logging in

 

http://pastebin.com/wwfAdQ7x

Edited by fatdoobie2

Share this post


Link to post
Share on other sites

I'm getting this:

Could this be due to the timing of log in?

 

 

[10:44:56] detected a bug [false too many incorrect attempts message] with jagex login system, attempting to fix manually by clicking 

 

 

 

EDIT: This was due to spam buying an item that had only 1 in stock. Fixed

Edited by bloods

Share this post


Link to post
Share on other sites

I'm getting this:

Could this be due to the timing of log in?

 

 

[10:44:56] detected a bug [false too many incorrect attempts message] with jagex login system, attempting to fix manually by clicking 

 

 

 

EDIT: This was due to spam buying an item that had only 1 in stock. Fixed

Nothing new, runescape limits the amount of times you can log in per xx seconds or something. This is to prevent ddosing or something. I believe the poll for integerated world hopping will fix this (vote for it!), a jmod said so himself.

Share this post


Link to post
Share on other sites

Nothing new, runescape limits the amount of times you can log in per xx seconds or something. This is to prevent ddosing or something. I believe the poll for integerated world hopping will fix this (vote for it!), a jmod said so himself.

That's pretty a dope poll, I hope it passes. I remember when this problem didn't happen.

  • Like 1

Share this post


Link to post
Share on other sites

Verison Number (DO NOT TYPE LATEST): 3.15
Script issue:idles/doesn't sell to the shop

Settings picture:can't get picture, says hopping to world _, and after it says we are sleeping for: _
Script status when issue is occuring?: Sell _ (_ = the first item I placed on sell on my list in the gui)
Script stack trace? (View -> Print script stack trace, please do it atleast 5 times and only when it's occuring. Paste it in http://pastebin.com):
Client debug (Paste it in http://pastebin.com): http://pastebin.com/906cwg6P
Additional information (Please provide additional information, the more information you provide the easier I can help you with your issue):

Usually happens randomly after around an hour of starting the script, hops to a world and then when it trades the store it doesn't do anything

Share this post


Link to post
Share on other sites

Verison Number (DO NOT TYPE LATEST): 3.15

Script issue:idles/doesn't sell to the shop

Settings picture:can't get picture, says hopping to world _, and after it says we are sleeping for: _

Script status when issue is occuring?: Sell _ (_ = the first item I placed on sell on my list in the gui)

Script stack trace? (View -> Print script stack trace, please do it atleast 5 times and only when it's occuring. Paste it in http://pastebin.com):

Client debug (Paste it in http://pastebin.com): http://pastebin.com/906cwg6P

Additional information (Please provide additional information, the more information you provide the easier I can help you with your issue):

Usually happens randomly after around an hour of starting the script, hops to a world and then when it trades the store it doesn't do anything

Please fill out the forms approriately. I need the script stack trace when the issue is occuring (atleast 5 times printed), and a full client debug / bot debug. As well, your settings picture is your GUI settings. If you want to keep the items you are selling private, send the new submitted form to my PM, thanks!

Share this post


Link to post
Share on other sites

I've had this purchased for over a month, I log on to Tribot today and the script is no longer in my script list.  It also says on the repository I have not purchased it. Could you help me out with this?

 

Edit: Sorry I'm a dumbass, just realized it's a monthly purchase

Edited by srig

Share this post


Link to post
Share on other sites

Please fill out the forms approriately. I need the script stack trace when the issue is occuring (atleast 5 times printed), and a full client debug / bot debug. As well, your settings picture is your GUI settings. If you want to keep the items you are selling private, send the new submitted form to my PM, thanks!

Filled it out and sent you the bug report through the pm, thanks

Share this post


Link to post
Share on other sites

dMCK8XS.png

"You currently have an unlimited auth count". All you need to do is click "activate script" found below (if it's already activated, it should say deactivate script), then go to the script selector on tribot client, moneymaking and find "ExShopper". If it's still not showing up, make sure file->settings, "load local scripts only" isn't checked. If it still isn't working, it's not an issue I can help resolve, sorry.

Share this post


Link to post
Share on other sites

"You currently have an unlimited auth count". All you need to do is click "activate script" found below (if it's already activated, it should say deactivate script), then go to the script selector on tribot client, moneymaking and find "ExShopper". If it's still not showing up, make sure file->settings, "load local scripts only" isn't checked. If it still isn't working, it's not an issue I can help resolve, sorry.

Hi again, thanks for fast answer. I can see the deactive button and I have been using the script for 27 days, and it is still working. I am writing because I am new here on tribot and I don´t know how to extend a current script (get more days) :P Do i have to wait until I have 0 days left and then buy 30 days one more time?

  • Like 1

Share this post


Link to post
Share on other sites

Hi again, thanks for fast answer. I can see the deactive button and I have been using the script for 27 days, and it is still working. I am writing because I am new here on tribot and I don´t know how to extend a current script (get more days) :P Do i have to wait until I have 0 days left and then buy 30 days one more time?

Oh sorry, I somehow misunderstood what you were trying to say. You would have to wait until the script runs out first then you will be able to purchase another month. I'll suggest to the TRiBot team for buying more months though!

Edited by erickho123

Share this post


Link to post
Share on other sites

Oh sorry, I somehow misunderstood what you were trying to say. You would have to wait until the script runs out first then you will be able to purchase another month. I'll suggest to the TRiBot team for buying more months though!

I could buy more days on my VIP, thats why I was wonderin :), yeah not a bad idéa

Share this post


Link to post
Share on other sites

Will we still be able to use the normal log out and hop method or will that be broken until the world hopper release?

Login#logout might break (client issue) upon update. If it doesn't, then the script should still be working, then again jagex may change more stuff. We will see on the update.

Edited by erickho123
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Similar Content

  • Our picks

    • This release will:

      Fix prayers and world hopper API (Thanks @JoeDezzy1 and @erickho123)


      Improve banking API (Thanks @Encoded)


      Adds methods for returning and using Java Lists, rather than arrays


      Slightly randomizes some hardcoded behaviour


      Removes sleeps from waitConditions; the efficiency saving potential is negligible in these use-cases, therefore cleaner code is preferable


      Other back-end improvements





      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Sad
        • Haha
        • Thanks
        • Like
      • 64 replies
    • This release will:

      Add new internal framework for capturing exceptions


      Fix issue with not selecting the last column in world hopper (Thanks @Todd)


      Add a message about pin usage in Banking#openBank (Thanks @Todd)


      Disable the firewall by default (Thanks @Todd)


      Fix handling of the welcome screen after login (Thanks @Encoded)


      Fix wrong amount bank withdrawal (Thanks @Encoded)


      Fix Screen#isInViewport


      Fix Game#isInViewport (Thanks @Encoded)


      Call onBreakEnd for ListenerManager Breaking Listeners (Thanks @Encoded)


      Fix Prayer#getPrayerPoints NumberFormatException (Thanks @JoeDezzy1)



      Note: If you are using LG, please restart both the RS client and TRiBot.
        • Thanks
        • Like
      • 28 replies
    • This release will:

      Fix LG for both OSBuddy and RuneLite


      Fix issue where the resizable client isn't able to be made smaller (Thanks @JoeDezzy1)


      Fix detection of the logout game tab when resizable mode and side panels are enabled (Thanks @JoeDezzy1)


      Add initial support for Sentry to allow us to identify and easily debug exceptions happening with all TRiBot users


      Add methods to determine if the bank is actually loaded, and not just the overarching interface (Thanks @wastedbro)



      Upcoming updates:

      Improved CLI support


      Full Sentry support


      Much more
        • Like
      • 64 replies
    • This release will:

      Fix NPE in Camera API (Thanks @wastedbro)


      Update deposit box interface ids (Thanks @Encoded)


      Add various bank methods (Thanks @wastedbro)


      Banking#getWithdrawXQuantity


      Banking#getDefaultWithdrawQuantity


      Banking#arePlaceholdersOn




      Fix resizeable minimap bug (Thanks @wastedbro)


      Remove Java 8 requirement


      Please note: TRiBot is not yet fully compatible with Java 10+




      Fix the break handler issues by ensuring the break handler thread never gets paused


      Fix broken settings hooks



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 68 replies
    • This release will:

      Add support for using custom F key bindings to switch between game tabs (Thanks @erickho123)


      Fix tab opening for "Skills" and "Kourend Tasks" (Thanks @erickho123)



      Note: If you are using LG, please restart both the RS client and TRiBot
        • Like
      • 34 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...