[Mac] How To: Resolve Most Problems With TRiBot [Pics]

chrismoon
By chrismoon in Tutorials,
TRiBot not showing up after logging in? Receiving a "Java null" error? Scripts not loading? Any other issue using TRiBot on your mac?   Fix #1 First thing you need to do is verify the latest version of Java is running on your Mac (available for download here).
To see what version you're currently running, Click on the  at the top left of your screen Click "System Preferences..." Click on the "Java" option at the bottom and the Java Control Panel should open in a separate window In the General tab, click on the "About..." option. Verify this is the most recent version available from the download link up top. Fix #2 Next, you need to verify you have the correct .jdk, or Java Development Kit. Before starting your TRiBot client, you tell it which jdk to reference, as seen here
 
Many, if not most, issues with the client on Macs are due to the jdk being outdated. To download the latest, go here, accept the License Agreement, and download the OS X version.
 
The file downloaded will be a .dmg file. Open it up and you'll be able to install it (only with Administrator privileges, of course).
 
To see what versions you have installed on your Mac, Click on the Spotlight search option in the top-right (or just type cmd+spacebar) and search for "Finder." Once in the Finder window, click on the "Go" option in the very top bar. Click "Go To Folder..." and type this in, then click Go: /Library/Java/JavaVirtualMachines You should see the available options to choose when starting your TRiBot client. Verify the latest jdk is present, should see something like this: Most common issues with loading the client should be resolved if you've verified both are up to date. 
 
If you're curious, here's a post I found that helps explain the difference between the two and why these steps are necessary:

 
Fix #3 
If none of the above work, another thing you can try that has been found to solve some issues is deleting your tribot folder, tribot loader, restarting, and redownloading:

If you've used TRiBot on your mac, your tribot folder will be here:
 
1. Click on Finder

 
2. In the menu bar, click "Go," then choose the "Go To Folder..." option

 
3. Paste this into the box changing "YOUR MAC USERNAME" to whatever is in your upper right corner. USE LOWERCASE LETTERS. /Users/"YOUR MAC USERNAME"/Library/Application Support/
 
4. Delete the tribot folder, then delete your TRiBot_Loader.jar file used to start TRiBot.

5. Restart your mac and redownload the file from TRiBot.org. THERE ARE 2 DIFFERENT "APPLICATION SUPPORT" FOLDERS. IF YOU SEE FOLDERS LIKE "ApplePushService," "CrashReporter," "com.apple.TCC," YOU'RE IN THE WRONG APPLICATION SUPPORT FOLDER. If you are still having any issues, PM me, post here, or add me on Skype and I and/or someone else will do our best to help get your client started.
 

Note: If you ask for help, I will require you to post a screenshot of your java and jdk version, proving you've already tried what's been recommended so far.
  • 30 replies