Jump to content
TRiLeZ

TRiBot Release 9.211_0

Recommended Posts

[17:24:35] Starting TRiBot Loader.

[17:24:35] TRiBot Loader Release 2.02 is up-to-date.
[17:24:35] Attempting to launch TRiBot.
[17:24:35] Java Exe: /Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk/Contents/Home/jre/bin/java ([7, 0, 51])
[17:24:36] TRiBot SID: '1854b-DMyTCr3J1HZqMnaUsQ 09cSmH4tfPBlAPQSHnacywSnL1QzOpd'.
[17:24:36] Click this text box to copy the SID to your clipboard.
[17:24:36] TRiBot Loader has finished it's process. TRiBot will now start.

[17:24:36] CONSOLE STARTED
[17:24:36] TRiBot Release 9.211_1
[17:24:36] Initial Settings Loaded
[17:24:36] Using SID: 1854b-DMyTCr3J1HZqMnaUsQ09cSmH4tfPBlAPQSHnacywSnL1QzOpd
[17:24:36] Exception in thread "TSV" java.lang.UnsatisfiedLinkError: java.lang.Class.getCheckMemberAccessMethod(Ljava/lang/Class;)Ljava/lang/reflect/Method;
[17:24:36] at java.lang.Class.getCheckMemberAccessMethod(Native Method)
[17:24:36] at java.lang.Class.access$0(Class.java:2359)
[17:24:36] at java.lang.Class$SecurityManagerHelper.(Class.java:2320)
[17:24:36] at java.lang.Class.isCheckMemberAccessOverridden(Class.java:2340)
[17:24:36] at java.lang.Class.checkMemberAccess(Class.java:2377)
[17:24:36] at java.lang.Class.newInstance(Class.java:345)
[17:24:36] at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:221)
[17:24:36] at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:206)
[17:24:36] at java.security.AccessController.doPrivileged(Native Method)
[17:24:36] at sun.security.jca.ProviderConfig.doLoadProvider(ProviderConfig.java:206)
[17:24:36] at sun.security.jca.ProviderConfig.getProvider(ProviderConfig.java:187)
[17:24:36] at sun.security.jca.ProviderList.getProvider(ProviderList.java:232)
[17:24:36] at sun.security.jca.ProviderList.getService(ProviderList.java:330)
[17:24:36] at sun.security.jca.GetInstance.getInstance(GetInstance.java:157)
[17:24:36] at javax.net.ssl.SSLContext.getInstance(SSLContext.java:156)
[17:24:36] at obf.mj.(gl:771)
[17:24:36] at obf.iJ.run(sj:853)
[17:24:36] at java.lang.Thread.run(Thread.java:744)
[17:24:36] Exception in thread "main" java.lang.UnsatisfiedLinkError: java.lang.Class.getCheckMemberAccessMethod(Ljava/lang/Class;)Ljava/lang/reflect/Method;
[17:24:36] at java.lang.Class.getCheckMemberAccessMethod(Native Method)
[17:24:36] at java.lang.Class.access$0(Class.java:2359)
[17:24:36] at java.lang.Class$SecurityManagerHelper.(Class.java:2320)
[17:24:36] at java.lang.Class.isCheckMemberAccessOverridden(Class.java:2340)
[17:24:36] at java.lang.Class.checkMemberAccess(Class.java:2377)
[17:24:36] at java.lang.Class.newInstance(Class.java:345)
[17:24:36] at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:221)
[17:24:36] at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:206)
[17:24:36] at java.security.AccessController.doPrivileged(Native Method)
[17:24:36] at sun.security.jca.ProviderConfig.doLoadProvider(ProviderConfig.java:206)
[17:24:36] at sun.security.jca.ProviderConfig.getProvider(ProviderConfig.java:187)
[17:24:36] at sun.security.jca.ProviderList.getProvider(ProviderList.java:232)
[17:24:37] at sun.security.jca.ProviderList.getService(ProviderList.java:330)
[17:24:37] at sun.security.jca.GetInstance.getInstance(GetInstance.java:157)
[17:24:37] at java.security.Security.getImpl(Security.java:695)
[17:24:37] at java.security.MessageDigest.getInstance(MessageDigest.java:159)
[17:24:37] at org.tribot.util.MD5Checksum.createChecksum(rc:146)
[17:24:37] at org.tribot.util.MD5Checksum.getMD5Checksum(rc:162)
[17:24:37] at org.tribot.TRiBot.(sj:0)
[17:24:37] at org.tribot.TRiBot.M(sj:969)
[17:24:37] at org.tribot.TRiBot.main(sj:954)

Share this post


Link to post
Share on other sites

 

New versions of the TRiBot Loader have been released. It now works with Java 8u25 and 7u71.

 

Also updated:

  • Users can disable random dismissing via TRiBot's settings.
  • RSObject.getAllTiles() has been altered.

 

Trilezz can you check

  setLoginBotState(boolean active) cause when I put it in false so that it doesnt work cause I got my own login method, it still is true even if I put it false..Before this update was all fine.Can you check it?thing is on 8 clients out of 20 it overided auto login method  but rest 12 didnt...

 

Edit: it seems that when I uncheck this new option in settings called  Dismiss randoms than it works... It seems this new option overide my settings onstart

Edited by Gundar

Share this post


Link to post
Share on other sites

its still broken. please fix and let us know here when you've fixed the bot.

 

It's not the bot that is broken. You are the one who have done something wrong since the bot work for 99.99% of all the others.

try using JRE instead of JDK and install the latest java.

Share this post


Link to post
Share on other sites

okay so i'm on a Mac os X and i downloaded the latest version of java but it still shows java 7.0 as the only option on the tribot login screen to use. I uninstalled all java and downloaded latest version and it still does the same showing /Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk

Share this post


Link to post
Share on other sites

okay so i'm on a Mac os X and i downloaded the latest version of java but it still shows java 7.0 as the only option on the tribot login screen to use. I uninstalled all java and downloaded latest version and it still does the same showing /Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk

Unfortunately I can't personally help you because I'm not a keen mac user but I'd suggest that you go here: https://tribot.org/forums/forum/126-bot-help/ 

and take a look around at different reports BEFORE you post anything and try use the search button. If you can't find anything relevant to your issue then make a post following this guide: https://tribot.org/forums/topic/21703-read-before-posting-be-specific/

 

That is the area where all bugs/errors are posted and people help out eachother with possible solutions.

 

Please take your time to read before posting.

Good luck :)

Share this post


Link to post
Share on other sites

i get this whenever i run tribot.

 

  • [20:56:50] TRiBot Release 9.211_5 loaded. (1.7.0_67:C:\Program Files\Java\jre7)
  • [20:56:51] Loading human mouse movement data.
  • [20:56:51] Could not load human mouse data. Reason: Human mouse data encryption key not found. 

Share this post


Link to post
Share on other sites

 

i get this whenever i run tribot.

 

  • [20:56:50] TRiBot Release 9.211_5 loaded. (1.7.0_67:C:\Program Files\Java\jre7)
  • [20:56:51] Loading human mouse movement data.
  • [20:56:51] Could not load human mouse data. Reason: Human mouse data encryption key not found. 

 

 

It should say that for now. You're bot(s) should still run normally.

Share this post


Link to post
Share on other sites

post-76265-0-81730100-1416090304_thumb.p

Well the loader shows me this then trying to load rs3 but rs3 don't load and when I try old school the client loads.

 

What is the problem ?

 

  1. I have the latest jre1.8.0_25.
  2. Old school client works.
  • But RS3 client don't even loads

 

Please help me to find my problem

 

IMP > I am using ubuntu linux and I run the jar in the terminal with this command > java -jar TRiBot.jar (< I don't have any problem to open the loader)

  • Like 1

Share this post


Link to post
Share on other sites

attachicon.gifScreenshot - 11152014 - 11:12:13 PM.png

Well the loader shows me this then trying to load rs3 but rs3 don't load and when I try old school the client loads.

 

What is the problem ?

 

  1. I have the latest jre1.8.0_25.
  2. Old school client works.
  • But RS3 client don't even loads

 

Please help me to find my problem

 

IMP > I am using ubuntu linux and I run the jar in the terminal with this command > java -jar TRiBot.jar (< I don't have any problem to open the loader)

 

TRiBot for RS3 doesn't work on Linux.

Share this post


Link to post
Share on other sites

Can you fix this please?

 

Thankyou for the reply

This isn't possible because linux doesn't support OpenGL.

Since you are not VIP, you are only allowed to run ONE script at a time. Please close your other instances of TriBot to use this one.

 

Anyone explain to me why everytime i try to run a script I get this??

 

No other client open?? WTF?

 

https://tribot.org/repository/user_panel/instance_manager/

are there any instances open?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • This release will:

      Fix key event handling issue


      Fix other event handling issue


      Fix RSServer hook


      Update world hopper to have it use OCR, thanks to Todd


      Use proper disposal of old Graphics objects


      Reformat code


      Rearrange code


      Organize code imports


      Apply around 8000 automated code refactorings


      Make preparations for Java 9


      Fix 11 various bugs


      Add more reliable debugging support


      Fix mouseEntered/Exited event dispatching bug


      Fix minimap walking bug where it opens the map


      Fix broken hooks for today's game update
      • 55 replies
    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
      • 27 replies
    • This release will:

      Fix some ClosedChannelException bug


      Fix bug in RSObject#getAllTiles


      Add game tab support for "Kourend Favour"
      • 15 replies
    • This release will:

      Fix Settings UI placement bug


      Fix game object location bug


      Fix small layout bug making the client shift up and down


      Fix client crashing bug where loading the client with a small display area will cause the client to crash


      Fix annoying Linux bug relating to painting events and peers


      Fix settings saving bug where settings are saved to disk more often than they should


      Fix RSInterface#isBeingDrawn bug affecting a limited amount of people


      Drop Java 1.7 bytecode version for 1.8


      Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date).


      This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support.
      • 40 replies
    • This update will:

      Fix the RSMenuNode bug which also fixes the bug with bank opening


      Fix the incorrect object positions bug


      Fix and re-enable the LG Objects API Accelerator


      Fix the RSObject#getAllTiles bug
      • 22 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×