Jump to content
TRiLeZ

TRiBot Release 9.211_0

Recommended Posts

[17:24:35] Starting TRiBot Loader.

[17:24:35] TRiBot Loader Release 2.02 is up-to-date.
[17:24:35] Attempting to launch TRiBot.
[17:24:35] Java Exe: /Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk/Contents/Home/jre/bin/java ([7, 0, 51])
[17:24:36] TRiBot SID: '1854b-DMyTCr3J1HZqMnaUsQ 09cSmH4tfPBlAPQSHnacywSnL1QzOpd'.
[17:24:36] Click this text box to copy the SID to your clipboard.
[17:24:36] TRiBot Loader has finished it's process. TRiBot will now start.

[17:24:36] CONSOLE STARTED
[17:24:36] TRiBot Release 9.211_1
[17:24:36] Initial Settings Loaded
[17:24:36] Using SID: 1854b-DMyTCr3J1HZqMnaUsQ09cSmH4tfPBlAPQSHnacywSnL1QzOpd
[17:24:36] Exception in thread "TSV" java.lang.UnsatisfiedLinkError: java.lang.Class.getCheckMemberAccessMethod(Ljava/lang/Class;)Ljava/lang/reflect/Method;
[17:24:36] at java.lang.Class.getCheckMemberAccessMethod(Native Method)
[17:24:36] at java.lang.Class.access$0(Class.java:2359)
[17:24:36] at java.lang.Class$SecurityManagerHelper.(Class.java:2320)
[17:24:36] at java.lang.Class.isCheckMemberAccessOverridden(Class.java:2340)
[17:24:36] at java.lang.Class.checkMemberAccess(Class.java:2377)
[17:24:36] at java.lang.Class.newInstance(Class.java:345)
[17:24:36] at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:221)
[17:24:36] at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:206)
[17:24:36] at java.security.AccessController.doPrivileged(Native Method)
[17:24:36] at sun.security.jca.ProviderConfig.doLoadProvider(ProviderConfig.java:206)
[17:24:36] at sun.security.jca.ProviderConfig.getProvider(ProviderConfig.java:187)
[17:24:36] at sun.security.jca.ProviderList.getProvider(ProviderList.java:232)
[17:24:36] at sun.security.jca.ProviderList.getService(ProviderList.java:330)
[17:24:36] at sun.security.jca.GetInstance.getInstance(GetInstance.java:157)
[17:24:36] at javax.net.ssl.SSLContext.getInstance(SSLContext.java:156)
[17:24:36] at obf.mj.(gl:771)
[17:24:36] at obf.iJ.run(sj:853)
[17:24:36] at java.lang.Thread.run(Thread.java:744)
[17:24:36] Exception in thread "main" java.lang.UnsatisfiedLinkError: java.lang.Class.getCheckMemberAccessMethod(Ljava/lang/Class;)Ljava/lang/reflect/Method;
[17:24:36] at java.lang.Class.getCheckMemberAccessMethod(Native Method)
[17:24:36] at java.lang.Class.access$0(Class.java:2359)
[17:24:36] at java.lang.Class$SecurityManagerHelper.(Class.java:2320)
[17:24:36] at java.lang.Class.isCheckMemberAccessOverridden(Class.java:2340)
[17:24:36] at java.lang.Class.checkMemberAccess(Class.java:2377)
[17:24:36] at java.lang.Class.newInstance(Class.java:345)
[17:24:36] at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:221)
[17:24:36] at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:206)
[17:24:36] at java.security.AccessController.doPrivileged(Native Method)
[17:24:36] at sun.security.jca.ProviderConfig.doLoadProvider(ProviderConfig.java:206)
[17:24:36] at sun.security.jca.ProviderConfig.getProvider(ProviderConfig.java:187)
[17:24:36] at sun.security.jca.ProviderList.getProvider(ProviderList.java:232)
[17:24:37] at sun.security.jca.ProviderList.getService(ProviderList.java:330)
[17:24:37] at sun.security.jca.GetInstance.getInstance(GetInstance.java:157)
[17:24:37] at java.security.Security.getImpl(Security.java:695)
[17:24:37] at java.security.MessageDigest.getInstance(MessageDigest.java:159)
[17:24:37] at org.tribot.util.MD5Checksum.createChecksum(rc:146)
[17:24:37] at org.tribot.util.MD5Checksum.getMD5Checksum(rc:162)
[17:24:37] at org.tribot.TRiBot.(sj:0)
[17:24:37] at org.tribot.TRiBot.M(sj:969)
[17:24:37] at org.tribot.TRiBot.main(sj:954)

Share this post


Link to post
Share on other sites

 

New versions of the TRiBot Loader have been released. It now works with Java 8u25 and 7u71.

 

Also updated:

  • Users can disable random dismissing via TRiBot's settings.
  • RSObject.getAllTiles() has been altered.

 

Trilezz can you check

  setLoginBotState(boolean active) cause when I put it in false so that it doesnt work cause I got my own login method, it still is true even if I put it false..Before this update was all fine.Can you check it?thing is on 8 clients out of 20 it overided auto login method  but rest 12 didnt...

 

Edit: it seems that when I uncheck this new option in settings called  Dismiss randoms than it works... It seems this new option overide my settings onstart

Edited by Gundar

Share this post


Link to post
Share on other sites

its still broken. please fix and let us know here when you've fixed the bot.

 

It's not the bot that is broken. You are the one who have done something wrong since the bot work for 99.99% of all the others.

try using JRE instead of JDK and install the latest java.

Share this post


Link to post
Share on other sites

okay so i'm on a Mac os X and i downloaded the latest version of java but it still shows java 7.0 as the only option on the tribot login screen to use. I uninstalled all java and downloaded latest version and it still does the same showing /Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk

Share this post


Link to post
Share on other sites

okay so i'm on a Mac os X and i downloaded the latest version of java but it still shows java 7.0 as the only option on the tribot login screen to use. I uninstalled all java and downloaded latest version and it still does the same showing /Library/Java/JavaVirtualMachines/jdk1.7.0_51.jdk

Unfortunately I can't personally help you because I'm not a keen mac user but I'd suggest that you go here: https://tribot.org/forums/forum/126-bot-help/ 

and take a look around at different reports BEFORE you post anything and try use the search button. If you can't find anything relevant to your issue then make a post following this guide: https://tribot.org/forums/topic/21703-read-before-posting-be-specific/

 

That is the area where all bugs/errors are posted and people help out eachother with possible solutions.

 

Please take your time to read before posting.

Good luck :)

Share this post


Link to post
Share on other sites

i get this whenever i run tribot.

 

  • [20:56:50] TRiBot Release 9.211_5 loaded. (1.7.0_67:C:\Program Files\Java\jre7)
  • [20:56:51] Loading human mouse movement data.
  • [20:56:51] Could not load human mouse data. Reason: Human mouse data encryption key not found. 

Share this post


Link to post
Share on other sites

 

i get this whenever i run tribot.

 

  • [20:56:50] TRiBot Release 9.211_5 loaded. (1.7.0_67:C:\Program Files\Java\jre7)
  • [20:56:51] Loading human mouse movement data.
  • [20:56:51] Could not load human mouse data. Reason: Human mouse data encryption key not found. 

 

 

It should say that for now. You're bot(s) should still run normally.

Share this post


Link to post
Share on other sites

post-76265-0-81730100-1416090304_thumb.p

Well the loader shows me this then trying to load rs3 but rs3 don't load and when I try old school the client loads.

 

What is the problem ?

 

  1. I have the latest jre1.8.0_25.
  2. Old school client works.
  • But RS3 client don't even loads

 

Please help me to find my problem

 

IMP > I am using ubuntu linux and I run the jar in the terminal with this command > java -jar TRiBot.jar (< I don't have any problem to open the loader)

  • Like 1

Share this post


Link to post
Share on other sites

attachicon.gifScreenshot - 11152014 - 11:12:13 PM.png

Well the loader shows me this then trying to load rs3 but rs3 don't load and when I try old school the client loads.

 

What is the problem ?

 

  1. I have the latest jre1.8.0_25.
  2. Old school client works.
  • But RS3 client don't even loads

 

Please help me to find my problem

 

IMP > I am using ubuntu linux and I run the jar in the terminal with this command > java -jar TRiBot.jar (< I don't have any problem to open the loader)

 

TRiBot for RS3 doesn't work on Linux.

Share this post


Link to post
Share on other sites

Can you fix this please?

 

Thankyou for the reply

This isn't possible because linux doesn't support OpenGL.

Since you are not VIP, you are only allowed to run ONE script at a time. Please close your other instances of TriBot to use this one.

 

Anyone explain to me why everytime i try to run a script I get this??

 

No other client open?? WTF?

 

https://tribot.org/repository/user_panel/instance_manager/

are there any instances open?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • This release will:

      Add LG support for Runelite


      Fix NPCChat issues


      Fix a bug where the camera angle setter would just hold down a key for 5 seconds (the timeout)


      Slightly adjust the rotation via keys to be more accurate


      Add the ability for asynchronous camera movement via keys


      Make Camera rotation via mouse more fluid, with more antiban, and work much better in resizable mode


      Add a "Camera#setCamera" method, allowing the rotation and angle to be set in parallel


      Increase the likelihood of using the mouse for camera movements


      Add support for adjusting the camera to positionable entities (Positionable#adjustCameraTo)



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 43 replies
    • This update will:

      Allow for clicking through the chat box when possible (Thanks @Todd)


      Fix Combat#selectIndex (Thanks @Encoded)


      Ensure worlds stay sorted and added a check to avoid misclicks in the in-game world hopper (Thanks @erickho123)


      Fix out-dated Options API interface indices (Thanks @Todd)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 12 replies
    • This release will:

      Fix login bot after today's game update (Thanks @JoeDezzy1)


      Fix latest in-game world hopping issues (Thanks @erickho123)


      Compact Settings UI and set location relative to TRiBot (Thanks @JoeDezzy1)


      Fix an older implementation of GrandExchange#getWindowState (Thanks @JoeDezzy1)


      Improve the preformance of NPCChat by only searching in certain interface parents (Thanks @JoeDezzy1)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      LG support for RuneLite


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 16 replies
    • This release will:

      Fix bytecode manipulation in order to prevent the modification of parameters within the Filter and Condition classes themselves (thanks @wastedbro)


      Fix NPE caused by non-null value in GE API (thanks @erickho123)


      Add and fix equals methods for api2007.types (thanks @JoeDezzy1)


      Modify Mouse#leaveGame to make the mouse leave the game from top, left, right, or bottom (thanks @erickho123)


      Add Entrana area to Ships API (thanks @erickho123)


      Fix raid prayers index/settings in Prayer API (thanks @erickho123)



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 29 replies
    • This update will:

      Implement better canvas locking/synchronization mechanism


      Fix small Login API bug


      Remove the requirement for xbooting Java classes


      Use ExecutorService to perform canvas work in parallel


      Add "Account Management" game tab to GameTab API (thanks @Encoded)


      Fix NPCChat#getMessage (thanks @Encoded )


      Fix NPCChat#selectOption (thanks @Encoded )


      Fix Banking API after today's update (thanks @Encoded )


      Fix in-game world hopper after today's update (thanks @Encoded )



      Upcoming updates:

      Break handler bug fix


      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 38 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×