Jump to content
elusiven

[EASY] An All-In-One Guide to setup & use VPS for BOTTING. (centOS/Ubuntu)

Recommended Posts

Hello guys!

 

I am here to show you how to use a VPS linux server to remote view your desktop and bot on it. This saves you money on buying a windows machine, you can just use linux with a few simple steps!

 

I bought mine server from rootnerds.com - they do really cheap good servers, 3gb ram, 1cpu, 200gb hdd and 500gb transfer for only 2.99eu/ a month!!!

http://lowendbox.com/blog/rootnerds-e1-99month-or-2-61month-1gb-openvz-vps-in-frankfurt-germany/

 

 

Ubuntu 14 desktop facility is not really suitable/compatible with xrdp, therefore we need to install xfce first to get it running, if you don't you will end up with grey screen!

 

NOTE: THIS WORKS FOR UBUNTU +9 AND CENTOS 5/6.

 

If you don't have WGET command on centos you need to download it.. Type this in terminal:

yum -y install wget

1. Download Putty.

2. Connect to your server (type in IP of ur server into putty)

3. open terminal and type in (CASE-SENSITIVE) - 

wget https://raw.github.com/anonymous--/SetupVPS/master/setupvps.sh

3. type in

chmod +x setupvps.sh 

(press enter)

 

Then type this in and press enter:

./setupvps.sh

4. After everything is completed in the script connect to your vnc using (ULTRAVNC)(google it) and type in SERVERIP:1 or SERVERIP:5901

5. go to terminal again and assuming you have centos type in     (if its ubuntu 10/11/12 type in sudo apt-get install java)

yum install java

6. Download BOT and run it ! (Make sure you run java 1.7.0 on the BOT !!)

 

DONE!

 

 

 

 

UBUNTU 10/11/12/13/14 PLEASE FOLLOW GUIDE BELOW.

GUIDE FOR UBUNTU +14.

 

1. Download putty.

2. Open putty and input your server's IP address.

3. Type in the following (case sensitive):

apt-get update

Now wail till it updates and then type in:

sudo apt-get install ubuntu-desktop --no-install-recommends

Again, wait till it's done and after that type in:

sudo apt-get install xrdp

Then type in:

/etc/init.d/xrdp status    // we check the status of the server/etc/init.d/xrdp start     // we start the server

Now we need to install XFCE desktop.. So type in:

sudo apt-get update                                         // we update the repo againsudo apt-get install xfce4                              // we install XFCE4

Now after we installed everything we need to let know XFCE that we will be using it's desktop instead of ubuntu or gnome.

So TYPE IN :

echo xfce4-session >~/.xsession

And then last step... Type in:

sudo service xrdp restart

Now to connect to your ubuntu, you don't really need any UltraVNC or anything like that. Just go to search on your windows and type in remote desktop, launch that little program and type in the IP of your server in the computer name field. It should now properly connect, type in your username (usually root) and password (whatever you setup on your vps as root) AND that's it! You are ready to bot, just remember to download JAVA!!! (sudo apt-get install java).

 

Once you are in remote desktop now open terminal window and type in:

sudo apt-get install default-jresudo apt-get install firefox

This will install java and firefox for you..

 

Now you can download the bot...When you download the bot make sure you make it exe. so you move the bot file to the /root directory and then go to terminal and type in:

chmod +x TRiBot.jar

after that you can go and launch the bot and BOT... remember to select java 1.7.0 on tribot client!!

 

IF you are using XRDP and want to reconnect you to the same session you MUST follow these short steps!

 

1. Login to your xfce desktop

2. Go to /etc/xrdp/xrdp.ini       ( Should be in the file system somewhere )

3. Look for "xrdp7" and at the bottom add this:

[xrdp8]name=Reconnectlib=libvnc.sousername=askpassword=askip=127.0.0.1port=5910

4. Save this file & exit your remote desktop.

5. Login to xrdp with module "RECONNECT" and ta da, job is done:) (everytime now you want to connect to your existing session you need to use RECONNECT module.

 

 

 

 

This is is my statistic from running 1 bot.

 

Bandwidth Usage

0%

528.31 MB of 500 GB Used / 499.48 GB Free Memory Usage

15%

447.35 MB of 3 GB Used / 2.56 GB Free VSwap Usage

0%

0 KB of 0 KB Used / 0 KB Free Disk Usage

1%

1.86 GB of 200 GB Used / 198.14 GB Free

 

 

Remember to run tribot with 512 ram cache.  You can run STABLE probably up to 4-5 bots with 3gb RAM

 

Also they sell additional IPs. So you can buy 2.99euro server and +5 different ips and you can bot without getting banned... Really good deal this is:)

 

 

 

SCREENIE: tadascript.png

Edited by elusiven
  • Like 2

Share this post


Link to post
Share on other sites

Sweet, good find thanks :)

 

Btw, after downloading the setupvps.sh you need to run these commands:

 

chmod +x setupvps.sh

 

(press enter)

 

Then type this in and press enter:

 

./setupvps.sh

Edited by Will

Share this post


Link to post
Share on other sites

Can someone explain how much power each bot need? Like if i buy the 2.99 eu, how many bot can i run on it?

 

Sure pal.

 

This is is my statistic from running 1 bot.

 

Bandwidth Usage

0%

528.31 MB of 500 GB Used / 499.48 GB Free Memory Usage

15%

447.35 MB of 3 GB Used / 2.56 GB Free VSwap Usage

0%

0 KB of 0 KB Used / 0 KB Free Disk Usage

1%

1.86 GB of 200 GB Used / 198.14 GB Free

 

 

Remember to run tribot with 512 ram cache.  You can run STABLE probably up to 4-5 bots with 3gb RAM

 

Also they sell additional IPs. So you can buy 2.99euro server and +5 different ips and you can bot without getting banned... Really good deal this is:)

Edited by elusiven

Share this post


Link to post
Share on other sites

Defo works with centos 5/6 and ubuntu not sure about 7 coz i haven't used it yet. If any of the commands changed or repos then it will not work. As long as its functioning like 5 or 6 then you should be fine. and btw that's a very nice deal....

Edited by elusiven
  • Like 1

Share this post


Link to post
Share on other sites

@elusiven Why is it that if i turn on the bot on ubuntu then close my remote desktop connection, the next time i try to enter on it, it doesnt take me to the other desktop? it creates a new one or so.

 

Sure pal,

 

You need to create another module called reconnection on different port...

 

1. Login to your xfce desktop

2. Go to /etc/xrdp/xrdp.ini       ( Should be in the file system somewhere )

3. Look for "xrdp7" and at the bottom add this:

[xrdp8]name=Reconnectlib=libvnc.sousername=askpassword=askip=127.0.0.1port=5910

4. Save this file & exit your remote desktop.

5. Login to xrdp with module "RECONNECT" and ta da, job is done:) (everytime now you want to connect to your existing session you need to use RECONNECT module.

Edited by elusiven

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By warlordslay3r
      Hey i recently got the vip with tribot i tried the rockcrabs bots but it was shit it runs around for no reason and script turns of automatically whats a good flawless bot for rockcrabs any recommendation ?
    • By TRiLeZ
      This release will:
      Fix Settings UI placement bug Fix game object location bug Fix small layout bug making the client shift up and down Fix client crashing bug where loading the client with a small display area will cause the client to crash Fix annoying Linux bug relating to painting events and peers Fix settings saving bug where settings are saved to disk more often than they should Fix RSInterface#isBeingDrawn bug affecting a limited amount of people Drop Java 1.7 bytecode version for 1.8 Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date). This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support. Edit: Release 9.312_1 will:
      Fix LG GZIP error Fix Client Starter for Linux 🙌
    • By Thebot13
      I think I may have figured out a technique used by the software botwatch they may look at a new account since the new account is at an extremely low ranking of several 100,000 if you continuously train on that account including other methods it uses to detect it must go by ranks as the most primary method of finding and flagging new accounts that are being botted.
       
      This also concerns mains that are botted let's say if you go over an increase of 80,000+ ranks in 24 hours. Then the botWatch system flags or account for a mod to look at. 
       
      I suggest tracking you account closely on CrystalMathlabs and watch your ranking. I would suggest that you stay under the 30,000 rank increase in any given skill
       
      **EDIT This is purely thought based, noone knows how the botwatch programme detects botters.
    • By Fluffee
      How to Run Most Applications Through a Proxy on both Windows and Linux
      Windows Instructions
      Note: Chrome and Firefox portable do not work with WideCap.
      1. Download WideCap from here (http://widecap.ru/en/download/)
      2. Run through the installer, and launch WideCap, you should see this screen.

      3.Go ahead and click on Settings (First option under the Widecap section on the left hand side). Then uncheck the box that says Run with system startup.

      4. Now go ahead and click on New proxy (First option under the proxies section on the left hand side).
      5.You should see this screen, in the top field enter the IP address and port (IP:Port format). Confirm that the protocol is set to SOCKS v5 (which is the default), and tick the box for Authentication if necessary. If using an authenticated proxy, enter your username in the login field, and obviously your password in the password field. Then hit the Create New button, next to Chain, and type in a name for your Proxy, then Hit OK

      6. Now that you're back to the main screen, click on the Proxy List section (Second option under the proxies section on the left hand side). Right click on your newly added proxy, and click check selected, to make sure you entered all the information correctly. If the status field rolls over to OK, you're good to go, and can move on to the next step

      7. Find WideCap in your System tray, right click, and uncheck the box that says Enable Widecap.

      8. Click on View Programs (Second option under the Programs section on the left hand side). Then drag and drop the icon for the application you want to proxify (run behind a proxy) into WideCap. WideCap supports the proxifying of both .exe and .jar files!

      9. Right Click on your newly added program, and click on Modify Application, you should see a similar screen depending on what you added. Then click on Create New... (to create a new rule)

      10. In the Chain tab, select the Proxy Chain you created earlier, then under the Main tab, give your new rule a name and hit OK. Then Hit OK again on the modify Application screen.

      11. Hit Apply and OK in the main window of WideCap, and then find it in your System Tray again, but this time click the box to Enable Widecap
      12.Open your Proxified application, and check to see if the proxy worked! If your IP is changed, congrats, you've got WideCap working!
      Linux Instructions (Based off of a Debian Installation)
      1. Open a new terminal and run this command
      sudo apt-get update && sudo apt-get install -y proxychains 2. Now that proxychains is installed, we're going to go ahead and create a user specific configuration file. To do this, we'll make a directory, then copy the standard proxychains configuration file to it and change the ownership of the configuration file to your user. Run the command below as your user.
      mkdir ~/.proxychains/ && cp /etc/proxychains.conf ~/.proxychains/proxychains.conf && sudo chown ${USER:=$(/usr/bin/id -run)} $HOME/.proxychains/proxychains.conf && sudo chgrp ${USER:=$(/usr/bin/id -run)} $HOME/.proxychains/proxychains.confroxychains.conf 3. Once the command is finished, open the proxychains config file in your favorite Linux text editor, for ease of use, I'm going to use nano. To install nano run this command
      sudo apt-get install -y nano To edit the proxychains config file, with nano, run this command
      nano ~/.proxychains/proxychains.conf 4. Now, what you'll want to do is scroll all the way down to the bottom, and you should see something like this

      That last line that says
      socks4    127.0.0.1    9050
      That's the line we'll be editing. Firstly, we'll go ahead and erase everything on that line, don't worry we'll put it back. The format for the configuration file is
      Proxy Type(lowercase) (tab) IP address (tab) Port (tab) Username (tab) Password
      Therefore if your proxy was a Socks5 proxy, with an IP of 192.168.1.1, a port of 1080, a username of Fluffee and a password of TRiBot, your final line would look like this:
      socks5    192.168.1.1    1080    Fluffee    TRiBot
      So, go ahead and modify your last line to fit your own proxy and then hit Control+X to exit, and then hit Y to save (instructions are based off of using nano to edit the file).
      5. Proxychains is now setup, but how do you use it? Go ahead and VNC into your Server and open a terminal, or open a Terminal inside your Desktop Environment (if using Linux installed on a PC). From there run the command proxychains followed by the application you would like to run, or the path to the application. For example, try running, if you have Firefox installed:
      proxychains firefox Then navigate to an IP checking website, and see if your proxy worked!
      That concludes the tutorial on how to use a proxy with Oldschool or any browser, on both Linux and Windows. If you have any questions feel free to post in the comments!
    • By Zepix
      Hi guys, i have this annoying issue, that whenever i open my Tribot client, it shows a white box, where it says TRiBot Login in the top left, and the rest is just white/blank.
       
      It's been like this for days. I've tried to install and uninstall Java 8, I also tried using Jarfix, etc etc. What can i possibly do, to fix this? 
    • By r0ot
      I've nearly got TRiBot running on an Ubuntu machine but have run into an error with the loader.  When I run the loader for the first time and it populates the dependencies folder, the file togl.dll get's downloaded instead of libTOGL.so which TRiBot.jar eventually looks for.  Error looks like this:
      Loading TOGL Loading: /home/<user>/.tribot/dependancies/libTOGL.so Exception in thread "AWT-EventQueue-1" java.lang.UnsatisfiedLinkError: Can't load library /home/<user>/.tribot/dependancies/ibTOGL.so Inside my dependencies folder there's a file called togl.dll.  The bug report forum says I need to post here before I can post there.
  • Our picks

    • Please welcome our new developers, @JoeDezzy1, @erickho123, @Encoded, and @wastedbro.

      These members will be responsible for working on, maintaining, and improving TRiBot.

      This means that bug fixes and improvements will now come at a much faster pace! We're committed to providing users with the best botting experience possible!
        • Thanks
        • Like
      • 30 replies
    • This release includes:

      More 3rd party libraries for script writers to use


      Apache Commons Codec


      Apache Commons Collections


      Apache Commons Configuration


      Apache Commons IO


      Apache Commons Lang


      Apache Commons Math


      GSON


      Guava


      JFoenix




      Hint arrow API


      Game#getHintArrowX


      Game#getHintArrowY




      Fix player hooks including Player#getSkullIcon and Prayer#getPrayerIcon
        • Thanks
        • Like
      • 41 replies
    • This update includes:

      Fix broken hooks


      Fix login bot for the message "No reply from login server. Please wait 1 minute and try again."


      Fix bug relating to which bot tab is sent human input


      General#randomLong bug fix involving negative numbers


      Fix GE API



      Please note: There are still some issues with the login bot due to a change in the game mechanisms handling the login screen. We're working on a fix and will upload it when ready.
        • Thanks
        • Like
      • 37 replies
    • This release will:

      Fix key event handling issue


      Fix other event handling issue


      Fix RSServer hook


      Update world hopper to have it use OCR, thanks to Todd


      Use proper disposal of old Graphics objects


      Reformat code


      Rearrange code


      Organize code imports


      Apply around 8000 automated code refactorings


      Make preparations for Java 9


      Fix 11 various bugs


      Add more reliable debugging support


      Fix mouseEntered/Exited event dispatching bug


      Fix minimap walking bug where it opens the map


      Fix broken hooks for today's game update
        • Thanks
        • Like
      • 100 replies
    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
        • Like
      • 27 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×