Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


xCode's Scripter Application

xCode Scripter   6 members have voted

  1. 1. Does xCode deserve Scripter rank?

Please sign in or register to vote in this poll.

7 posts in this topic



Randoms/Updates submitted:

Scripts available:

Note: All script sources are in BitBucket due to too many classes.

About me
My love for programming started to develop about 4 years ago. I had some courses Information Sciences at high school and that's the place where it all started. I started developing some websites in HTML and CSS (just the basics) and started to realise that I really loved doing this. Because of that I started an Information Sciences course on my local university. In the meanwhile I got introduced with C#, JAVA, C++, HTML, PHP and some more nice object orientated languages. Before I joined this community, my JAVA knowledge was kinda low in my opinion. But since the language is kinda similar to C# (in which I'm more familiar with) I understood it rather quickly. Combining this with my love for Runescape resulted in me being addicted to this forum and me writing this application eventually.

Why I deserve to be a Scripter
I feel like I'm qualified enough to be a Scripter on this forum, because I've provided this nice community some scripts. I've devoted a lot of my spare time to contribute to a community which respects my work and keep me motivated doing the thing I love. I desire making more free scripts for this community and help the ones in need, while gaining more experience myself and grow stronger as a programmer.

What you plan to provide the community with?
I will provide this community help, not only with scripting or bot related issues, but also with free, high quality scripts. I'm checking the Help section each day to see if there is someone who needs me. I will keep my scripts up to date and will post tutorials and snippets whenever I think of something that could be really helpful for others.

Do you agree to continue to not only update, but provide more free, open sourced scripts to the community? [YES/NO]
Yes, ofcourse. :)


@AlphaDog Thank you for your criticism. The snippet contains indeed a lot of duplicate code, but this is because each method is supposed to be used seperated from each other. If it would be in one class it would be 10000x better to put the duplicate code in a method and call that. Furthermore, I like using classes instead of enums. This was a deliberate choice. I do use it sometimes tho. FishingMethods is an enum. I am looking forward to the rest of your feedback :)

@Assume Thanks for your feedback. What do you mean by 'basic code'? Also, as far as I know, I'm using lowerCamelCase. It might be possible I sometimes did UpperCamelCase, cuz I've been using C# a lot recently. Can you tell me where exactly you found it? I will adjust it. I'm looking forward to the rest of your feedback :)


Thanks for your feedback. I see what you mean. I will adjust my scripts and will, in the future, use enums when necessary. Besides this, is there anything more you suggest I should improve? Again, thanks for your feedback :) I thrive to learn and am therefore very curious about what I could improve more.
@JoeDezzy1 Thanks!
- Where do you see static sleeps? As far as I can remember I'm only using dynamic ones. Could you post where you found it? I'll adjust it immediately.
- Also, I do know what an enhanced loop is. I sometimes use it whenever I think it's useful. But sometimes if I need the index of the iteration the loop is in, I need to use just the normal for-loop.
- I prefer using classes > enums. But I'm willing to change some of my classes to enums if you want. :)
- Could you please tell me in what ways I should clean up my code more?
I thrive to learn and to gain experience, but I'm doing things as they seem right to me. If you could give me examples of what is wrong and maybe, if possible, give me examples about how I should do it. Thank you very much for your feedback :)


@Everyone I rewrote some of my code to meet standards you made me aware of. Please take a look again and tell me where I can improve. For xFishy: Location, FishType and FishingMethods are now an enum. For xHunter: MonsterType, TrapType and TrapFormation are now enums. I also edited my GUI code, so it uses the objects instead of the string with index (@Starfox). I'm looking forward to your feedback (again :D)


@Assume Thanks, fixed it. I missed it while I was checking my code. Don't be pissed off. I Won't ask you again. I promise.

Edited by xCode
1 person likes this

Share this post

Link to post
Share on other sites

Only based on your snippet, I have to say no.


You have 80% duplicate code in those 3 methods you provided in your snippet.

Don't have time to review your code right now, but first thing I saw when opening your xFishy script is that you don't use any enum's at all.


Both location & fishtype could easily be an enum type, will review the rest of your code later on,

and change my answer to yes if I think you are capable enough for the rank.

Edited by AlphaDog

Share this post

Link to post
Share on other sites



Your code is very basic. Also, methods should not be named using UpperCamelCase, they should be named using lowerCamelCase.

Share this post

Link to post
Share on other sites

Reserved for review. Also, you're going to need to put a poll up so we can vote.


You do not understand object oriented programming which is evident looking at how you structure your scripts.


Also, there are right and wrong ways to achieve results when programming. You can't "prefer classes over enums" when using a class makes no sense for the objective you're trying to reach and vice versa. You should browse oracle tutorials that cover the differences between each reference data type so you can familiarize yourself with when each should and shot not be used.


The above aside, I'd like to point out a specific example of when you are using the wrong type of object. Inside your GUI class in xHunter, you fill the model of the component huntOnCBox with an array of Strings. Instead of doing that, you should make the model accept MonsterType's because MonsterType is the object your script uses to determine information about which monster you are catching.


Example of above statement:

huntOnCBox.setModel(new DefaultComboBoxModel<MonsterType>(xHunter.supportedMonsters));

Of course, to display it in the combobox correctly you should override the toString method of each MonsterType.


Implementing the code written above will allow you to directly set xHunter.monster without parsing a String into a MonsterType inside your startButtonActionPerformed method. I did notice however that you simply rely on the index of the selected item which is even worse than parsing an object because it's entirely static and could prove to be quite annoying to debug and keep track of the ordering of the xHunter.supportedMonsers array.


Example of above statement:

xHunter.monster = (MonsterType) huntOnCBox.getSelectedItem();

Now, with all of that said, the code could still be improved by using an enum to store your pre-defined MonsterType constants which I mentioned at the top of this post.


I am voting no on your application. Best of luck on any future applications.

Edited by Starfox

Share this post

Link to post
Share on other sites

I honestly don't think your code is that bad, I mean everyones code has room for improvement. However you do seem to know what you are doing, and these scripts do seem to work. So I'd say yes. Good luck

1 person likes this

Share this post

Link to post
Share on other sites

If you dont make it this time, please try again later, you seem like a nice guy who's willing to improve.


I think this statement pretty much sums up this thread.


Continue working on developing your skills and learning from many of our Scripters, ask questions and continue revamping your code. Good luck on your next application.

1 person likes this

Share this post

Link to post
Share on other sites
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.