Welcome to TRiBot Forums

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

modulusfrank12

Edgeville Chaos Druid Killer

175 posts in this topic

Made a fresh account to only f2p pk. Got members and all that shit, botted for like almost 2 days. Got banned... i guess jagex really doesnt like moneymaking bots. 100k+ in hour with like 50 str 40 at..

 

And not sure about all these people complaining about bugs, i had almost no problem with it.

Edited by dzambu

Share this post


Link to post
Share on other sites
 

 

Made a fresh account to only f2p pk. Got members and all that shit, botted for like almost 2 days. Got banned... i guess jagex really doesnt like moneymaking bots. 100k+ in hour with like 50 str 40 at..

 

And not sure about all these people complaining about bugs, i had almost no problem with it.

what breaks did you use botted 2 days like straight or what?    Add Potion support and its perfect

Share this post


Link to post
Share on other sites

This script is normally amazing, however today it randomly started getting stuck at "withdrawing essentials". Not sure if that's caused by me putting in "Mithril Bolts" and "Law Runes" into the looting/herb tab, but it's kind of strange. I have the required food and it's clearly visible, strange bug.

 

Edit: It seems this only happens about 5% of the time

Edited by snoopthelion55

Share this post


Link to post
Share on other sites

This script is normally amazing, however today it randomly started getting stuck at "withdrawing essentials". Not sure if that's caused by me putting in "Mithril Bolts" and "Law Runes" into the looting/herb tab, but it's kind of strange. I have the required food and it's clearly visible, strange bug.

 

Edit: It seems this only happens about 5% of the time

Hmm yeah are you using looking glass? It seems that methods such as Banking#find that use alot of CPU get bugged in looking glass.

Share this post


Link to post
Share on other sites

Hmm yeah are you using looking glass? It seems that methods such as Banking#find that use alot of CPU get bugged in looking glass.

i have no idea what is Glass but i get stock sometimes after banking with the withdrawing essential  i'm trying to look lobster and after i grab it it wont leave the bank to go back to chaos druid :) otherwise everything work great check ur pm sir !

Share this post


Link to post
Share on other sites

i have no idea what is Glass but i get stock sometimes after banking with the withdrawing essential  i'm trying to look lobster and after i grab it it wont leave the bank to go back to chaos druid :) otherwise everything work great check ur pm sir !

Ok i'll take a look. Thanks for the report.

Share this post


Link to post
Share on other sites

Testing this now, one issue I find is it always wants to find a new target, regardless if one finds it.

Perhaps you could make a more accurate "currently engaged in combat" method to detect when the sobs preemptively strike?

 

@modulusfrank12

Edited by pkedyuh

Share this post


Link to post
Share on other sites

Testing this now, one issue I find is it always wants to find a new target, regardless if one finds it.

Perhaps you could make a more accurate "currently engaged in combat" method to detect when the sobs preemptively strike?

 

@modulusfrank12

Close all clients, delete the .tribot folder, restart computer

Edited by modulusfrank12

Share this post


Link to post
Share on other sites

Close all clients, delete the .tribot folder, restart computer

 

Will try, also the profit/hour didn't calculate for me. Not sure if the tribot deletion will fix that as well or not. Forgot to take a screeny but I managed to run it for 2 1/2 hours so far, with about 110k loot on a very low level account. 

I have found that it loots shitty herbs like guam, tarromin, and marrentill so I am going to be sure to exclude those next time to maximize profit/hour and save on v tabs lol.

 

Edit:

Deleted the tribot folder and now all the bot does is attempts to world hop. I don't even have the world hop option selected..

 

@modulusfrank12

 

Here is a log from the bot:

 

[07:18:54] TRiBot Release 9.230_1 loaded. (1.8.0_51:C:\Program Files\Java\jdk1.8.0_51\jre)[07:18:54] Loading human mouse movement data.[07:19:01] Successfully loaded human mouse data.[07:20:36] java.io.IOException: Server returned HTTP response code: 403 for URL: http://www.runelocus.com/item-details/?item_id=4151[07:20:36] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1839)[07:20:36] 	at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:90)[07:20:36] 	at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1432)[07:20:36] 	at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1430)[07:20:36] 	at java.security.AccessController.doPrivileged(Native Method)[07:20:36] 	at java.security.AccessController.doPrivileged(AccessController.java:713)[07:20:36] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1429)[07:20:36] 	at java.net.URL.openStream(URL.java:1038)[07:20:36] 	at scripts.sbf.util.Zybez.r.M(ZybezItem.java:210)[07:20:36] 	at scripts.sbf.util.Zybez.r.<init>(ZybezItem.java:60)[07:20:36] 	at scripts.EdgevilleDruidKiller.run(EdgevilleDruidKiller.java:64)[07:20:36] 	at java.lang.Thread.run(Thread.java:745)[07:20:36] java.lang.NullPointerException[07:20:36] 	at scripts.sbf.util.Zybez.r.K(ZybezItem.java:228)[07:20:36] 	at scripts.sbf.util.Zybez.r.<init>(ZybezItem.java:60)[07:20:36] 	at scripts.EdgevilleDruidKiller.run(EdgevilleDruidKiller.java:64)[07:20:36] 	at java.lang.Thread.run(Thread.java:745)[07:20:50] java.io.IOException: Server returned HTTP response code: 403 for URL: http://www.runelocus.com/item-details/?item_id=4151[07:20:50] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1839)[07:20:50] 	at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:90)[07:20:50] 	at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1432)[07:20:50] 	at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1430)[07:20:50] 	at java.security.AccessController.doPrivileged(Native Method)[07:20:50] 	at java.security.AccessController.doPrivileged(AccessController.java:713)[07:20:50] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1429)[07:20:50] 	at java.net.URL.openStream(URL.java:1038)[07:20:50] 	at scripts.sbf.util.Zybez.r.M(ZybezItem.java:210)[07:20:50] 	at scripts.sbf.util.Zybez.r.<init>(ZybezItem.java:60)[07:20:50] 	at scripts.EdgevilleDruidKiller.run(EdgevilleDruidKiller.java:64)[07:20:50] 	at java.lang.Thread.run(Thread.java:745)[07:20:50] java.lang.NullPointerException[07:20:50] 	at scripts.sbf.util.Zybez.r.K(ZybezItem.java:228)[07:20:50] 	at scripts.sbf.util.Zybez.r.<init>(ZybezItem.java:60)[07:20:50] 	at scripts.EdgevilleDruidKiller.run(EdgevilleDruidKiller.java:64)[07:20:50] 	at java.lang.Thread.run(Thread.java:745)[07:24:29] java.io.IOException: Server returned HTTP response code: 403 for URL: http://www.runelocus.com/item-details/?item_id=4151[07:24:29] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1839)[07:24:29] 	at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:90)[07:24:29] 	at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1432)[07:24:29] 	at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1430)[07:24:29] 	at java.security.AccessController.doPrivileged(Native Method)[07:24:29] 	at java.security.AccessController.doPrivileged(AccessController.java:713)[07:24:29] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1429)[07:24:29] 	at java.net.URL.openStream(URL.java:1038)[07:24:29] 	at scripts.sbf.util.Zybez.r.M(ZybezItem.java:210)[07:24:29] 	at scripts.sbf.util.Zybez.r.<init>(ZybezItem.java:60)[07:24:29] 	at scripts.EdgevilleDruidKiller.run(EdgevilleDruidKiller.java:64)[07:24:29] 	at java.lang.Thread.run(Thread.java:745)[07:24:29] java.lang.NullPointerException[07:24:29] 	at scripts.sbf.util.Zybez.r.K(ZybezItem.java:228)[07:24:29] 	at scripts.sbf.util.Zybez.r.<init>(ZybezItem.java:60)[07:24:29] 	at scripts.EdgevilleDruidKiller.run(EdgevilleDruidKiller.java:64)[07:24:29] 	at java.lang.Thread.run(Thread.java:745)[07:26:20] java.io.IOException: Server returned HTTP response code: 403 for URL: http://www.runelocus.com/item-details/?item_id=4151[07:26:20] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1839)[07:26:20] 	at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:90)[07:26:20] 	at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1432)[07:26:20] 	at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1430)[07:26:20] 	at java.security.AccessController.doPrivileged(Native Method)[07:26:20] 	at java.security.AccessController.doPrivileged(AccessController.java:713)[07:26:20] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1429)[07:26:20] 	at java.net.URL.openStream(URL.java:1038)[07:26:20] 	at scripts.sbf.util.Zybez.r.M(ZybezItem.java:210)[07:26:20] 	at scripts.sbf.util.Zybez.r.<init>(ZybezItem.java:60)[07:26:20] 	at scripts.EdgevilleDruidKiller.run(EdgevilleDruidKiller.java:64)[07:26:20] 	at java.lang.Thread.run(Thread.java:745)[07:26:20] java.lang.NullPointerException[07:26:20] 	at scripts.sbf.util.Zybez.r.K(ZybezItem.java:228)[07:26:20] 	at scripts.sbf.util.Zybez.r.<init>(ZybezItem.java:60)[07:26:20] 	at scripts.EdgevilleDruidKiller.run(EdgevilleDruidKiller.java:64)[07:26:20] 	at java.lang.Thread.run(Thread.java:745)[07:46:25] java.io.IOException: Server returned HTTP response code: 403 for URL: http://www.runelocus.com/item-details/?item_id=4151[07:46:25] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1839)[07:46:25] 	at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:90)[07:46:25] 	at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1432)[07:46:25] 	at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1430)[07:46:25] 	at java.security.AccessController.doPrivileged(Native Method)[07:46:25] 	at java.security.AccessController.doPrivileged(AccessController.java:713)[07:46:25] 	at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1429)[07:46:25] 	at java.net.URL.openStream(URL.java:1038)[07:46:25] 	at scripts.sbf.util.Zybez.r.M(ZybezItem.java:210)[07:46:25] 	at scripts.sbf.util.Zybez.r.<init>(ZybezItem.java:60)[07:46:25] 	at scripts.EdgevilleDruidKiller.run(EdgevilleDruidKiller.java:64)[07:46:25] 	at java.lang.Thread.run(Thread.java:745)[07:46:25] java.lang.NullPointerException[07:46:25] 	at scripts.sbf.util.Zybez.r.K(ZybezItem.java:228)[07:46:25] 	at scripts.sbf.util.Zybez.r.<init>(ZybezItem.java:60)[07:46:25] 	at scripts.EdgevilleDruidKiller.run(EdgevilleDruidKiller.java:64)[07:46:25] 	at java.lang.Thread.run(Thread.java:745)
Edited by pkedyuh

Share this post


Link to post
Share on other sites

Post the client debug not bot debug.

 

Can you also give me the script stack trace?

Do Script > Script Stack Trace 4 times.

Share this post


Link to post
Share on other sites

Post the client debug not bot debug.

 

Can you also give me the script stack trace?

Do Script > Script Stack Trace 4 times.

 

Here in a little I will fire your script back up and get you those, sorry just have my character running another bot currently.

 

Edit:

It appears that this issue resolved itself? Not sure how? 

 

@modulusfrank12

Edited by pkedyuh

Share this post


Link to post
Share on other sites

Here in a little I will fire your script back up and get you those, sorry just have my character running another bot currently.

 

Edit:

It appears that this issue resolved itself? Not sure how? 

 

@modulusfrank12

Runescape has been experiencing engine errors and Tribot's servers have been faulty. I'm not surprised the issue resolved itself.

1 person likes this

Share this post


Link to post
Share on other sites

Works well getting to chaos druids and banking. Butt, while at chaos druids it will still try to attack another druid while in combat. otherwise very good job.

 

1 person likes this

Share this post


Link to post
Share on other sites

Works well getting to chaos druids and banking. Butt, while at chaos druids it will still try to attack another druid while in combat. otherwise very good job.

Try deleting hooks.dat

Share this post


Link to post
Share on other sites
On 10/28/2015 at 1:31 AM, modulusfrank12 said:

Try deleting hooks.dat

I did that, but it doing the same thing for me :-( and i'm using LG

Share this post


Link to post
Share on other sites

does this utilize the looting bag? or is it not worth the risk of being pked

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.