Jump to content
TRiLeZ

TRiBot Release 9.120_0

Recommended Posts

This release features:

  • More character randomization/anti-ban
    • The delay between moving the mouse and clicking has been improved. The delay time is now unique for every different botter, and more similar to the delay an actual human would have.
    • The delay between opening the Choose Option menu and clicking an option has been improved. The delay time is now unique for every different botter, and more similar to the delay an actual human would have.
    • The delay between dropping consecutive inventory items has been improved. The delay time is now unique for every different botter, and more similar to the delay an actual human would have.
  • Most deprecated API has been removed.
  • The Account Manager can now have a user-specified password/encryption key.
  • More Anti Ban Compliance areas:
    • HP percent at which to eat at.
    • Delay between item interaction.
  • Updated the event sender/handler.
    • Has been optimized for slower computers.
  • Like 5

Share this post


Link to post
Share on other sites

 

After this update the tribot client doesn't start up for me.

 

 

 

The script loader says tribot is loaded and it gives the green light, but the tribot client never pops up. Strangely, when i go to task manager, i can see a java client running though. 

Any idea whats wrong? 

Edited by gabrielspecter

Share this post


Link to post
Share on other sites

The script loader says tribot is loaded and it gives the green light, but the tribot client never pops up. Strangely, when i go to task manager, i can see a java client running though. 

Any idea whats wrong? 

See my thread posted above. If you launch it in console mode it displays the error, waiting for a response from TriLeZ though

Share this post


Link to post
Share on other sites

Is it just me, or does it feel like these improvements have been added on top of the current clicking system, instead of replacing them? It might just be this script, but the initial clicking is slowed & realistic (which I much prefer), but immediately after the old, way too quick & spam-like clicking also tries to click the object. 

Share this post


Link to post
Share on other sites

I seriously don't understand why the account manager password is constantly messing up. Can we seriously get a fix for this please? I'm unable to use my bots until this is fixed and it's stupid.

 

Post it in the client bugs section

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Our picks

    • This release will:

      Fix key event handling issue


      Fix other event handling issue


      Fix RSServer hook


      Update world hopper to have it use OCR, thanks to Todd


      Use proper disposal of old Graphics objects


      Reformat code


      Rearrange code


      Organize code imports


      Apply around 8000 automated code refactorings


      Make preparations for Java 9


      Fix 11 various bugs


      Add more reliable debugging support


      Fix mouseEntered/Exited event dispatching bug


      Fix minimap walking bug where it opens the map


      Fix broken hooks for today's game update
        • Thanks
        • Like
      • 47 replies
    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
        • Like
      • 27 replies
    • This release will:

      Fix some ClosedChannelException bug


      Fix bug in RSObject#getAllTiles


      Add game tab support for "Kourend Favour"
        • Like
      • 15 replies
    • This release will:

      Fix Settings UI placement bug


      Fix game object location bug


      Fix small layout bug making the client shift up and down


      Fix client crashing bug where loading the client with a small display area will cause the client to crash


      Fix annoying Linux bug relating to painting events and peers


      Fix settings saving bug where settings are saved to disk more often than they should


      Fix RSInterface#isBeingDrawn bug affecting a limited amount of people


      Drop Java 1.7 bytecode version for 1.8


      Important: Since the downloadable RS client uses Java 7, it will no longer be compatible with Looking Glass. To make up for this, we will add support for using other clients such as RuneLite (at a later date).


      This change was necessary to allow us to use Java 8 syntax. It also paves the way for Java 9/10/11 support.
        • Like
      • 40 replies
    • This update will:

      Fix the RSMenuNode bug which also fixes the bug with bank opening


      Fix the incorrect object positions bug


      Fix and re-enable the LG Objects API Accelerator


      Fix the RSObject#getAllTiles bug
        • Like
      • 22 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×