Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
TRiLeZ

TRiBot Release 9.11_0

Recommended Posts

i have a mac im running maverick ive been useing tri bot i even used it last night but when i woke up this morning my scipts wont work like none of them will work. they will start up and the paint will come up but the dont do anything im confused some one plzzz help me

Share this post


Link to post
Share on other sites

I think I've found a solution to walking problems. Obviously its a bug still but I found a way to make it work (I think)

  • Start the bot up
  • Get player to where you need to be.
  • Client -> Block all user input
  • Start script
  • Should be fine from there on

EDIT: I've also got each instance in a new window, tabs may work using these instructions but I haven't tried.

Edited by Zallen93

Share this post


Link to post
Share on other sites

I think I've found a solution to walking problems. Obviously its a bug still but I found a way to make it work (I think)

  • Start the bot up
  • Get player to where you need to be.
  • Client -> Block all user input
  • Start script
  • Should be fine from there on

EDIT: I've also got each instance in a new window, tabs may work using these instructions but I haven't tried.

 

I don't understand.  Are you saying the solution to the walking problems is to use a bot that doesn't walk? Lol.

 

"Get player to where you need to be" -> "start script", you make it sound like this only applies to scripts that don't walk from where you start.

Share this post


Link to post
Share on other sites

I don't understand.  Are you saying the solution to the walking problems is to use a bot that doesn't walk? Lol.

 

"Get player to where you need to be" -> "start script", you make it sound like this only applies to scripts that don't walk from where you start.

 

Minor error, sorry :P

 

What I mean is just press start. The main point I was trying to get across is that being able to move the mouse freely while the script was running was messing it up for me.

 

Probably won't work after a while knowing my luck but hey ho.

Share this post


Link to post
Share on other sites

Minor error, sorry :P

 

What I mean is just press start. The main point I was trying to get across is that being able to move the mouse freely while the script was running was messing it up for me.

 

Probably won't work after a while knowing my luck but hey ho.

 

Trying my script now with block user input.  Would make sense that because it was a changed feature, it could be a potential problem. 

 

Still messing up right away, just gonna wait for a proper fix lol.

Edited by Acknowledge

Share this post


Link to post
Share on other sites

Minor error, sorry :P

 

What I mean is just press start. The main point I was trying to get across is that being able to move the mouse freely while the script was running was messing it up for me.

 

Probably won't work after a while knowing my luck but hey ho.

lmao, this, for some reason, is working for me!? It's keeping my cpu down by 50% also. Better not jinx it. :P thanks a lot man!

Share this post


Link to post
Share on other sites

I think I've found a solution to walking problems. Obviously its a bug still but I found a way to make it work (I think)

  • Start the bot up
  • Get player to where you need to be.
  • Client -> Block all user input
  • Start script
  • Should be fine from there on

EDIT: I've also got each instance in a new window, tabs may work using these instructions but I haven't tried.

 

This is working for me, but it only works on one client. Once I open another TRiBot client it stops the first. One bot is better than none though.

  • Like 1

Share this post


Link to post
Share on other sites

This is working for me, but it only works on one client. Once I open another TRiBot client it stops the first. One bot is better than none though.

 

Yeah the same happened to me after a while (when using Master Chopper AIO specifically). It's very hit and miss but as you said one is better than none :-)

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Our picks

    • This release will:

      Fix LG for both OSBuddy and RuneLite


      Fix issue where the resizable client isn't able to be made smaller (Thanks @JoeDezzy1)


      Fix detection of the logout game tab when resizable mode and side panels are enabled (Thanks @JoeDezzy1)


      Add initial support for Sentry to allow us to identify and easily debug exceptions happening with all TRiBot users


      Add methods to determine if the bank is actually loaded, and not just the overarching interface (Thanks @wastedbro)



      Upcoming updates:

      Improved CLI support


      Full Sentry support


      Much more
      • 48 replies
    • This release will:

      Fix NPE in Camera API (Thanks @wastedbro)


      Update deposit box interface ids (Thanks @Encoded)


      Add various bank methods (Thanks @wastedbro)


      Banking#getWithdrawXQuantity


      Banking#getDefaultWithdrawQuantity


      Banking#arePlaceholdersOn




      Fix resizeable minimap bug (Thanks @wastedbro)


      Remove Java 8 requirement


      Please note: TRiBot is not yet fully compatible with Java 10+




      Fix the break handler issues by ensuring the break handler thread never gets paused


      Fix broken settings hooks



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 68 replies
    • This release will:

      Add support for using custom F key bindings to switch between game tabs (Thanks @erickho123)


      Fix tab opening for "Skills" and "Kourend Tasks" (Thanks @erickho123)



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 34 replies
    • This release will:

      Fix an issue where breaks would stop firing


      Fix Combat#getWildernessLevel, use dynamic search for text and cache ID for later calls


      Fix an NPE in the Combat API


      Fix Mouse#leaveGame bug where the mouse wouldn't actually leave the game screen
      • 21 replies
    • This release will:

      Add LG support for Runelite


      Fix NPCChat issues


      Fix a bug where the camera angle setter would just hold down a key for 5 seconds (the timeout)


      Slightly adjust the rotation via keys to be more accurate


      Add the ability for asynchronous camera movement via keys


      Make Camera rotation via mouse more fluid, with more antiban, and work much better in resizable mode


      Add a "Camera#setCamera" method, allowing the rotation and angle to be set in parallel


      Increase the likelihood of using the mouse for camera movements


      Add support for adjusting the camera to positionable entities (Positionable#adjustCameraTo)



      Upcoming updates:

      Improved CLI support


      Much more



      Note: If you are using LG, please restart both the RS client and TRiBot
      • 59 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×