Jump to content
Druid

[ABCL 10!] Master Thiever AIO [Profit 300k+ per hour] [Flawless!] [Always Updated]

Recommended Posts

when thieving men it will randomly say we're under attack. Then it will run around lummy castle turn around, then run through lummy swamp. Then back, im to scared to even run this script on men anymore.

Edit: this is the worst thieving script i've ever used, it always attacks the npc's its stealing from, and can never find the right place. Total waste of 8.00$, i wouldn't ever purchase again and i warn others not to. Seems like a very high ban chance,.

Thanks, was about to purchase.

Share this post


Link to post
Share on other sites

when thieving men it will randomly say we're under attack. Then it will run around lummy castle turn around, then run through lummy swamp. Then back, im to scared to even run this script on men anymore.

Edit: this is the worst thieving script i've ever used, it always attacks the npc's its stealing from, and can never find the right place. Total waste of 8.00$, i wouldn't ever purchase again and i warn others not to. Seems like a very high ban chance,.

There is nothing in the code to attack NPCs, you've probably lagged and the client misclicked, which is totally out of my control. It will run away from the NPC if you get attacked however. I'll run a few tests and check why it's having a problem with lumby castle.

 

Otherwise it shouldn't be an issue elsewhere. 

Share this post


Link to post
Share on other sites

Druid Smart dropping isn't working. While I'm stunned script do not stop to click to pickpocket the master farmer at draynor village, "You're stunned!" is shown 4 times instead of dropping junks. Could you fix that? When I bought this scrip it was fine, but now I do not know what happened.

Thanks.

 

Share this post


Link to post
Share on other sites

There is nothing in the code to attack NPCs, you've probably lagged and the client misclicked, which is totally out of my control. It will run away from the NPC if you get attacked however. I'll run a few tests and check why it's having a problem with lumby castle.

 

Otherwise it shouldn't be an issue elsewhere. 

it misclicks on attacking them like 3/10 try's then when it does run, it takes like 5 minutes then runs back. Doesn't work AT all

Share this post


Link to post
Share on other sites

Just purchased the script, I'm probably doing something wrong but I get this error on startup

 

  • [19:22:49] Starting client.
  • [19:23:04] Downloading script 'Master Thiever AIO'.
  • [19:23:05] Script Started: Master Thiever AIO.
  • [19:23:05] Disabled all randoms.
  • [19:23:05] Please ALWAYS run tribot in lite mode!
  • [19:23:06] java.lang.ClassCastException: java.lang.Integer cannot be cast to [i
  • [19:23:06] at org.tribot.api2007.NPCs.getAll(xn:160)
  • [19:23:06] at org.tribot.api2007.NPCs.getAll(xn:134)
  • [19:23:06] at scripts.MasterThiever.rb.E(GuiNew.java:928)
  • [19:23:06] at scripts.MasterThiever.rb.(GuiNew.java:73)
  • [19:23:06] at scripts.MasterThiever.Main.E(Main.java:39)
  • [19:23:06] at scripts.MasterThiever.Main.run(Main.java:65)
  • [19:23:06] at java.lang.Thread.run(Thread.java:745)
  • [19:23:06] The version you were running was V2.1.6
  • [19:23:06] Thieving configuration:
  • [19:23:06] - None
  • [19:23:06] - null
  • [19:23:06] - null
  • [19:23:06] - null
  • [19:23:06] - []
  • [19:23:06] Script Ended: Master Thiever AIO. 

 

 

Fixed by deleting hooks.dat found in %appdata%>Roaming>.Tribot>settings>hooks.dat

Edited by Einey

Share this post


Link to post
Share on other sites

Can you please fix script mate? Trying to steal from baker's stalls and my character runs back and fourth numerous times, does not even steal. Please update script.

Sounds like something from an update might have broken. I'll take a look for you. If you could demonstrate the issue for me over Skype that would be useful :)

Share this post


Link to post
Share on other sites

@Druid As the previous poster mentioned, if it misclicks and attacks a man in Lumbridge, it will run out to the graveyard and into the swamp, to the back of the castle and to the front of the castle, and loop - about 3 times in my case.

 

Request: Keep loot over x-value, so you don't have to nitpick through every item.

Edited by MSO

Share this post


Link to post
Share on other sites

@Druid So I made a fresh account and setup the account at Lumbridge, set it on automatic and left it for the night. Almost 8 hours later, I come back to find that it only managed to get to level 14 thieving and it was stuck in the 2nd floor of Lumbridge castle in the room with the spinning wheel. It kept logging in and back out again, not even trying to get out. The door was wide open.

Share this post


Link to post
Share on other sites

the client keeps looking for the farmer in lumby , when there are 2 farmers so it goes to the chicken place keeps opening the door and keeps entering then it locks the door , it sometimes get stuck there doing that , that being said , in ardy when there are 2 farmers it keeps misclicking and attacks the other farmer and when hes under attack he goes to the gate , stops there and continue fighting the farmer

 

PS: im not saying the bot is not good , im impressed by the bot more than anything it works perfect after 38+ thief.

Share this post


Link to post
Share on other sites

@Druid Left it by itself for a few hours and came back to see that it was stuck on the 2nd floor of Lumbridge castle again. It left-clicked on the stairs on the left-side of the castle with the options-menu open and got stuck there, for what I imagine to be a long time. Also, the bot is still pick-pocketing men even at level 32 - I'm not sure if this is normal.

Edited by MSO

Share this post


Link to post
Share on other sites

@Druid Left it by itself for a few hours and came back to see that it was stuck on the 2nd floor of Lumbridge castle again. It left-clicked on the stairs on the left-side of the castle with the options-menu open and got stuck there, for what I imagine to be a long time. Also, the bot is still pick-pocketing men even at level 32 - I'm not sure if this is normal.

I'm going to take some time tomorrow to look into the issues you've raised in depth, they are not straight forward. But I promise I'll try get an update out ASAP for you. 

Edited by Druid

Share this post


Link to post
Share on other sites

It seems to be working fine with everything in Ardougne. 

 

Thieve in this order mates:

 

-Lvl 1: Lumbridge Men [suicide thieving]

-Lvl 10: Varrock Tea Stall
-Lvl 25: Warrior Woman
-Lvl 38: Draynor Master Farmer
-Lvl 38: Marvin the Master Gardener
-Lvl 38: Ardougne Master Farmer
-Lvl 40: Ardougne Guards
-Lvl 55: Knight of Ardougne
-Lvl 55: Safe Cracking [Rogue's Den]
-Lvl 65: Yanille Watchman
-Lvl 70: Ardougne Paladin
-Lvl 80: Ardougne Hero

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Please welcome our new developers, @JoeDezzy1, @erickho123, @Encoded, and @wastedbro.

      These members will be responsible for working on, maintaining, and improving TRiBot.

      This means that bug fixes and improvements will now come at a much faster pace! We're committed to providing users with the best botting experience possible!
      • 30 replies
    • This release includes:

      More 3rd party libraries for script writers to use


      Apache Commons Codec


      Apache Commons Collections


      Apache Commons Configuration


      Apache Commons IO


      Apache Commons Lang


      Apache Commons Math


      GSON


      Guava


      JFoenix




      Hint arrow API


      Game#getHintArrowX


      Game#getHintArrowY




      Fix player hooks including Player#getSkullIcon and Prayer#getPrayerIcon
      • 39 replies
    • This update includes:

      Fix broken hooks


      Fix login bot for the message "No reply from login server. Please wait 1 minute and try again."


      Fix bug relating to which bot tab is sent human input


      General#randomLong bug fix involving negative numbers


      Fix GE API



      Please note: There are still some issues with the login bot due to a change in the game mechanisms handling the login screen. We're working on a fix and will upload it when ready.
      • 37 replies
    • This release will:

      Fix key event handling issue


      Fix other event handling issue


      Fix RSServer hook


      Update world hopper to have it use OCR, thanks to Todd


      Use proper disposal of old Graphics objects


      Reformat code


      Rearrange code


      Organize code imports


      Apply around 8000 automated code refactorings


      Make preparations for Java 9


      Fix 11 various bugs


      Add more reliable debugging support


      Fix mouseEntered/Exited event dispatching bug


      Fix minimap walking bug where it opens the map


      Fix broken hooks for today's game update
      • 100 replies
    • This update will:

      Fix GE inventory item positioning bug


      Fix broken object hooks
      • 27 replies
  • Recently Browsing   0 members

    No registered users viewing this page.

×